Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Blank screen after firefox 33.0 beta update

  • 19 replies
  • 55 have this problem
  • 3 views
  • Last reply by Nitishkumar

more options

Previously everything was fine, but after the latest Beta update 33.0 when I start my browser a black screen opens instead of a normal screen. I tried to reinstall it but still the same problem. Plz help me.

Modified by cor-el

Chosen solution

Nitishkumar, please try to disable hardware acceleration in the firefox menu ≡ > options > advanced > general while in safe mode.

Read this answer in context 👍 9

All Replies (19)

more options

hello, can you try to replicate this behaviour when you launch firefox in safe mode once like described under: Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

Hey there,well I tried in safe mode,and everything is ok there,but when I restarted to normal conditions the same problem is still there,now how can I go though the menu options for troubleshooting ,when I cant even see the screen? I am attaching a screenshot what the browser looks when I open it.

more options

can you copy the troubleshooting information from about:support while you're in safe-mode and paste it as a reply into the forum? this could be really helpful, thank you...

more options

]Application Basics


Name: Firefox Version: 33.0 User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0 Multiprocess Windows: 0/1

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: Ad-Bye - For Facebook Version: 1.02 Enabled: true ID: s.alfa@idev.com

Name: Adblock Plus Version: 2.6.4 Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: avast! Online Security Version: 9.0.2021.112 Enabled: true ID: wrc@avast.com

Name: BYTubeD - Bulk YouTube video Downloader Version: 1.1.2a2 Enabled: true ID: bytubed@cs213.cse.iitk.ac.in

Name: GoPhotoIt Version: 1.6 Enabled: true ID: gophoto@gophoto.it

Name: IDM CC Version: 7.3.82 Enabled: true ID: mozilla_cc@internetdownloadmanager.com

Name: SaveFrom.net helper Version: 4.5 Enabled: true ID: helper@savefrom.net

Name: Hotspot Shield Extension Version: 3.42 Enabled: false ID: afproxy@anchorfree.com

Graphics


Adapter Drivers: vga framebuf vga256 vga64k Adapter RAM: Unknown ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 50 Enhanced Contrast: 100 Device ID: 0x0000 Direct2D Enabled: Blocked for your graphics card because of unresolved driver issues. DirectWrite Enabled: false (6.2.9200.16571) GPU #2 Active: false GPU Accelerated Windows: 0/1 Basic (OMTC) Blocked for your graphics card because of unresolved driver issues. Vendor ID: 0x0000 WebGL Renderer: Blocked for your graphics card because of unresolved driver issues. windowLayerManagerRemote: true AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.frecency_experiment: 3 browser.newtab.url: chrome://quick_start/content/index.html browser.places.smartBookmarksVersion: 7 browser.search.openintab: false browser.sessionstore.upgradeBackup.latestBuildID: 20140902214533 browser.startup.homepage_override.buildID: 20140902214533 browser.startup.homepage_override.mstone: 33.0 browser.tabs.closeButtons: 1 browser.tabs.closeWindowWithLastTab: false browser.tabs.opentabfor.middleclick: true browser.tabs.tabMinWidth: 100 browser.tabs.warnOnClose: false browser.tabs.warnOnOpen: false browser.urlbar.autoFill: false browser.urlbar.hideGoButton: false dom.mozApps.used: true extensions.lastAppVersion: 33.0 gfx.direct3d.last_used_feature_level_idx: 0 media.gmp-gmpopenh264.lastUpdate: 1410011317 media.gmp-gmpopenh264.version: 1.0 media.gmp-manager.lastCheck: 1410011314 network.cookie.prefsMigrated: true network.prefetch-next: true places.database.lastMaintenance: 1410027168 places.history.expiration.transient_current_max_pages: 104658 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true privacy.popups.showBrowserMessage: false privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1409299261

user.js Preferences


Your profile folder contains a user.js file, which includes preferences that were not created by Firefox.

Important Locked Preferences


JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.7 Version in use: 4.10.7

NSS Expected minimum version: 3.17 Basic ECC Version in use: 3.17 Basic ECC

NSSSMIME Expected minimum version: 3.17 Basic ECC Version in use: 3.17 Basic ECC

NSSSSL Expected minimum version: 3.17 Basic ECC Version in use: 3.17 Basic ECC

NSSUTIL Expected minimum version: 3.17 Version in use: 3.17

Experimental Features


more options

this is all what I could get

more options

thanks, the "GoPhotoIt 1.6" extension that you have installed is usually considered adware/malware. in safemode go to the firefox menu ≡ > addons > extensions and remove it and see if you can start firefox normally again.

afterwards run a full scan of your system with different security tools like the free version of malwarebytes and adwcleaner to make sure that adware isn't present in other places of your system as well.

Troubleshoot Firefox issues caused by malware

more options

Thanks for ur reply,i will do it tomorrow and reply u back as soon as possible

more options

well one more thing the gophotoit ext was working fine with previous versions of firefox

more options

Some added toolbar are known to cause issues. If the above does not help, open the add-ons manager and disable all toolbars.

more options

Removing gophoto it didn't help me

more options

FredMcD, I don't have any added toolbars installed

more options

Did you try a new profile?

Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.


Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then also create a new profile.


more options

Chosen Solution

Nitishkumar, please try to disable hardware acceleration in the firefox menu ≡ > options > advanced > general while in safe mode.

more options

Thank u philipp , FredMcD and cor-el for ur help,well i did reset my browser from about:support and then disabled the hardware acceleration both in safe mode and restarted my pc.This helped me getting back my firefox to normal condition

more options

Had the same problem except I had been using beta 33 since the update. I had shut down FF and was going to use the New Private Window option. The FF 33 came up with a translucent across the top and down the left side where the bookmarks would be. The working screen is black. If I got in the right place I could click on the Open Menu even if I could not see it. It worked in Safe Mode. I reinstalled, reset, wiped out all extensions and plugins were cut off with no luck. I did not try the hardware acceleration option. I even downloaded the Intel driver HD update. I think it was already using the updated version. I finally had to back up to regular FF 32 to get FF to work. Plan to try beta again. Just added this in case FF had a bad bug that took something rare to trigger the bug.

more options

After I posted above I when back and upgraded to FF beta 33. I got the same black screen. I got to the Safe Mode and cut off the Hardware Acceleration and restarted the Beta 33. It worked OK. I cut the Hardware Acceleration restarted FF and it was black screen. Cut it off and restart OK.

I even tried loading the Private Window and it worked OK with the Hardware Acceleration off. Failed if ON.

I had been using Beta 33 several days with no problem in regular or private window until it failed last night when I shut down the Reg beta 33 and tried to restart in Private Window mode.

more options

What now,if u have disabled the hardware acceleration,and it is working fine,then why are u turning it on again? Let it be as it is buddy

more options

I was just testing to see if it had reset back to working with it on since I it had worked for several days since the update instead of when I loaded the update. Also wanted to test private window. When they failed I had already decided to Let It Be if I wanted to stay with the beta version. Thanks for your help with the original poster wish I had put Beta in my search for Black Screen last night. Live and learn. Thanks again for the time you spend helping people.

more options

Your welcome buddy,i know the picture was necessary to let know the prob easily,and well i was also helped by other members out here,do thanks them too.Take care