X
Tap here to go to the mobile version of the site.

Support Forum

My firefox doesn't show icon fonts!

Posted

I use fontello.com for my web designing project. but recently it doesn't show the icon.

and the weird thing is that, its OK on my friends Firefox and just my PC has the problem.

for example this page shows icon on my friends firefox but i cant see the icons https://dl.dropboxusercontent.com/u/28793409/fontello-d3b0f38a/demo.html

this is what i see https://dl.dropboxusercontent.com/u/28793409/shot.jpg

I use fontello.com for my web designing project. but recently it doesn't show the icon. and the weird thing is that, its OK on my friends Firefox and just my PC has the problem. for example this page shows icon on my friends firefox but i cant see the icons https://dl.dropboxusercontent.com/u/28793409/fontello-d3b0f38a/demo.html this is what i see https://dl.dropboxusercontent.com/u/28793409/shot.jpg

Modified by milad

Chosen solution

If Safe Mode is good, the most likely culprits are one of your extensions or graphics driver incompatibility. To work around the second issue, you can disable Firefox's use of hardware acceleration to see whether that helps.

"3-bar" menu button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect the next time you exit and start Firefox up again.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Garena Talk Plugin
  • Google Update
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 5.1.7.17873
  • Shockwave Flash 12.0 r0
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 5.1.20513.0
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Yahoo Application State Plugin version 1.0.0.7
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448

Application

  • Firefox 31.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
  • Support URL: https://support.mozilla.org/1/firefox/31.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Anti-Banner 13.0.1.4372 (anti_banner@kaspersky.com) (Inactive)
  • Content Blocker 13.0.1.4372 (content_blocker@kaspersky.com) (Inactive)
  • IDM CC 7.3.38 (mozilla_cc@internetdownloadmanager.com) (Inactive)
  • Kaspersky URL Advisor 13.0.1.4372 (url_advisor@kaspersky.com) (Inactive)
  • Safe Money 13.0.1.4372 (online_banking@kaspersky.com) (Inactive)
  • Skype Click to Call 7.3.16540.9015 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)
  • Virtual Keyboard 13.0.1.4372 (virtual_keyboard@kaspersky.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GT 630M
  • adapterDescription2:
  • adapterDeviceID: 0x0de9
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7600.16385
  • driverDate: 10-23-2013
  • driverDate2:
  • driverVersion: 9.18.13.3165
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 630M Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 3
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140716183446
  • browser.startup.homepage_override.buildID: 20140716183446
  • browser.startup.homepage_override.mstone: 31.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 31.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
15196 solutions 137906 answers

Helpful Reply

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

You can check the gfx.downloadable_fonts.enabled pref on the about:config page and make sure that it is set to true (if necessary double-click the line to toggle its value).

Make sure that you allow pages to choose their own fonts. *Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above" You can check the <b>gfx.downloadable_fonts.enabled</b> pref on the <b>about:config</b> page and make sure that it is set to true (if necessary double-click the line to toggle its value).
seancannon 3 solutions 9 answers

This may not be an issue with Firefox. There are a number of reasons that this could be happening. Here are a few ideas to get you started:

  1. Where is this webpage hosted? Is this on a server somewhere? Or is this a local page?
  2. If on a server, are all of the paths correct in the code? (CSS and links to font files?
  3. If hosted locally, do you have ALL of the needed files on your computer? (CSS, Fonts, etc.) And are the paths correct?

Outside of those issues, I can't think of anything else that would be causing this without looking through some HTML/CSS.

This may not be an issue with Firefox. There are a number of reasons that this could be happening. Here are a few ideas to get you started: # Where is this webpage hosted? Is this on a server somewhere? Or is this a local page? # If on a server, are all of the paths correct in the code? (CSS and links to font files? # If hosted locally, do you have ALL of the needed files on your computer? (CSS, Fonts, etc.) And are the paths correct? Outside of those issues, I can't think of anything else that would be causing this without looking through some HTML/CSS.

Question owner

@cor-el : I done all that but still have the problem, i also reset Firefox but still have the problem

@cor-el : I done all that but still have the problem, i also reset Firefox but still have the problem

Question owner

@seancannon i test it local and online its OK on my friends Firefox and it just my problem.

its a test page for example that i have the problem with https://dl.dropboxusercontent.com/u/28793409/fontello-d3b0f38a/demo.html

i cant see icons , and i also put a screenshot it the question if you take a look

@seancannon i test it local and online its OK on my friends Firefox and it just my problem. its a test page for example that i have the problem with https://dl.dropboxusercontent.com/u/28793409/fontello-d3b0f38a/demo.html i cant see icons , and i also put a screenshot it the question if you take a look

Modified by milad

cor-el
  • Top 10 Contributor
  • Moderator
15196 solutions 137906 answers

What does the inspector show if you check those elements with class "icon-" in the Inspector?

You can right-click on a web page and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer). You can check the font used for selected text in the Font tab in the right pane of the Inspector or click show all fonts to see if Firefox is using the rooeen font.

You can also check the Web Console (Firefox/Tools > Web Developer) for error messages about downloading fonts.

What does the inspector show if you check those elements with class "icon-" in the Inspector? *https://developer.mozilla.org/Tools/Page_Inspector You can right-click on a web page and select "Inspect Element" to open the Inspector (Firefox/Tools > Web Developer). You can check the font used for selected text in the Font tab in the right pane of the Inspector or click show all fonts to see if Firefox is using the rooeen font. You can also check the Web Console (Firefox/Tools > Web Developer) for error messages about downloading fonts. *https://developer.mozilla.org/Tools/Web_Console

Question owner

I done it, it seems that font is not rendering. please look at screenshots.

I done it, it seems that font is not rendering. please look at screenshots.
cor-el
  • Top 10 Contributor
  • Moderator
15196 solutions 137906 answers

Did you check the Fonts tab in the right pane?

You can also check the Web Console for error messages about downloading the font file(s) like I posted above if you haven't done this yet.

Did you check the Fonts tab in the right pane? You can also check the Web Console for error messages about downloading the font file(s) like I posted above if you haven't done this yet.

Question owner

i done that console is empty with no errors.

i done that console is empty with no errors.

Modified by milad

Question owner

i have no problem in firefox safe mode ! please help to fix this problem :(

i have no problem in firefox safe mode ! please help to fix this problem :(
jscher2000
  • Top 10 Contributor
6224 solutions 51195 answers

Chosen Solution

If Safe Mode is good, the most likely culprits are one of your extensions or graphics driver incompatibility. To work around the second issue, you can disable Firefox's use of hardware acceleration to see whether that helps.

"3-bar" menu button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

This takes effect the next time you exit and start Firefox up again.

If Safe Mode is good, the most likely culprits are one of your extensions or graphics driver incompatibility. To work around the second issue, you can disable Firefox's use of hardware acceleration to see whether that helps. "3-bar" menu button (or Tools menu) > Options > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available" This takes effect the next time you exit and start Firefox up again.
jscher2000
  • Top 10 Contributor
6224 solutions 51195 answers

Firefox's Safe Mode also disables style rules you might have created in a userContent.css file, if applicable.

Firefox's Safe Mode also disables style rules you might have created in a userContent.css file, if applicable.
cor-el
  • Top 10 Contributor
  • Moderator
15196 solutions 137906 answers

Helpful Reply

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can try to disable hardware acceleration in Firefox. *Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available" You need to close and restart Firefox after toggling this setting. *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes *https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

Question owner

thank you jscher2000 it solved my problem. you made my day :D

thank you jscher2000 it solved my problem. you made my day :D