X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

HOw to delete yahoo from firefox?

Posted

When i search for something in the search box in the top of the browser it takes me to a list of items in google. When i click on the website in the search list it takes me to a website i want to view and then a second later it takes me to yahoo. This only seems to happen when i use the search bars in the browser.

Any ideas of how i can stop this?

When i search for something in the search box in the top of the browser it takes me to a list of items in google. When i click on the website in the search list it takes me to a website i want to view and then a second later it takes me to yahoo. This only seems to happen when i use the search bars in the browser. Any ideas of how i can stop this?

Chosen solution

It's hard to track that Yahoo URL, but one potential culprit is a Conduit plugin or extension (such as a "Community Toolbar" extension).

You can check your plugins and extensions on the Add-ons page. Either:

  • Command+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. For those that are not essential for the next 48 hours (most everything other than Shockwave Flash), set them to "Never Activate".

In the left column, click Extensions. For those that are not essential for the next 48 hours, click "Disable". If in double, "Disable".

You probably will need to quit and start Firefox back up before those changes take full effect. Any improvement?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Provides information about the default web browser
  • Shockwave Flash 14.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Facebook Video Calling by Skype
  • 20-20 Technologies - 20-20 3D Viewer for IKEA v5.0.94.0
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • Picasa plugin.
  • 20-20 Technologies - 20-20 3D Viewer v4.5.2.0
  • Garmin Communicator Plug-in Version 2.9.1.0
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0

More Information

srihari.k 0 solutions 3 answers

this may be because if Add-ons. Try and remove yahoo search Add=on from browser. Also check the default browser options. Hope this ans will be helpfull.

this may be because if Add-ons. Try and remove yahoo search Add=on from browser. Also check the default browser options. Hope this ans will be helpfull.
ilixandr 3 solutions 26 answers
Try resetting preferences - http://kb.mozillazine.org/Resetting_preferences - and deleting your Browsing History - https://support.mozilla.org/en-US/kb/remove-recent-browsing-search-and-download-history#w_how-do-i-clear-my-history. Let me know.
jscher2000
  • Top 10 Contributor
8760 solutions 71676 answers

Next time this happens, could you copy the address of the Yahoo results page and paste it into a reply? The URL may help identify the culprit.

Also, if the page mentions anything like "DNS Solution" please see this thread: Why does my browser goes to DNS Solution Yahoo Error when I try to navigate a specific website (thecompanystore.com).

Next time this happens, could you copy the address of the Yahoo results page and paste it into a reply? The URL may help identify the culprit. Also, if the page mentions anything like "DNS Solution" please see this thread: [https://support.mozilla.org/questions/1005874 Why does my browser goes to DNS Solution Yahoo Error when I try to navigate a specific website (thecompanystore.com)].
cor-el
  • Top 10 Contributor
  • Moderator
17530 solutions 158495 answers

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Do a malware check with several malware scanning programs on the Windows computer. Please scan with all programs because each program detects different malware. All these programs have free versions. Make sure that you update each program to get the latest version of their databases before doing a scan. *Malwarebytes' Anti-Malware:<br>http://www.malwarebytes.org/mbam.php *AdwCleaner:<br>http://www.bleepingcomputer.com/download/adwcleaner/<br>http://www.softpedia.com/get/Antivirus/Removal-Tools/AdwCleaner.shtml *SuperAntispyware:<br>http://www.superantispyware.com/ *Microsoft Safety Scanner:<br>http://www.microsoft.com/security/scanner/en-us/default.aspx *Windows Defender:<br>http://windows.microsoft.com/en-us/windows/using-defender *Spybot Search & Destroy:<br>http://www.safer-networking.org/en/index.html *Kasperky Free Security Scan:<br>http://www.kaspersky.com/security-scan You can also do a check for a rootkit infection with TDSSKiller. *Anti-rootkit utility TDSSKiller:<br>http://support.kaspersky.com/5350?el=88446 See also: *"Spyware on Windows": http://kb.mozillazine.org/Popups_not_blocked

Question owner

ok here is a link...

https://uk.search.yahoo.com/yhs/errorhandler?hspart=gt&hsimp=yhse-gt&q=related-info-hrd.appspot.com%2Fstatic%2Frelated-information-mvc-1.3.&type=769480

It comes up with DNS solution yahoo error hander, where the metal title would be.

Im on a mac and have no virus. I have deleted all yahoo bits from all preferences and done all that sort of stuff and it was fine until this happened!

ok here is a link... https://uk.search.yahoo.com/yhs/errorhandler?hspart=gt&hsimp=yhse-gt&q=related-info-hrd.appspot.com%2Fstatic%2Frelated-information-mvc-1.3.&type=769480 It comes up with DNS solution yahoo error hander, where the metal title would be. Im on a mac and have no virus. I have deleted all yahoo bits from all preferences and done all that sort of stuff and it was fine until this happened!
jscher2000
  • Top 10 Contributor
8760 solutions 71676 answers

Chosen Solution

It's hard to track that Yahoo URL, but one potential culprit is a Conduit plugin or extension (such as a "Community Toolbar" extension).

You can check your plugins and extensions on the Add-ons page. Either:

  • Command+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. For those that are not essential for the next 48 hours (most everything other than Shockwave Flash), set them to "Never Activate".

In the left column, click Extensions. For those that are not essential for the next 48 hours, click "Disable". If in double, "Disable".

You probably will need to quit and start Firefox back up before those changes take full effect. Any improvement?

It's hard to track that Yahoo URL, but one potential culprit is a Conduit plugin or extension (such as a "Community Toolbar" extension). You can check your plugins and extensions on the Add-ons page. Either: * Command+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. For those that are not essential for the next 48 hours (most everything other than Shockwave Flash), set them to "Never Activate". In the left column, click Extensions. For those that are not essential for the next 48 hours, click "Disable". If in double, "Disable". You probably will need to quit and start Firefox back up before those changes take full effect. Any improvement?

Question owner

Thanks Jscher2000,

Your post on the other topic help, i clicked on the "learn" link at the top and it took me to a page to help point it out. But i found a plugin i thought i had deleted before "spigot". Removed that and its happy days again!!

cheers for the pointers

Thanks Jscher2000, Your post on the other topic help, i clicked on the "learn" link at the top and it took me to a page to help point it out. But i found a plugin i thought i had deleted before "spigot". Removed that and its happy days again!! cheers for the pointers
ukrkoz 0 solutions 18 answers

hairyhobo said

When i search for something in the search box in the top of the browser it takes me to a list of items in google. When i click on the website in the search list it takes me to a website i want to view and then a second later it takes me to yahoo. This only seems to happen when i use the search bars in the browser. Any ideas of how i can stop this?

OK, so I reset my PC to out the box state and re installed windows. W7. IE from the get go had Yahoo in it. Downloaded latest FF - came with Yahoo too. Home page, everything was set to Yahoo. OK, went into ad ons and removed Yahoo toolbar, Yahoo Persona, and Yahoo in extensions. Rest home page to Google. Removed all search engines except Google. The very moment I search for anything in search bar, it automatically brings me to Yahoo search page. What else needs to be done to rid of Yahoo? Please, do consider that not everyone is s/w engineer and developer, hence, layman English is appreciated. Thank you

''hairyhobo [[#question-1015866|said]]'' <blockquote> When i search for something in the search box in the top of the browser it takes me to a list of items in google. When i click on the website in the search list it takes me to a website i want to view and then a second later it takes me to yahoo. This only seems to happen when i use the search bars in the browser. Any ideas of how i can stop this? </blockquote> OK, so I reset my PC to out the box state and re installed windows. W7. IE from the get go had Yahoo in it. Downloaded latest FF - came with Yahoo too. Home page, everything was set to Yahoo. OK, went into ad ons and removed Yahoo toolbar, Yahoo Persona, and Yahoo in extensions. Rest home page to Google. Removed all search engines except Google. The very moment I search for anything in search bar, it automatically brings me to Yahoo search page. What else needs to be done to rid of Yahoo? Please, do consider that not everyone is s/w engineer and developer, hence, layman English is appreciated. Thank you
jscher2000
  • Top 10 Contributor
8760 solutions 71676 answers

Hi ukrkoz, first, could you double-check your default search engine? When you starting typing into the search bar (not address bar) of Firefox 34, a panel should drop down showing at the top the icon of the search engine that will be used. Is it Google? If that's not correct, use the Change Search Settings item at the bottom of the panel. (If you use a version older than Firefox 34, you should see the white-on-blue "g" at the left end of the search bar.)

If that is set to Google but you still get Yahoo results, could you double-check your other extensions. Some extensions have paid affiliate deals with search engines. I suggest disabling ALL nonessential or unrecognized extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then, if in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Does that help at all?

Hi ukrkoz, first, could you double-check your default search engine? When you starting typing into the ''search bar'' (not address bar) of Firefox 34, a panel should drop down showing at the top the icon of the search engine that will be used. Is it Google? If that's not correct, use the Change Search Settings item at the bottom of the panel. (If you use a version older than Firefox 34, you should see the white-on-blue "g" at the left end of the search bar.) If that is set to Google but you still get Yahoo results, could you double-check your other extensions. Some extensions have paid affiliate deals with search engines. I suggest disabling ALL nonessential or unrecognized extensions on the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then, if in doubt, disable. Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Does that help at all?
ukrkoz 0 solutions 18 answers

Thank you. I had it all deleted or disabled. This is my Tools>Search: [URL=http://s302.photobucket.com/user/ukrkoz/media/Captureengines_zpsaf45c594.png.html][IMG]http://i302.photobucket.com/albums/nn101/ukrkoz/Captureengines_zpsaf45c594.png/IMG/URL

And if typed from the UPPER RIGHT search bar, it now works fine and goes through Google.

But, if search is attempted from the center, Google home page search bar - it goes to Yahoo search again. See, thing is, right after I downloaded FF latest version today and installed it, it CAME with Yahoo everything. Like as if it was pre-packaged with it off FF main site:

[URL=http://s302.photobucket.com/user/ukrkoz/media/Captureyahoo_zps3bd583fe.png.html][IMG]http://i302.photobucket.com/albums/nn101/ukrkoz/Captureyahoo_zps3bd583fe.png/IMG/URL

Actually, it IS Firefox problem. Come to find, it's "Yahoo edition". Bastards.

[URL=http://s302.photobucket.com/user/ukrkoz/media/FFyahooedition_zps016e47b9.png.html][IMG]http://i302.photobucket.com/albums/nn101/ukrkoz/FFyahooedition_zps016e47b9.png/IMG/URL

Thank you. I had it all deleted or disabled. This is my Tools>Search: [URL=http://s302.photobucket.com/user/ukrkoz/media/Captureengines_zpsaf45c594.png.html][IMG]http://i302.photobucket.com/albums/nn101/ukrkoz/Captureengines_zpsaf45c594.png[/IMG][/URL] And if typed from the UPPER RIGHT search bar, it now works fine and goes through Google. But, if search is attempted from the center, Google home page search bar - it goes to Yahoo search again. See, thing is, right after I downloaded FF latest version today and installed it, it CAME with Yahoo everything. Like as if it was pre-packaged with it off FF main site: [URL=http://s302.photobucket.com/user/ukrkoz/media/Captureyahoo_zps3bd583fe.png.html][IMG]http://i302.photobucket.com/albums/nn101/ukrkoz/Captureyahoo_zps3bd583fe.png[/IMG][/URL] Actually, it IS Firefox problem. Come to find, it's "Yahoo edition". Bastards. [URL=http://s302.photobucket.com/user/ukrkoz/media/FFyahooedition_zps016e47b9.png.html][IMG]http://i302.photobucket.com/albums/nn101/ukrkoz/FFyahooedition_zps016e47b9.png[/IMG][/URL]
jscher2000
  • Top 10 Contributor
8760 solutions 71676 answers

Hi ukrkoz, I believe the Yahoo edition is only distributed directly by Yahoo. To get the normal Firefox, try this Clean Reinstall procedure:

(1) Download a fresh installer for Firefox 34 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox.

(3) Rename the program folder

(32-bit Windows folder names)

C:\Program Files\Mozilla Firefox

to

C:\Program Files\OldFirefox

(64-bit Windows folder names)

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

Then you can start Firefox up again (and restore your earlier session using the History menu, if applicable) and test.

Does that fix it?

Note: Some recently installed plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
Hi ukrkoz, I believe the Yahoo edition is only distributed directly by Yahoo. To get the normal Firefox, try this Clean Reinstall procedure: (1) Download a fresh installer for Firefox 34 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) (2) Exit out of Firefox. (3) Rename the program folder ''(32-bit Windows folder names)'' C:\Program Files\Mozilla Firefox to C:\Program Files\OldFirefox ''(64-bit Windows folder names)'' C:\Program Files (x86)\Mozilla Firefox to C:\Program Files (x86)\OldFirefox (4) Run the installer you downloaded in #1. It should automatically connect to your existing settings. Then you can start Firefox up again (and restore your earlier session using the History menu, if applicable) and test. Does that fix it? Note: Some recently installed plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders: * \OldFirefox\Plugins * \OldFirefox\browser\plugins
cor-el
  • Top 10 Contributor
  • Moderator
17530 solutions 158495 answers

You seem to have a special branded Yahoo Firefox version.

Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.

If you keep having problems then also create a new profile.


You seem to have a special branded Yahoo Firefox version. Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release. *Download the full Firefox installer and save the file to the desktop<br>https://www.mozilla.org/en-US/firefox/all/ If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software. *Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions. Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer. *(32 bit Windows) "C:\Program Files\Mozilla Firefox\" *(64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\" *It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling. *http://kb.mozillazine.org/Uninstalling_Firefox Your bookmarks and other personal data are stored in the Firefox profile folder and won't be affected by an uninstall and (re)install, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data. If you keep having problems then also create a new profile. ---- *http://kb.mozillazine.org/Profile_folder_-_Firefox *http://kb.mozillazine.org/Profile_backup *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Clean_reinstall
ukrkoz 0 solutions 18 answers

Well, whatever it was it was downloaded off MOZILLA original site. Instead of going through the 25 step dance of renaming this and that I simply un installed the branded one and installed the older 31. something version. All good. FF must 5hen be in kahutz with Yahoo by allowing this. Shame.

Well, whatever it was it was downloaded off MOZILLA original site. Instead of going through the 25 step dance of renaming this and that I simply un installed the branded one and installed the older 31. something version. All good. FF must 5hen be in kahutz with Yahoo by allowing this. Shame.
jscher2000
  • Top 10 Contributor
8760 solutions 71676 answers

Hi ukrkoz, can you check your browser history for the exact download URL? If there is a problem with one of the download mirror sites we should report it.

Hi ukrkoz, can you check your browser history for the exact download URL? If there is a problem with one of the download mirror sites we should report it.
drumgas 0 solutions 4 answers

hairyhobo said

When i search for something in the search box in the top of the browser it takes me to a list of items in google. When i click on the website in the search list it takes me to a website i want to view and then a second later it takes me to yahoo. This only seems to happen when i use the search bars in the browser. Any ideas of how i can stop this?
''hairyhobo [[#question-1015866|said]]'' <blockquote> When i search for something in the search box in the top of the browser it takes me to a list of items in google. When i click on the website in the search list it takes me to a website i want to view and then a second later it takes me to yahoo. This only seems to happen when i use the search bars in the browser. Any ideas of how i can stop this? </blockquote>
drumgas 0 solutions 4 answers

I found clicking on the button up in the far right hand corner of the browser, then selecting options , select the Search tab, and set your default browser there. You can also uncheck the others that you do not wish to use. I did restart my computer then to make sure it was holding the changes. Seemed to work for me. Hope this helps

I found clicking on the button up in the far right hand corner of the browser, then selecting options , select the Search tab, and set your default browser there. You can also uncheck the others that you do not wish to use. I did restart my computer then to make sure it was holding the changes. Seemed to work for me. Hope this helps
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 solutions 40231 answers

The Search Bar was changed in Firefox 34 (and later versions) - so please read about how the new Search Bar works.

https://support.mozilla.org/en-US/kb/search-bar-add-change-manage-search-engines-firefox


locking this older, Solved thread as the information posted here is out of date for current issues with the Search Bar

The Search Bar was changed in Firefox 34 ''(and later versions)'' - so please read about how the new Search Bar works. https://support.mozilla.org/en-US/kb/search-bar-add-change-manage-search-engines-firefox ''locking this older, Solved thread as the information posted here is out of date for current issues with the Search Bar''