Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox 31 blocked by webroot b/c it downloads irfanviewerset and freefileviewersetup, unasked, on startup. Why? &

  • 8 replies
  • 2 have this problem
  • Last reply by hmarcuse

more options

Each time I start firefox 31.0 on Win 7 it tries to download 2 setup.exe programs, unsuccessfully. When I next restart ffx it won't connect to the internet (all other programs/browsers will, however). I found that my anti-virus, Webroot,'s firewall is blocking it. I can turn that firewall off, restart ffx, and it will work again, even after I turn webroot's firewall back on. But once I restart ffx, same deal, can't connect. And I see the telescoping download arrow that it tried to download something--in the download list the two programs are there again: irfanviewersetup-9957237.exe and freefileviewersetup.exe. Is no one else having this occur (do I have a unique bug)? Why would firefox try to download these files in the background when I open it? (The homepage is set to Please help!

All Replies (8)

more options


Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

More information about reinstalling Firefox can be found here.

WARNING:Do not use a third party uninstaller as part of this process. Doing so could permanently delete your Firefox profile data, including but not limited to, extensions, cache, cookies, bookmarks, personal settings and saved passwords. These cannot be easily recovered unless they have been backed up to an external device! See Back up and restore information in Firefox profiles.

Please report back to say if this helped you!

Thank you.

more options

Perhaps they were downloads you had going before and the downloads had not completed and are simply trying to resume the next time you start Firefox. You could try canceling and removing them.

Firefox from does not try to download any applications including these two.

more options

Some web pages can download to you without your consent. Always be on the alert!

It could be the work of one of your add-ons, or even add / mal-ware. Look thru your add-ons list and make sure you know what each one is and what it does. Also, check the programs that are on your computer

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder Linux: options depends on the package manager and the desktop environment

Go thru the list. If you find something that you don't know what it is, use a web search.

Troubleshoot Firefox Issues Caused By Malware {web link}

Modified by James

more options

I tried all of this, several times, to no avail. Here was my final procedure:

0a. uninstalled programs in Windows 7 that I didn't know or use 0b. deactivated most plugins in firefox 0c. In order to see whether my own plugins/settings were the problem, I went into ffx's Help > Troubleshooting & (tried to) Reset firefox (this hung: after 1/2 hour I canceled it and had to restart my computer in order for the uninstall to run, since it thought ffx was still running, even tho the task manager said it wasn't)

1. uninstalled ffx 2. delete the mozilla folders from program files x86 3. run ccleaner (installed newest version) 4. run antimalwarebytes (updated) 5. reboot computer 6. reinstall ffx (31.0) 7. start using it -- problem reappeared

What I haven't yet tried is where (or whether) the problem occurred in the reimportation of my booksmarks toolbar and starting to use websites. What surprised me was that the plugins were all back and set to "ask to activate".

I'll try the whole business again, and try to see whether I can tell exactly when the problem comes up, but have 2 additional questions:

1. Why can't I do the Reset of ffx--why does it hang (tried 4 times, waited about 40 mins on final time). Or does it need even more time?

2. if plugins may be the problem, isn't there a simple way to uninstall them? The help page says I have to go to each plugin's website to get the uninstaller.

more options

Plugins are programs that Firefox finds on your computer. For example, flash, some anti-virus, Win Silver Light, and others. Unless you remove that program, all you can do is Disable it in the Add-ons Manager.

Did you get any error or crash reports? Post them here.

When you remove the main Firefox program, your user profile is left in your user folder.

I want to try this, create a new profile. After, see if there is a problem. Use the Profile Manager to create and remove Firefox profiles Firefox stores your personal information and settings in a profile folder. Learn to use the Profile Manager to create, remove, rename, and switch profiles.

more options

Hi FredMcD, thanks for your suggestion.

No error or crash reports. Ok, disabled all add-on (safe mode), created new profile tmpAug20ffx and set to start automatically in that profile without asking, reset firefox (it worked fairly quickly now, maybe I hadn't been waiting long enough and now all stuff is already cleared out?), uninstalled firefox. No mozilla folder found in Programs x86 directory this time.

Reinstalled firefox. And the problem is still there. I no longer see ffx trying automatically to download any files however (no telescoping download arrow, nothing in download history). And it is clear that it is a conflict with webroot's firewall. If I disable the firewall And restart firefox, I can access the internet. I can reenable the firewall and ffx will continue to access the internet. But any time I start ffx with the webroot firewall on: no internet access (but all other programs access internet just fine).

I disable webroot's firewall still no access until I restart ffx, then just fine, also after reenabling firewall. But anytime I start ffx with firewall on, no access. I can't believe I'm the only one having this issue.

more options

Open the settings for webroot's firewall. See if Firefox is listed. If it is, remove those rules. Then try again.

Some problems occurs when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted.

more options

In webroot firewall only relevant setting is "Automatically Protect Newly Installed Browsers". I unchecked this, rebooted computer, checked that it was still unchecked, yes. Start firefox: still conflict. Uninstalled ffx. (did not reboot since I'm typing here) firefox won't connect to internet. webroot: turn firewall off, ffx still won't connect (timeout error) restart ffx, firefox connects right away turn on webroot firewall, ffx still connects shut down ffx, webroot firewall still on, firefox won't connect "The connection has timed out" Thanks for still trying.