Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

PDF files downloading as html files

  • 6 replies
  • 71 have this problem
  • 1 view
  • Last reply by cor-el

more options

I am trying to save pdf files from a database but firefox keeps on saving them as html files instead, even when saving it shows it saving as *.pdf. I have only just fixed the problem of not being able to open the pdf files and now using adobe reader add on but now can't save the files I have opened. I need to be able to access these documents when not online. Instead of studying for the last 3 hours I have been trying to solve issues since downloading the lastest version of firefox. This was never an issue with the older version.

All Replies (6)

more options

In the Adobe Acrobat plugin, if you mouse toward the bottom of the PDF, a floating toolbar should appear with a save icon. Alternately, if you press the Esc key once, a toolbar should appear above the document.

For the built-in PDF reader, the toolbar is displayed at all times, the the relevant button is the Download arrow button.


Regarding the files you already saved: is the problem with the file name or with the file contents?

If it's the extension, you probably have tried renaming a saved file from filename.html to filename.pdf to see whether it can be opened by Adobe Reader. (Note: you may need to switch off hiding of file extensions in order to rename files. See http://windows.microsoft.com/en-us/wi.../show-hide-file-name-extensions.)

If it's the file content, when you open it in Firefox, what does it look like?

more options

I am having a similar problem. When I save a Word Doc. to PDF it saves it a Firefox extension.

When I click on the file that I have saved. It tries to open in my browser and it keeps opening tabs automatically, one right after the other. I have to open task manager and end the process because it will continue opening tabs.

This problem seemed to have started after I updated FF with the latest update. I can't reinstall or I will lose my Bookmark Tabs.

Any Idea what is going on?

more options

Hi lqdolls, I believe you have a different issue. Firefox 31 was designed to take over as the viewer for PDF files if there wasn't another viewer installed on the system, but some users are reporting that it took them over partly or fully even if another viewer already was assigned.

Do you run Windows? Could you try the steps in this (randomly Googled) article to make Adobe Reader or Adobe Acrobat your default once again: http://www.csu.edu.au/division/dit/services/faqs/PDF_Files/make-adobe-reader-default-viewer.pdf (for Windows XP; there's a completely different way for Vista/7/8)

more options

This did not remedy my problem.

Modified by WinchesterBunnyMama

more options

Hi WinchesterBunnyMama, what exactly is your problem. Is it this issue:

Some users are finding that an update changed the description of "Adobe Acrobat Document" to "Firefox HTML Document". The installer was supposed to add Firefox as an ADDITIONAL viewer for PDFs, not as the DEFAULT viewer. Sorry if you were affected by this glitch and hopefully they will figure out why some systems get changed this way.

You can try this fix suggested by a user in another thread:

  1. Open Adobe Reader / Acrobat*
  2. Edit->Preferences
  3. In the Categories column click 'General'
  4. Near the bottom of the page click the button marked 'Select Default PDF Handler'
  5. In the dialog, select 'Adobe Reader XI' (or Adobe Acrobat, as the case may be) and click 'Apply'
  6. A Windows Configuration screen will appear. Allow it to do its stuff (takes a few minutes), then restart your computer when prompted.

Does that work for you?

* If you do not have Adobe Reader 11, you can install it from here: http://get.adobe.com/reader/

more options

Try to rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

You can use this button to go to the currently used Firefox profile folder: