X
Tap here to go to the mobile version of the site.

Support Forum

Can't establish connection to localhost

Posted

Hi There,

As of today I seem to be having a strange issue with Firefox 31, I'm unsure as to when this problem began as I haven't developed on this project for around 2 weeks. I have a PHP Development server running on localhost port 8000 using the following command: "bin\php -S localhost:8000 -c php.ini" (without quotes)

Upon trying to connect to this server via Firefox I'm presented with "Firefox can't establish a connection to the server at 127.0.0.1:8000." the message adjusts to show "localhost:8000" when connecting via that method, I've tried running Firefox in Safe Mode, reinstalling Firefox and also changing the network settings to "No Proxy" from "Using system proxy settings".

I'm able to connect through Chrome, IE and also by running a cURL command.

Hi There, As of today I seem to be having a strange issue with Firefox 31, I'm unsure as to when this problem began as I haven't developed on this project for around 2 weeks. I have a PHP Development server running on localhost port 8000 using the following command: "bin\php -S localhost:8000 -c php.ini" (without quotes) Upon trying to connect to this server via Firefox I'm presented with "Firefox can't establish a connection to the server at 127.0.0.1:8000." the message adjusts to show "localhost:8000" when connecting via that method, I've tried running Firefox in Safe Mode, reinstalling Firefox and also changing the network settings to "No Proxy" from "Using system proxy settings". I'm able to connect through Chrome, IE and also by running a cURL command.

Modified by Rewt0r

Chosen solution

Hi guis2,

Referring back to the page you linked to, it seems that the IPv6 section applied to my issue somewhat. For some reason network.dns.disableIPv6 was already set to true however once I set this to false localhost:8000 began to work.

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • 5.1.30214.0
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components

Application

  • Firefox 31.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0
  • Support URL: https://support.mozilla.org/1/firefox/31.0/WINNT/en-GB/

Extensions

  • 1-Click YouTube Video Downloader 2.3.3 (YoutubeDownloader@PeterOlayev.com)
  • Adblock Plus 2.6.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • ColorZilla 2.8 ({6AC85730-7D0F-4de0-B3FA-21142DD85326})
  • DownThemAll! 3.0b5 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Firebug 2.0.2 (firebug@software.joehewitt.com)
  • FireRainbow 1.5 (firerainbow@hildebrand.cz)
  • Flagfox 5.0.5 ({1018e4d6-728f-4b20-ad56-37578a4de76b})
  • Personas Plus 1.7.3 (personas@christopher.beard)
  • Screengrab (fix version) 0.97.25c ({02450914-cdd9-410f-b1da-db004e18c671})
  • The easiest Xdebug 2.0 (jid1-fQpPMP6uBdJNCg@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Wappalyzer 3.0.11 (wappalyzer@crunchlabz.com)
  • Web Developer 1.2.5 ({c45c406e-ab73-11d8-be73-000a95be3b12})
  • ProxTube - Unblock YouTube 1.5.5 (ich@maltegoetz.de) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 200
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.17111
  • driverDate: 5-16-2014
  • driverDate2:
  • driverVersion: 10.18.10.3621
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.frecency_experiment: 3
  • browser.cache.memory.capacity: 65536
  • browser.display.show_image_placeholders: True
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140716183446
  • browser.startup.homepage_override.buildID: 20140716183446
  • browser.startup.homepage_override.mstone: 31.0
  • browser.urlbar.autocomplete.enabled: True
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 31.0
  • font.internaluseonly.changed: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • network.dns.disableIPv6: True
  • network.dnsCacheEntries: 20
  • network.http.connect.timeout: 30
  • network.http.keep-alive: True
  • network.http.keep-alive.timeout: 300
  • network.http.max-connections: 48
  • network.http.max-connections-per-server: 16
  • network.http.max-persistent-connections-per-proxy: 16
  • network.http.max-persistent-connections-per-server: 8
  • network.http.pipelining.maxrequests: 8
  • network.http.proxy.keep-alive: True
  • network.http.request.max-start-delay: 0
  • places.database.lastMaintenance: 1406059002
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.expose_full_path: True
  • plugin.importedState: True
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.offlineApps: True
  • privacy.cpd.sessions: False
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.dta_queue.sqlite: 1404937932
  • storage.vacuum.last.index: 2
  • storage.vacuum.last.places.sqlite: 1403900797

Misc

  • User JS: Yes
  • Accessibility: No
guigs
  • Top 25 Contributor
  • Administrator
  • Moderator
1070 solutions 11652 answers

This may help check out: [about:networking] In the developer toolbar you can see if there is a cookie with local host stored as well with : cookie list And please also try these steps: Firefox can't load websites but other browsers can

This may help check out: [about:networking] In the developer toolbar you can see if there is a cookie with local host stored as well with : cookie list And please also try these steps: [[Firefox can't load websites but other browsers can]]

Question owner

Hi guigs2,

about:networking gives no more information than I already know, after navigating to "localhost:8000" there's an entry in the DNS tab:

Hostname Family Addresses Expires (Seconds) localhost ipv4 127.0.0.1 46

Http Tab Hostname Port SPDY SSL Active Idle localhost 8000 false false 0 0

I've already cleared my cache and cookies and as a result "cookie list" produces "No cookies found for host localhost:8000"

I've already taken the steps in the link you provided (refer to original post), changing proxy settings has no effect, reinstalling has no effect, running firefox in safemode has no effect, firefox is allowed in the Windows firewall (not that this would make a difference since it's localhost)

Hi guigs2, about:networking gives no more information than I already know, after navigating to "localhost:8000" there's an entry in the DNS tab: Hostname Family Addresses Expires (Seconds) localhost ipv4 127.0.0.1 46 Http Tab Hostname Port SPDY SSL Active Idle localhost 8000 false false 0 0 I've already cleared my cache and cookies and as a result "cookie list" produces "No cookies found for host localhost:8000" I've already taken the steps in the link you provided (refer to original post), changing proxy settings has no effect, reinstalling has no effect, running firefox in safemode has no effect, firefox is allowed in the Windows firewall (not that this would make a difference since it's localhost)

Chosen Solution

Hi guis2,

Referring back to the page you linked to, it seems that the IPv6 section applied to my issue somewhat. For some reason network.dns.disableIPv6 was already set to true however once I set this to false localhost:8000 began to work.

Hi guis2, Referring back to the page you linked to, it seems that the IPv6 section applied to my issue somewhat. For some reason network.dns.disableIPv6 was already set to '''true''' however once I set this to '''false''' localhost:8000 began to work.