X
Tap here to go to the mobile version of the site.

Support Forum

Firefox can't open any Microsoft link - get "windows stopped working error"

Posted

When I try to open a Microsoft Word or xls file (not Powerpoint), I get the useless Microsoft popup: "Microsoft X has stop working. Windows is looking for a solution....". This just started the other day and I haven't made any changes to my computer. I don't know if this an Office or Firefox issue. It happens on multiple website/programs in Firefox.

When I try to open a Microsoft Word or xls file (not Powerpoint), I get the useless Microsoft popup: "Microsoft X has stop working. Windows is looking for a solution....". This just started the other day and I haven't made any changes to my computer. I don't know if this an Office or Firefox issue. It happens on multiple website/programs in Firefox.

Modified by kimski

Chosen solution

Moses and jscher2000,

I figured out what happened with not being able to open Word or Excel inside Firefox. We run Firefox from inside Sandboxie (virtual browser) and once I cleaned it out (from all the crap people try to install on my computer) I no longer have the problem.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • Google Update
  • Next Generation Java Plug-in 10.60.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.30214.0
  • Used to make VSee installation status and version number accessible via JavaScript
  • Coupons, Inc. Coupon Printer 4.0.2.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0

More Information

jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Firefox 30 switched many plugins from running on any site automatically to requiring your permission to run. In case the Office plugin is not compatible with this setting, you could try switching it back to see whether that helps.

Open the Add-ons page using either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. Look for the Office plugin(s) and change "Ask to Activate" to "Always Activate".

You might need to create a new window or exit and start Firefox up again before this takes effect. (This varies between plugins.)

Any improvement?

Firefox 30 switched many plugins from running on any site automatically to requiring your permission to run. In case the Office plugin is not compatible with this setting, you could try switching it back to see whether that helps. Open the Add-ons page using either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Plugins. Look for the Office plugin(s) and change "Ask to Activate" to "Always Activate". You might need to create a new window or exit and start Firefox up again before this takes effect. (This varies between plugins.) Any improvement?

Question owner

No, unfortunately it did not. Something changed in the last few days without my doing yet I've done no updates. I can download the files and then open them outside of Firefox but launching Word or Excel from within Firefox isn't working.

No, unfortunately it did not. Something changed in the last few days without my doing yet I've done no updates. I can download the files and then open them outside of Firefox but launching Word or Excel from within Firefox isn't working.
jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

Just to clarify, when you get the dialog to Open, Save, or Cancel, are the results as follows:

  • Open : Office application doesn't load successfully
  • Save : Office application can open the file after it is saved

The "Open" option uses the Windows temp folder. That folder can become congested; you may want to clear it at some point if you haven't already tried that.

Just to clarify, when you get the dialog to Open, Save, or Cancel, are the results as follows: * Open : Office application doesn't load successfully * Save : Office application can open the file after it is saved The "Open" option uses the Windows temp folder. That folder can become congested; you may want to clear it at some point if you haven't already tried that.

Question owner

Yes, both. I can save without any problem but if I choose to open it goes right into that useless window popup that says "Microsoft [X] stopped working. Windows is looking for a solution" and then after 5 seconds of "trying" it just closes and I'm left empty handed-no solution and the file doesn't open. Again it only happens with word and Excel, not PP or pdf which is very odd to me.

I cleaned out Windows/temp but no change.

Yes, both. I can save without any problem but if I choose to open it goes right into that useless window popup that says "Microsoft [X] stopped working. Windows is looking for a solution" and then after 5 seconds of "trying" it just closes and I'm left empty handed-no solution and the file doesn't open. Again it only happens with word and Excel, not PP or pdf which is very odd to me. I cleaned out Windows/temp but no change.

Modified by kimski

Question owner

Would love to get some more ideas. I also think I have profile issues because occasionally when I try to upload a file (through various ways), the browser crashes.

Would love to get some more ideas. I also think I have profile issues because occasionally when I try to upload a file (through various ways), the browser crashes.
cor-el
  • Top 10 Contributor
  • Moderator
17467 solutions 157838 answers

Note that you usually open files in read-only mode that way and you should never modify such a file and save it under the same name to avoid dataloss.

It is possible that security (anti-virus) software is blocking the file, so you may have to check that.

Note that you usually open files in read-only mode that way and you should never modify such a file and save it under the same name to avoid dataloss. It is possible that security (anti-virus) software is blocking the file, so you may have to check that.

Question owner

My issue has nothing to do with read only. Firefox can no longer open Word or Excel files so I can't get these files from websites unless I save it locally and open it outside Firefox. Until last week I could choose to open it from the popup box inside Firefox. There have been no system changes so firewall, anti-virus, etc is not the issue. Firefox can open Powerpoint and pdf files just fine.

My issue has nothing to do with read only. Firefox can no longer open Word or Excel files so I can't get these files from websites unless I save it locally and open it outside Firefox. Until last week I could choose to open it from the popup box inside Firefox. There have been no system changes so firewall, anti-virus, etc is not the issue. Firefox can open Powerpoint and pdf files just fine.
jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

It's puzzling, because it's hard to think of a reason for two particular files types not to load in their corresponding external application when others do. As far as I know, the "hand-off" is the same.

Firefox learns the hand-off from the Windows registry. If something has changed with the shell commands for Word and Excel, Firefox might not have gotten the memo, or perhaps it has become garbled. You can clear Firefox's download action settings file and have it re-read the registry. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information

In the first table on the page, click the "Show Folder" button

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • File menu > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Start Firefox back up again. Any improvement?

Note: This will clear any preferences you changed on the "Applications" section of the Options dialog, such as your preferred PDF viewer. Those will need to be set again.

It's puzzling, because it's hard to think of a reason for two particular files types not to load in their corresponding external application when others do. As far as I know, the "hand-off" is the same. Firefox learns the hand-off from the Windows registry. If something has changed with the shell commands for Word and Excel, Firefox might not have gotten the memo, or perhaps it has become garbled. You can clear Firefox's download action settings file and have it re-read the registry. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * Help menu > Troubleshooting Information In the first table on the page, click the "Show Folder" button Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * File menu > Exit Pause while Firefox finishes its cleanup, then rename '''mimeTypes.rdf''' to something like mimeTypes.old Start Firefox back up again. Any improvement? Note: This will clear any preferences you changed on the "Applications" section of the Options dialog, such as your preferred PDF viewer. Those will need to be set again.

Question owner

That didn't help although the idea sounded good.

PS after renaming the mimestype file I had the same Windows error for any Office files I tried to open OUTSIDE of Firefox. I assumed that file was only in use in Firefox. Anyway the new one that was supposedly created was a problem. I had to delete the new one and rename the old to be able to open files again. I don't know if that was expected or not.

That didn't help although the idea sounded good. PS after renaming the mimestype file I had the same Windows error for any Office files I tried to open OUTSIDE of Firefox. I assumed that file was only in use in Firefox. Anyway the new one that was supposedly created was a problem. I had to delete the new one and rename the old to be able to open files again. I don't know if that was expected or not.

Modified by kimski

jscher2000
  • Top 10 Contributor
8684 solutions 70998 answers

As far as I know, neither Windows nor Office reads mimeTypes.rdf. I really can't explain what's going on.

As far as I know, neither Windows nor Office reads mimeTypes.rdf. I really can't explain what's going on.

Question owner

Thanks for trying.

Thanks for trying.
Moses
  • Moderator
459 solutions 3607 answers

I don't have a solution either but I've marked this thread as 'escalate' so someone from the Help Desk team can get to you.

I don't have a solution either but I've marked this thread as 'escalate' so someone from the Help Desk team can get to you.

Question owner

Thank you so much.

Do you have any ideas as to why Firefox sometimes crashes when I try to upload a file (attach to email or upload to Canvas)? That's another issue I've been having. I did the reset option to try to fix this issue above but it didn't fix either.

Thank you so much. Do you have any ideas as to why Firefox sometimes crashes when I try to upload a file (attach to email or upload to Canvas)? That's another issue I've been having. I did the reset option to try to fix this issue above but it didn't fix either.
guigs 1072 solutions 11697 answers

Office Authorization plug-in for NPAPI browsers is a plugin to provide support for Office Web Apps which is basically Microsoft’s version of Google Docs. If you use Office Web Apps, then you will need to keep the plugin enabled, otherwise you can disable it.

I think it is referring to this plugin http://msdn.microsoft.com/en-us/libra.../ff407576%28v=office.14%29.aspx which is the plugin related to the steps you have described your issue, opening Microsoft Office files from Firefox.

I can recommend updating or reinstalling that plugin to see if the issue persists. However since you have tried to disable the plugin and have created a new file that stores the "Application" actions for the profile and have also seen it cause a crash in Microsoft, but you said it crashed do you have some crash reports we can take alook at to see if its not a memory issue? Firefox crashes - Troubleshoot, prevent and get help fixing crashes

Office Authorization plug-in for NPAPI browsers is a plugin to provide support for Office Web Apps which is basically Microsoft’s version of Google Docs. If you use Office Web Apps, then you will need to keep the plugin enabled, otherwise you can disable it. I think it is referring to this plugin [http://msdn.microsoft.com/en-us/library/ff407576%28v=office.14%29.aspx] which is the plugin related to the steps you have described your issue, opening Microsoft Office files from Firefox. I can recommend updating or reinstalling that plugin to see if the issue persists. However since you have tried to disable the plugin and have created a new file that stores the "Application" actions for the profile and have also seen it cause a crash in Microsoft, but you said it crashed do you have some crash reports we can take alook at to see if its not a memory issue? [[Firefox crashes - Troubleshoot, prevent and get help fixing crashes]]

Question owner

I don't have that dll. I have 2 plugins for that purpose. Both are "Microsoft Office 2010" with one being 14.0.4761.1000 that says its for allowing the opening of Office apps. The other is 14.0.4730.1010 which is for authorizing the plug-in for NPAPI but since I don't have that dll that probably isn't working. Firefox doesn't know the first one so I can't update it. I've tried to update the adobe and java that are out of date but your update link sends me to the release notes but that's it so nothing gets updated (what's with that?).

As for the crash report, are you asking in regards to my second question? If so I got to the list of reports. When I did the whole "appdata" path with the Windows+R per the instructions in your link it gave me a list of txt files all dated in 2013. I have no idea where the 2014 files are. Attached are screenshots of the only crash report I could open through Firefox.

I don't have that dll. I have 2 plugins for that purpose. Both are "Microsoft Office 2010" with one being 14.0.4761.1000 that says its for allowing the opening of Office apps. The other is 14.0.4730.1010 which is for authorizing the plug-in for NPAPI but since I don't have that dll that probably isn't working. Firefox doesn't know the first one so I can't update it. I've tried to update the adobe and java that are out of date but your update link sends me to the release notes but that's it so nothing gets updated (what's with that?). As for the crash report, are you asking in regards to my second question? If so I got to the list of reports. When I did the whole "appdata" path with the Windows+R per the instructions in your link it gave me a list of txt files all dated in 2013. I have no idea where the 2014 files are. Attached are screenshots of the only crash report I could open through Firefox.

Modified by kimski

Question owner

Would uninstalling and reinstalling Firefox fix my issues with opening Word and Excel? If so what's the best way to save all my current settings?

Would uninstalling and reinstalling Firefox fix my issues with opening Word and Excel? If so what's the best way to save all my current settings?
Moses
  • Moderator
459 solutions 3607 answers

kimski: I'm not sure about Word/Excel as I prefer LibreOffice over Microsoft Office.

The screenshots of your crash report is caused by Adobe Flash. Try disabling Hardware Acceleration.

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.


If you still get crashes after that, try to disable Protected Mode in Flash 11.3 and above by adding the line ProtectedMode=0 to the Flash "mms.cfg" file located in one of these locations: [46]

   (Windows 32bit) C:\Windows\System32\Macromed\Flash 
   (Windows 64bit) C:\Windows\SysWOW64\Macromed\Flash 

For example, on a Windows 7 64-bit system, open the C:\Windows\SysWOW64\Macromed\Flash folder, copy the file "mms.cfg" to the desktop, open it in Notepad, add a new line ProtectedMode=0 and then close Notepad, saving your changes. Next, go back to the C:\Windows\SysWOW64\Macromed\Flash folder, rename the original file to "mms.cfgBAK" (to save it as a backup) and then drag and drop in the modified "mms.cfg" file from the desktop.

Note: To re-enable Flash Protected Mode, either restore a backup of the original mms.cfg file, if you saved one, or else re-edit the mms.cfg file to remove the ProtectedMode=0 l line you added. Updating Flash Player or installing a newer version does not automatically re-enable Protected Mode

kimski: I'm not sure about Word/Excel as I prefer LibreOffice over Microsoft Office. The screenshots of your crash report is caused by Adobe Flash. Try disabling Hardware Acceleration. <br> #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. ---- If you still get crashes after that, try to disable Protected Mode in Flash 11.3 and above by adding the line ProtectedMode=0 to the Flash "mms.cfg" file located in one of these locations: [46] (Windows 32bit) C:\Windows\System32\Macromed\Flash (Windows 64bit) C:\Windows\SysWOW64\Macromed\Flash For example, on a Windows 7 64-bit system, open the C:\Windows\SysWOW64\Macromed\Flash folder, copy the file "mms.cfg" to the desktop, open it in Notepad, add a new line <code>ProtectedMode=0 </code> and then close Notepad, saving your changes. Next, go back to the C:\Windows\SysWOW64\Macromed\Flash folder, rename the original file to "mms.cfgBAK" (to save it as a backup) and then drag and drop in the modified "mms.cfg" file from the desktop. Note: To re-enable Flash Protected Mode, either restore a backup of the original mms.cfg file, if you saved one, or else re-edit the mms.cfg file to remove the <code>ProtectedMode=0 l</code> line you added. Updating Flash Player or installing a newer version does not automatically re-enable Protected Mode

Question owner

Moses,

I did uncheck and will see if the crashing stops. Thanks

Moses, I did uncheck and will see if the crashing stops. Thanks

Modified by kimski

Chosen Solution

Moses and jscher2000,

I figured out what happened with not being able to open Word or Excel inside Firefox. We run Firefox from inside Sandboxie (virtual browser) and once I cleaned it out (from all the crap people try to install on my computer) I no longer have the problem.

Moses and jscher2000, I figured out what happened with not being able to open Word or Excel inside Firefox. We run Firefox from inside Sandboxie (virtual browser) and once I cleaned it out (from all the crap people try to install on my computer) I no longer have the problem.

Modified by kimski

AliceWyman
  • Moderator
240 solutions 2594 answers

kimski, Thanks for your last reply reporting how you solved the problem, which I've marked as the solution.

kimski, Thanks for your [/questions/1010176#answer-606710 last reply] reporting how you solved the problem, which I've marked as the solution.