X
Tap here to go to the mobile version of the site.

Support Forum

Flash plugin causes stuttering video when maximized on sites like Twitch

Posted

I've noticed that on sites like Twitch or Youtube, that the larger the window size is for higher quality streams of video content, the more it tends to stutter and thrash the disk. Since Twitch and YouTube are both supporting 60fps videos now, it's very easy to tell when the video stutters.

If I shrink the window size down, the problem isn't fully alleviated, but it does get better. With Chrome, I don't really notice any slowdown, yet it's using the same Flash version.

Any thoughts or ideas on what the problem might be?

I've noticed that on sites like Twitch or Youtube, that the larger the window size is for higher quality streams of video content, the more it tends to stutter and thrash the disk. Since Twitch and YouTube are both supporting 60fps videos now, it's very easy to tell when the video stutters. If I shrink the window size down, the problem isn't fully alleviated, but it does get better. With Chrome, I don't really notice any slowdown, yet it's using the same Flash version. Any thoughts or ideas on what the problem might be?

Chosen solution

Hello,

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Shockwave Flash 14.0 r0
  • Google Update
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft Lync
  • 5.1.30214.0
  • The plugin allows you to have a better experience with Microsoft SharePoint

Application

  • Firefox 30.0
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
  • Support URL: https://support.mozilla.org/1/firefox/30.0/WINNT/en-US/

Extensions

  • 1Password 4.2.3 (onepassword4@agilebits.com)
  • AppTabs Plus 1.6 (apptabsplus@github.com)
  • BetterTTV 6.6 (jid0-OeCFXKAPh2tC0bN3Li9ajRAZx6c@jetpack)
  • feedly 16.0.528 (feedly@devhd)
  • FiddlerHook 2.4.6.0 (fiddlerhook@fiddler2.com)
  • Firebug 2.0.1 (firebug@software.joehewitt.com)
  • FrankerFaceZ 1.55 (jid1-snHdAu6px3p0jA@jetpack)
  • Imgur Uploader 1.0.6 (giorgio@gilestro.tk)
  • Pocket 3.0.5 (isreaditlater@ideashower.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Turn Off the Lights 2.3.0.20 (stefanvandamme@stefanvd.net)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 210
  • adapterDescription2:
  • adapterDeviceID: 0x0a65
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16581
  • driverDate: 3-4-2014
  • driverDate2:
  • driverVersion: 9.18.13.3523
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 210 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.restore_on_demand: False
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140605174243
  • browser.startup.homepage: about:blank
  • browser.startup.homepage_override.buildID: 20140605174243
  • browser.startup.homepage_override.mstone: 30.0
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 30.0
  • font.internaluseonly.changed: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1404833036
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1403365177

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4220 solutions 58911 answers

Chosen Solution

Hello,

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

Hello, Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See [[Flash Plugin - Keep it up to date and troubleshoot problems|this article]] for more information on using the Flash plugin in Firefox). To disable hardware acceleration in Flash Player: #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. Does this solve the problem? Let us know.

Question owner

It seems like that has helped. Is there any reason for this?

It seems like that has helped. Is there any reason for this?
FredMcD
  • Top 10 Contributor
4220 solutions 58911 answers

Some things work without problems, some things don't. Hardware settings are among them.

Some things work without problems, some things don't. Hardware settings are among them.