Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird: Auto returning when typing message

  • 4 replies
  • 1 has this problem
  • 68 views
  • Last reply by wuergler

more options

Ahoy!

I'm hoping this will be a quick fix. When I type a message in Thunderbird, after about 80 characters the cursor is auto returning to the left and starting another line, hence I'm getting a paragraphed message block that isn't using the whole of the available text box across the whole screen! I have no idea why this is happening, but I hope it may just be a setting correction. Here's a sample of what it's doing (I've just used any characters to show as an example:

rtrwrwyryr y rttywywy ywyywywywey ryeyeey reryeyt3tet 454y45yury y4y44yuy 5yreyryrry y4y4577587 567575i67 i ll7i68u3446 455746644y5y4 y466yryyuu y4646 n 47464644646464646464 747474 464yy g 4y4y yuyuy5y 332336 ii6i645433 46463636363n 3336363 43646 464646.

Thunderbird is limiting the number of characters I can use and then auto returns. Is there a technophone that can help to correct this phenomenon? It would be really appreciated ;o)

Chosen solution

There is a line length set by default to 72 characters in about:config.

  • mailnews.wraplength = 72

Maybe that is causing the phenomenon.

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

There is a line length set by default to 72 characters in about:config.

  • mailnews.wraplength = 72

Maybe that is causing the phenomenon.

more options

Ahoy!

Thank you. I've located the line and it's set to 72. I don't know what number should be entered, but I've tried 1000 and it seems to work, so many thanks for the info (I have no idea why it reverted to 72 as I never made any changes, it just happened)!

Anyway, is there a value number that should be used or is 1000 OK?

Regards,

Mark

more options

No idea. I like the 72-character limit. It works for me.

more options

This may not be a good idea. See [*] for some reasons. Some of your recipients may see your text all on one line and have to scroll.

Better IHMO is to keep the default of all "wrap" configs in Config Editor except
mail.compose.wrap_to_window_width
which you would toggle to true if you don't like the wrapping while composing a message. 2014-06-19_TB_config_wrap2

Or, if you want to send mails in HTML most of the time (don't if you are not sure), then in Account Settings > Composition & Addressing check Compose messages in HTML format in which case the cursor won't auto return either.

[*] e. g. http://mailformat.dan.info/body/linelength.html older, but sill mostly quite valid