Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I prevent Firefox from redirecting me to Yahoo search engine

  • 7 replies
  • 30 have this problem
  • 38797 views
  • Last reply by Tom Cat

more options

When I try to go to the official site for ATF Cleaner, Firefox redirects me to the Yahoo search engine. I have deleted every reference to Yahoo in my registry and searched all user profiles for any reference to Yahoo. I am running Firefox version 29.0.1 under Windows XP.

Chosen solution

It's also possible that this problem is caused by an add-on, perhaps one that snuck onto your system as part of a bundle.

In case one of your extensions is involved, could you test the page in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

Read this answer in context 👍 5

All Replies (7)

more options

When does this problem occur, exactly? For example, when you:

  • type the address into the address bar
  • use a bookmark
  • click a link in a page open in Firefox
  • click a link in a different program that opens a new tab in Firefox

Or...

If the Yahoo site you get mentions DNS results, it may be a page that appears when there is a typo in the address or the server can't be found. Look around on the page (especially the very top or very bottom) for a way to opt out or cancel these kinds of results so you get a normal "server not found" error page.

Can you find anything like that?

more options

Chosen Solution

It's also possible that this problem is caused by an add-on, perhaps one that snuck onto your system as part of a bundle.

In case one of your extensions is involved, could you test the page in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

Not all add-ons are disabled: Flash and other plugins still run

After Firefox shuts down, a small dialog should appear. Click "Start in Safe Mode" (not Reset).

Any difference?

more options

It works when I go into Safe Mode, but if I run Firefox normally, it still brings up Yahoo.

more options

It occurs when I use Ixquick search engine to look up ATF Cleaner. I then click on the official ATF Cleaner site. This brings up a page www.atribune.org and in about 2 seconds switches to Yahoo search with the following words in the search bar: a tribune space imagaes portal blue templates."

more options

Hmm, our URL filter is blocking me from going to the site, so maybe it has been hacked?

more options

I I had the same yahoo redirect issue on Firefox 31, Mac OSX 10.6.8 on a whole slew of links (on popurls, cnn but also random small sites)

The issue resolved when I found (and disabled) four add-ons (ALL by Spigot!) that I did not knowingly install: - Amazon shopping assistant by Spigot 1.7 - Ebay shopping assistant by Spigot 1.7 - Searchme 2.1 - Slick Savings 3.2

How did they get IN there? That is what I want to know...

more options

How to just delete a reply HERE?

How about a simple "delete" button next to "edit" - similar to facebook...?

Modified by Tom Cat