Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to disable anti-alasing completely in firefox 30?

  • 8 replies
  • 9 have this problem
  • 128 views
  • Last reply by guigs

more options

Till today I used an add-on to remove the anti-alasing functionality to get clear, sharp Fonts in Firefox. With Firefox 30 the add-on is no longer supported. And now I am back at the beginning with this prblem as I already hat in Firefox 17.

Here an example of what I mean. http://s1.directupload.net/images/140612/rl8qxiiu.jpg

The upper line is as Windows renders fonts without antialasing and so did firefox until firefox 29. The bottom line is how firefox renders fonts in firefox 30. I can not live with that washed-out, frayed fonts, I get headache from that.

Can someone tell me how to remove this anti-alasing feature completely out of my firefox?

All Replies (8)

more options

What is the name of the add-on? Did you check it's web page for updates?

more options
more options

This thread is about Firefox 30, while the other one is Firefox 24 ESR, so maybe better to keep separate...

Is hardware acceleration working on your Firefox 30? You can check on the Troubleshooting Information page, either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • Help menu > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Search in the page for GPU and check what you have for "GPU Accelerated Windows". If hardware acceleration is enabled and working, it should show all windows accelerated. If it is blocked, it should show zero windows accelerated.

more options

Here is the section about the GPU

http://s14.directupload.net/images/140613/2yryiq2h.png

more options

Good idea showing all the detail.

I think the reason the extension doesn't work is that the current Azure back end is not Direct2d. The extension works with that technology, and/or DirectWrite.

Could you check this setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste gfx and pause while the list is filtered

(3) If gfx.content.azure.backends is not set to

direct2d,cairo

could you right-click > Reset it.

Are any other gfx. preferences set to non-default values?

more options

I did that, "direct2d,cairo" was default. Other preferences were not changed by me.

more options

Tagged as escalate. See Escalation Guidelines

Help Desk Note Jeff was asking

How can I escalate this to someone to figure out why direct2d is not being used?

Modified by John99

more options