X
Tap here to go to the mobile version of the site.

Support Forum

microsoft visual c++ runtime library runtime error r6025 program:C/program files (x86) mozilla firefox/plugin-container.exe

Posted

I get this message when on facebook, either playing a game or just reading the news feed. I have firefox 30.0. Windows 8.1. I have current flashplayer and current firefox. Firefox freezes and my CPU usage goes up to 75%.

I get this message when on facebook, either playing a game or just reading the news feed. I have firefox 30.0. Windows 8.1. I have current flashplayer and current firefox. Firefox freezes and my CPU usage goes up to 75%.

Modified by kedwards138

Additional System Details

Installed Plug-ins

  • Shockwave Flash 13.0 r0
  • Picasa plugin
  • LastPass Plugin

Application

  • Firefox 30.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0
  • Support URL: https://support.mozilla.org/1/firefox/30.0/WINNT/en-US/

Extensions

  • AmazonSmile 1Button for Firefox 1.0 (smile1Button@amazon.com)
  • LastPass 3.1.1 (support@lastpass.com)
  • NoScript 2.6.8.28 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • McAfee Security Scan Plus 1.0 ({e4f94d1e-2f53-401e-8885-681602c0ddd8}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0152
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 1-22-2014
  • driverDate2:
  • driverVersion: 10.18.10.3412
  • driverVersion2:
  • info: {u'AzureContentBackend': u'cairo', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140605174243
  • browser.startup.homepage: http://md39.quartz.synacor.com/zimbra/mail#1
  • browser.startup.homepage_override.buildID: 20140605174243
  • browser.startup.homepage_override.mstone: 30.0
  • browser.tabs.warnOnClose: False
  • dom.max_script_run_time: 20
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 30.0
  • gfx.direct2d.disabled: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1402433744
  • places.history.expiration.transient_current_max_pages: 104655
  • plugin.disable_full_page_plugin_for_types:
  • plugin.importedState: True
  • plugin.state.npgoogleupdate: 0
  • plugin.state.npintelwebapiipt: 0
  • plugin.state.npintelwebapiupdater: 0
  • plugin.state.nplastpass: 2
  • plugin.state.nppdf: 0
  • plugin.state.nppicasa: 2
  • plugin.state.nppokkidownloadhelper: 0
  • privacy.cpd.cookies: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1400921384

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4267 solutions 59836 answers

Helpful Reply

Start Firefox in Safe Mode {web link} While you are in safe mode; Press the <Alt> or <F10> key to bring up the tool bar. Followed by;

Windows; Tools > Options Linux; Edit > Preferences Mac; application name > Preferences

Then Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites and see if there is still a problem. Then restart.

'''''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''''' {web link} While you are in safe mode; Press the '''<Alt>''' or '''<F10>''' key to bring up the tool bar. Followed by; Windows; '''Tools > Options''' Linux; '''Edit > Preferences''' Mac; ''application name'' '''> Preferences''' Then '''Advanced > General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites and see if there is still a problem. Then restart.

Question owner

Thank you for your reply Fred. I had found this tip in my searches for a remedy but I got the error message again today after I had turned it off. This is so frustrating.

Thank you for your reply Fred. I had found this tip in my searches for a remedy but I got the error message again today after I had turned it off. This is so frustrating.
FredMcD
  • Top 10 Contributor
4267 solutions 59836 answers

Helpful Reply

Next step;

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

Next step; Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See [[Flash Plugin - Keep it up to date and troubleshoot problems|this article]] for more information on using the Flash plugin in Firefox). To disable hardware acceleration in Flash Player: #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. Does this solve the problem? Let us know.

Question owner

I had done this before after reading how to do it. I still got the error message. I have checked all of my drivers for updates like it was suggested also. Just had a windows update of 14, so maybe one of those will help.

I had done this before after reading how to do it. I still got the error message. I have checked all of my drivers for updates like it was suggested also. Just had a windows update of 14, so maybe one of those will help.
FredMcD
  • Top 10 Contributor
4267 solutions 59836 answers

Did you see if you still had the problem while you are in safe mode?

Did you see if you still had the problem while you are in safe mode?

Question owner

No I did not have the problem while in safe mode, but then I did not play a lot of games or do much on facebook while in safe mode. I don't get the error message every day. I have had it a total of three times now in the past month or so.

No I did not have the problem while in safe mode, but then I did not play a lot of games or do much on facebook while in safe mode. I don't get the error message every day. I have had it a total of three times now in the past month or so.