Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

updated Mavericks to 10.9.3 and now scrolling doesn't work in Firefox.

  • 7 replies
  • 21 have this problem
  • 1528 views
  • Last reply by cor-el

more options

I updated yesterday, and now the scroll wheel on my mouse (Belkin optical mouse) does not work in Firefox. It works everywhere else, just not in Firefox.

Chosen solution

Can you scroll with the keyboard?

On Mac the scroll bars can be hidden and only have them show when you scroll the page so you can see the current scroll position. The idea is that a touch pad is used that doesn't require the scroll bars to be visible and thus have more screen estate for the browsing area. You can make the scroll bars always visible:

  • System Preferences > General > Show Scroll Bar > Choose "Always"

Note that on Mac you can toggle full screen mode with Command+Shift+F.

Read this answer in context 👍 1

All Replies (7)

more options

Start Firefox in Safe Mode {web link} While you are in safe mode; Press the <Alt> or <F10> key to bring up the tool bar.. Then Tools > Options > Advanced > General. Look for and turn off Use Hardware Acceleration.

See if there is still a problem. Then restart.

more options

I tried to do what you said, but I couldn't. I succeeded in starting up in safe mode, but when I press the F10 key it just turns sound on and off. I don't have an Alt key. I have command and option, and I tried both of them, but nothing happened in either case. So I couldn't access the tool bar. Can you suggest any other way I can find it?

more options

Faywouk
Instead of pressing F10 to go into the menu, you can simply click the new menu button (new fx menu > Help (?) > Restart with add-ons disabled. Firefox will then pop up a box and click Start Firefox in Safe Mode or similar.

Does it work okay with Firefox? If it does, it's probably one of your extensions misbehaving. Try to narrow it down while re-enabling them back on in Safe Mode to see when your scrolling stops working.

more options

My problem is not with safe mode. As I said in my last message, I was able to restart in safe mode. My problem was with the rest of the procedure. I could not find the tool bar.

more options

Chosen Solution

Can you scroll with the keyboard?

On Mac the scroll bars can be hidden and only have them show when you scroll the page so you can see the current scroll position. The idea is that a touch pad is used that doesn't require the scroll bars to be visible and thus have more screen estate for the browsing area. You can make the scroll bars always visible:

  • System Preferences > General > Show Scroll Bar > Choose "Always"

Note that on Mac you can toggle full screen mode with Command+Shift+F.

more options

Yes, I can scroll with the keyboard. Thanks.

more options

So this only only a problem with the mouse?

Do you have another mouse that you can try?