X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Why does Firefox 29.0.1 keep crashing?

Posted

Since I updated to version 29.0.1 Firefox is crashing daily. Before this latest update I had no problems. I've gone through support and tried every suggestion (safe mode, made sure all drivers are up-to-date, uninstalled and reinstalled, etc.) and yet it still crashes. I desperately need my browser to work flawlessly for my work, otherwise, regretfully, I am going to have to use another browser. Here are a couple of my crash reports:

bp-dc242b7c-781f-458b-abc0-45eba2140525 bp-3761933f-8b46-4aef-ad5f-0e6ff2140524

If anyone can help me stop Firefox from crashing, I will be eternally grateful.

Since I updated to version 29.0.1 Firefox is crashing daily. Before this latest update I had no problems. I've gone through support and tried every suggestion (safe mode, made sure all drivers are up-to-date, uninstalled and reinstalled, etc.) and yet it still crashes. I desperately need my browser to work flawlessly for my work, otherwise, regretfully, I am going to have to use another browser. Here are a couple of my crash reports: bp-dc242b7c-781f-458b-abc0-45eba2140525 bp-3761933f-8b46-4aef-ad5f-0e6ff2140524 If anyone can help me stop Firefox from crashing, I will be eternally grateful.

Modified by Vici

Additional System Details

Installed Plug-ins

  • Shockwave Flash 13.0 r0
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • EagleGet Downloader
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.1.151
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • VLC media player Web Plugin 2.1.3
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.9.149
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

More Information

Moses
  • Moderator
459 solutions 3607 answers

First, thank you for the crash reports. This is an on going issue with graphics acceleration and it is being addressed in

Please read the Bugzilla Etiquette if you decide to post in crash reports.

D2d is blocklisted for Firefox 21, and the current nightly version 31/32 is being monitored to less crashes. Now there are patches pending and performance monitoring being preformed on the patches.

For identification:

  • Bug 902952 - Use Direct2D 1.1 on mozilla-central , please feel free to look at different bug descriptions at your leisure for *fixed* :-)

For current plan:

  • Milestone for this issue is version 30. So it will be a while before non Firefox Beta is affected by the changes made.

Firefox has hardware acceleration set to "on" by default, but it's still young, which means some video cards or drivers might have problems with it. You can try to disable hardware acceleration to see if that alleviates your problems.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps for Firefox version 29.0 and above:

  • Click the menu button New Fx Menu and select Options for Windows or Preferences on Mac or Linux. For Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window, click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

First, thank you for the crash reports. This is an on going issue with graphics acceleration and it is being addressed in *[https://bugzilla.mozilla.org/show_bug.cgi?id=805406 Bug 805406 - crash in gfxContext::PushClipsToDT with Direct2D 1.1 (d3d11.dll 6.2 or 6.3)] Please read the [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html Bugzilla Etiquette] if you decide to post in crash reports. D2d is blocklisted for Firefox 21, and the current nightly version 31/32 is being monitored to less crashes. Now there are patches pending and performance monitoring being preformed on the patches. For identification: *Bug 902952 - Use Direct2D 1.1 on mozilla-central , please feel free to look at different bug descriptions at your leisure for *fixed* :-) For current plan: *Milestone for this issue is version 30. So it will be a while before non Firefox Beta is affected by the changes made. ---- Firefox has hardware acceleration set to "on" by default, but it's still young, which means some video cards or drivers might have problems with it. You can try to disable hardware acceleration to see if that alleviates your problems. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps for Firefox version 29.0 and above: *Click the menu button [[Image:New Fx Menu]] and select Options for Windows or Preferences on Mac or Linux. For Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window, click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]]

Question owner

Thank you for the prompt reply. So it's a problem with the hardware acceleration? But I've always had that disabled. Is there anything else I can do to try and stop the crashing?

Thank you for the prompt reply. So it's a problem with the hardware acceleration? But I've always had that disabled. Is there anything else I can do to try and stop the crashing?
FredMcD
  • Top 10 Contributor
4269 solutions 59846 answers

I found that after Firefox v29, a LOT of my settings and add-ons were changed / reset.

I found that after Firefox v29, a LOT of my settings and add-ons were changed / reset.

Question owner

Should I downgrade or upgrade? I've double checked that hardware acceleration is disabled and I've disabled the WebGL. Still crashing. :(

Should I downgrade or upgrade? I've double checked that hardware acceleration is disabled and I've disabled the WebGL. Still crashing. :(

Modified by Vici

FredMcD
  • Top 10 Contributor
4269 solutions 59846 answers

Copy and post the last 5 crash reports here.

When does Firefox crash? What were you doing? Is it at one or two sites or many?

Copy and post the last 5 crash reports here. When does Firefox crash? What were you doing? Is it at one or two sites or many?

Question owner

Just crashed again. :( It crashes on various sites. Here's the latest crash report.

bp-688c266e-6b5a-41c1-afe7-b9fd42140526

Graphics


Adapter Description: NVIDIA GeForce 210 Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um Adapter RAM: 1024 ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 Device ID: 0x0a65 DirectWrite Enabled: false (6.2.9200.16571) Driver Date: 3-4-2014 Driver Version: 9.18.13.3523 GPU #2 Active: false GPU Accelerated Windows: 0/3 Basic Vendor ID: 0x10de windowLayerManagerRemote: false AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

JavaScript


Incremental GC: true

Just crashed again. :( It crashes on various sites. Here's the latest crash report. bp-688c266e-6b5a-41c1-afe7-b9fd42140526 Graphics -------- Adapter Description: NVIDIA GeForce 210 Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um Adapter RAM: 1024 ClearType Parameters: Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50 Device ID: 0x0a65 DirectWrite Enabled: false (6.2.9200.16571) Driver Date: 3-4-2014 Driver Version: 9.18.13.3523 GPU #2 Active: false GPU Accelerated Windows: 0/3 Basic Vendor ID: 0x10de windowLayerManagerRemote: false AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0 JavaScript ---------- Incremental GC: true

Modified by Vici

Question owner

I've gone back to Firefox 28 - I hope this is fixed before the next update, otherwise I'll have to use another browser. :(

I've gone back to Firefox 28 - I hope this is fixed before the next update, otherwise I'll have to use another browser. :(

Question owner

Now it's crashing with Firefox 28! Please help me! I don't want to change browsers, but if this continues I will be forced to do so. :(

bp-2fe28dc9-f2de-467a-89e0-d877e2140527

Now it's crashing with Firefox 28! Please help me! I don't want to change browsers, but if this continues I will be forced to do so. :( bp-2fe28dc9-f2de-467a-89e0-d877e2140527
FredMcD
  • Top 10 Contributor
4269 solutions 59846 answers

Start Firefox in Safe Mode {web link} Let it just sit there for a few minutes.

Then poke around in the options / add-ons menus. Any problems?

While you are in safe mode; Press the <Alt> or <F10> key to bring up the tool bar. Then Tools > Options > Advanced > General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites and see if there is still a problem. Then restart.

'''''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''''' {web link} Let it just sit there for a few minutes. Then poke around in the options / add-ons menus. Any problems? While you are in safe mode; Press the '''<Alt>''' or '''<F10>''' key to bring up the tool bar. Then '''Tools > Options > Advanced > General.''' Look for and turn off '''Use Hardware Acceleration'''. Poke around safe web sites and see if there is still a problem. Then restart.
John99 971 solutions 13138 answers

I am not sure why you went back to Firefox 28 that is not supported or secure and will not get any fixes. There was a comment about Fx29 changing preferences but should that have happened to you it would have been trivial to reset the prefs.

One of the bugs that could have been affecting you appears to have been fixed #c140already in Firefox 30

Unlike Moses I have not tried to read up on the maze of related bug reports on this issue but I would say you would definitely be better on the Beta channel which is currently Firefox 30 and it seems you have little to lose by trying that

I am not sure why you went back to Firefox 28 that is not supported or secure and will not get any fixes. There was a comment about Fx29 changing preferences but should that have happened to you it would have been trivial to reset the prefs. One of the bugs that could have been affecting you appears to have been fixed <sup>[https://bugzilla.mozilla.org/show_bug.cgi?id=805406#c140 #c140]</sup>already in Firefox 30 Unlike ''Moses'' I have not tried to read up on the maze of related bug reports on this issue but I would say you would definitely be better on the Beta channel which is currently Firefox 30 and it seems you have little to lose by trying that * http://www.mozilla.org/en-US/firefox/channel/#beta/beta-desktop

Question owner

Thanks FredMcD. But I've already tried safe mode and it crashed again while I was browsing on a couple of sites. I've also disabled all add-ons and enabled one at a time. Still crashed. So, I'm going to go with John's suggestion and try out Firfox 30. Can't hurt. :)

Thanks FredMcD. But I've already tried safe mode and it crashed again while I was browsing on a couple of sites. I've also disabled all add-ons and enabled one at a time. Still crashed. So, I'm going to go with John's suggestion and try out Firfox 30. Can't hurt. :)
chockfei 0 solutions 3 answers

Have you tried Firefox reset to factory defaults? Worth a try if Firefox 30 still crashes.

Have you tried Firefox reset to factory defaults? Worth a try if Firefox 30 still crashes.
John99 971 solutions 13138 answers

It is certainly worth trying Firefox in Firefox's safe mode with all plugins disabled. It sounds from the first post as if you will have tried that. Does it still crash then, and if it does a couple of the Crash IDs would be worth pasting in and looking at, just in case it gives a different crash signature.

It is certainly worth trying Firefox in Firefox's safe mode with all plugins disabled. It sounds from the first post as if you will have tried that. Does it still crash then, and if it does a couple of the Crash IDs would be worth pasting in and looking at, just in case it gives a different crash signature.

Question owner

I was just about to post that all seems to be well with Firefox 30 after no crashes for a couple of days, but it's just crashed again. :(

bp-d739821b-79a1-433e-b6bb-114752140531

I was just about to post that all seems to be well with Firefox 30 after no crashes for a couple of days, but it's just crashed again. :( bp-d739821b-79a1-433e-b6bb-114752140531

Modified by Vici

John99 971 solutions 13138 answers

Is that related to using high zoom or very large font sizes when you see the crash ? or some other specific action like using Google Street view #c181.

As I mentioned earlier please test with all plugins disabled and in Firefox's safe mode.

Or is it only crashing very infrequently now. Intermittent crashes are often difficult to pin down and troubleshooting may be rather inconvenient. it may help to use multiple Firefox profiles when troubleshooting but it may not be worth the effort of doing any troubleshooting if the crashes are infrequent.


For forum cross referencing purposes

  • Your Reports for CrashIDs
    bp-2fe28dc9-f2de-467a-89e0-d877e2140527 (Firefox 28.0 )
    bp-d739821b-79a1-433e-b6bb-114752140531 (Firefox 30.0 )
  • Crash Signature: gfxContext::PushClipsToDT(mozilla::gfx::DrawTarget*)
  • RelatedBugs
    (edited -includes)
    1011864 NEW --- Mozilla Firefox 29.0 crash (pointing to Null ) with window.open and very large sizes (PushClipsToDT signature)
    1011348 NEW --- Crash/freeze when rendering certain private-use characters at font-sizes greater than about 1300%
    1010262 NEW --- crash in gfxContext::PushClipsToDT(mozilla::gfx::DrawTarget*)

    74656 NEW --- Linux crash in gfxContext::PushClipsToDT(mozilla::gfx::DrawTarget*)
    805406 REOPENED --- crash in gfxContext::PushClipsToDT with Direct2D 1.1 (d3d11.dll 6.2 or 6.3)
Is that related to using high zoom or very large font sizes when you see the crash ? or some other specific action like using Google Street view <sup>[https://bugzilla.mozilla.org/show_bug.cgi?id=805406#c181 #c181]</sup>. As I mentioned earlier please test with all plugins disabled and in Firefox's safe mode. Or is it only crashing very infrequently now. Intermittent crashes are often difficult to pin down and troubleshooting may be rather inconvenient. it may help to use multiple Firefox profiles when troubleshooting but it may not be worth the effort of doing any troubleshooting if the crashes are infrequent. ------------ For forum cross referencing purposes * Your Reports for CrashIDs <br /> bp-2fe28dc9-f2de-467a-89e0-d877e2140527 (Firefox 28.0 ) <br /> bp-d739821b-79a1-433e-b6bb-114752140531 (Firefox 30.0 ) * Crash Signature: gfxContext::PushClipsToDT(mozilla::gfx::DrawTarget*) * RelatedBugs <br /> (edited -includes) <br/> 1011864 NEW --- Mozilla Firefox 29.0 crash (pointing to Null ) with window.open and very large sizes (PushClipsToDT signature) <br/> 1011348 NEW --- Crash/freeze when rendering certain private-use characters at font-sizes greater than about 1300% <br /> 1010262 NEW --- crash in gfxContext::PushClipsToDT(mozilla::gfx::DrawTarget*) <br /> <br /> 74656 NEW --- Linux crash in gfxContext::PushClipsToDT(mozilla::gfx::DrawTarget*) <br /> 805406 REOPENED --- crash in gfxContext::PushClipsToDT with Direct2D 1.1 (d3d11.dll 6.2 or 6.3)

Question owner

I don't zoom or use Google Street View and I don't think I use very large font sizes. Sorry, I'm not very techno savvy. It crashes on various sites, so I can't pinpoint what's going wrong, but as it hasn't crashed in a couple of days it seems to be crashing infrequently now.

I'll test again with all plugins disabled and in Firefox's safe mode and let you know how that goes. Thanks for the help, John.

I don't zoom or use Google Street View and I don't think I use very large font sizes. Sorry, I'm not very techno savvy. It crashes on various sites, so I can't pinpoint what's going wrong, but as it hasn't crashed in a couple of days it seems to be crashing infrequently now. I'll test again with all plugins disabled and in Firefox's safe mode and let you know how that goes. Thanks for the help, John.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

You can also try to boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test.


Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem

You can also try to boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ ----- Create a new profile as a test to check if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

Another crash, but this time I got a message from Windows. Does this help with what is going wrong?

Problem signature:

 Problem Event Name:	APPCRASH
 Application Name:	plugin-container.exe
 Application Version:	30.0.0.5262
 Application Timestamp:	5387f37a
 Fault Module Name:	mozalloc.dll
 Fault Module Version:	30.0.0.5262
 Fault Module Timestamp:	5387c49f
 Exception Code:	80000003
 Exception Offset:	0000141b
 OS Version:	6.1.7601.2.1.0.256.1
 Locale ID:	3081
 Additional Information 1:	0a9e
 Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
 Additional Information 3:	0a9e
 Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:

 http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:

 C:\Windows\system32\en-US\erofflps.txt
Another crash, but this time I got a message from Windows. Does this help with what is going wrong? Problem signature: Problem Event Name: APPCRASH Application Name: plugin-container.exe Application Version: 30.0.0.5262 Application Timestamp: 5387f37a Fault Module Name: mozalloc.dll Fault Module Version: 30.0.0.5262 Fault Module Timestamp: 5387c49f Exception Code: 80000003 Exception Offset: 0000141b OS Version: 6.1.7601.2.1.0.256.1 Locale ID: 3081 Additional Information 1: 0a9e Additional Information 2: 0a9e372d3b4ad19135b953a78882e789 Additional Information 3: 0a9e Additional Information 4: 0a9e372d3b4ad19135b953a78882e789 Read our privacy statement online: http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409 If the online privacy statement is not available, please read our privacy statement offline: C:\Windows\system32\en-US\erofflps.txt

Helpful Reply

OK. I'm laying this problem on Mozilla's door. I've completely uninstalled and reinstalled Firefox. Browsed with no extensions, then browsed with only one enabled at a time. Still crashes with the same crash signature. I don't know what else I can do, only hope that Mozilla can sort out what is going wrong. :(

OK. I'm laying this problem on Mozilla's door. I've completely uninstalled and reinstalled Firefox. Browsed with no extensions, then browsed with only one enabled at a time. Still crashes with the same crash signature. I don't know what else I can do, only hope that Mozilla can sort out what is going wrong. :(
ilg924 0 solutions 1 answers

I'm getting this crash as well, at least twice a day and have been for a few months. The only thing keeping me from switching browsers is Noscript. This actually started once I got a new computer, I didn't have these crashes on my last computer. I've tried all steps above, nothing's worked. I'm running Firefox 30 beta

Here's one of my crashlogs

bp-9c8724b2-5f0b-4e13-8bcb-5ef7e2140518

I'm getting this crash as well, at least twice a day and have been for a few months. The only thing keeping me from switching browsers is Noscript. This actually started once I got a new computer, I didn't have these crashes on my last computer. I've tried all steps above, nothing's worked. I'm running Firefox 30 beta Here's one of my crashlogs bp-9c8724b2-5f0b-4e13-8bcb-5ef7e2140518

Modified by ilg924