X
Tap here to go to the mobile version of the site.

Support Forum

Why is Firefox rendering fonts all jagged and blocky, w/no anti-aliasing?

Posted

Running FF 29.01 on Windows 7. You can see the image linked below for a comparison of how browsers should render font and how my browser actually renders font. It is not a magnification issue. I've already installed the Anti-Aliasing Tuner extension. I've added the layout.paint_rects_separately boolean as well.

http://i.imgur.com/6kdcFok.png

Running FF 29.01 on Windows 7. You can see the image linked below for a comparison of how browsers should render font and how my browser actually renders font. It is not a magnification issue. I've already installed the Anti-Aliasing Tuner extension. I've added the layout.paint_rects_separately boolean as well. http://i.imgur.com/6kdcFok.png

Chosen solution

Looks to me like ClearType is disabled. http://www.thewindowsclub.com/disable-font-smoothing-windows

Does this only apply to Firefox? If so did you switch to a different font in Firefox settings?

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 13.0 r0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • Google Update
  • Next Generation Java Plug-in 10.55.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • 5.1.30214.0
  • Citrix URL-Redirection Helper Plugin
  • Citrix Receiver Plugin (Win32)
  • Nitro PDF plugin for Firefox and Chrome
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17270 solutions 156099 answers

Try to create a new Boolean pref on the about:config page via the right-click context menu with the name layout.paint_rects_separately and set the value to true and leave hardware acceleration enabled.

Try to create a new Boolean pref on the about:config page via the right-click context menu with the name <b>layout.paint_rects_separately</b> and set the value to true and leave hardware acceleration enabled. *http://kb.mozillazine.org/about:config

Question owner

From OP:

I've added the layout.paint_rects_separately boolean as well.

Another screenshot to illustrate the issue, if that helps:

http://i.imgur.com/SZZIrya.png

From OP: '''I've added the layout.paint_rects_separately boolean as well. ''' Another screenshot to illustrate the issue, if that helps: http://i.imgur.com/SZZIrya.png

Modified by jaero

teleguy 8 solutions 32 answers

Chosen Solution

Looks to me like ClearType is disabled. http://www.thewindowsclub.com/disable-font-smoothing-windows

Does this only apply to Firefox? If so did you switch to a different font in Firefox settings?

Looks to me like ClearType is disabled. http://www.thewindowsclub.com/disable-font-smoothing-windows Does this only apply to Firefox? If so did you switch to a different font in Firefox settings?

Question owner

That was absolutely it. Thank you.

That was absolutely it. Thank you.