Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why firefox 29 is keep deleting my cookies? Also, where is the clear on exit option now?

more options

All I have in the options is a list of stored cookies to delete, that's fine, but with every session closed I lose my cookies from various sites. I would really like to have the option to keep those, is getting annoying to set over and over all the preferences. I can't describe in words how disappointed I am right now, Chrome looks like the only option. I'm getting tired of all this switch back and forth from one browser to another! With every update is getting worse, how come firefox turned from hero to a common problem?

Chosen solution

Details like websites remembering you (log you in automatically) are stored in a cookie.

  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

It is possible that the cookies.sqlite file that stores the cookies got corrupted.

  • Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
Read this answer in context 👍 1

All Replies (4)

more options

If you don't have many add-ons, you may want to simply reset Firefox. This should eliminate any problems related to preferences or file or folder permissions.

Otherwise, if your settings are forgotten when you restart Firefox, see the following article.


  1. Click the ≡ Menu Button and choose Options.
  2. Click the Privacy button.
  3. Choose "Firefox will: Use custom settings for history".
    • If you've selected "Keep until: I close Firefox", then cookies will be discarded unless you've created an Allow exception for the site in question.
    • If you've checked "Clear history when Firefox closes", you can click the Settings button to select what gets cleared on exit.
more options

Thank you for your answer, unfortunately this doesn't solve my problem, I tried every combination, with the option to remember history with all that involves and custom settings with "keep cookies until they expire", and doesn't work. The new thing since Firefox 29 is only the Classic Theme Restorer add-on, but even with this removed I have the same problem. To reset Firefox means to throw all away, I have too many bookmarks stored in the Fast Dial add-on. Speaking of Classic Theme Restorer it's very annoying that Firefox 29 doesn't have the refresh button where it used to be, for most of the developers this became a reflex. I try not to speak about the awful new tab design, but I made an account just to spill it out. Sorry. Either way, I appreciate your support, otherwise I would be elsewhere.

more options

Chosen Solution

Details like websites remembering you (log you in automatically) are stored in a cookie.

  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

It is possible that the cookies.sqlite file that stores the cookies got corrupted.

  • Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

You can use this button to go to the currently used Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
more options

Thank you very much, this would probably solve my problem, but I preferred to reset the whole thing, rewrote my bookmarks and favorite add-ons in a file and start from scratch. It's weird, though, some cookies are still removed after the session close. From my tests Firefox has problems with cookies that don't have the expire date set and completely ignores the ones with secure:true. It must be a security reason, I won't go deeper. I appreciate your support, it works fine, I hope it won't update again without my approval. All the best, Levi

Modified by leviszekeres