X
Thinta lapha ukuze uye kuveshini yamakhalekhukhwini kusayithi.

Isithangami Sabeseki

Lolu chungechunge lwabekwa kunqolobane. Uyacelwa ubuze umbuzo omusha uma udinga usizo.

Is there any option to save opened tabs when I closed Firefox 4.0 (like it used to be in Firefox 3.5)?

Kuphostiwe

Is there any option to save opened tabs when I close/quit Firefox in the version 4.0 (like it used to be in Firefox 3.6)?

Is there any option to save opened tabs when I close/quit Firefox in the version 4.0 (like it used to be in Firefox 3.6)?

Isisombululo esikhethiwe

You are posting from a system using Firefox 3.6.9----Correct?

One of the changes in Firefox 4: by default Firefox 4 does not display the warning message when closing multiple tabs, but it can be turned back on by changing some preferences.

  1. Type about:config in the URL/Location/Address bar and press the Enter key
  2. Accept the warning message (promise to be careful)
  3. The preferences page/list will open
  4. Filter = browser.tabs.warnOnClose
  5. If its value is set to false, double-click on it (in the lower panel) to toggle its value to true
  6. Repeat steps 4 and 5 for these following 3 preferences also:
    • browser.warnOnQuit
    • browser.warnOnRestart
    • browser.showQuitWarning
  7. See:




Other issues needing your attention

The information submitted with your question indicates that you have out of date plugins with known security and stability issues that should be updated. To see the plugins submitted with your question, click "More system details..." to the right of your original question post. You can also see your plugins from the Firefox menu, Tools > Add-ons > Plugins.

  • Shockwave Flash 10.2 r152
    • Security update just released
  1. Check your plugin versions on either of the following links':
  2. Update the Flash plugin to the latest version.
    • Download and SAVE to your Desktop so you can find the installer later
    • If you do not have the current version, click on the "Player Download Center" link on the "Download and information" or "Download Manual installers" below
    • After download is complete, exit Firefox
    • Click on the installer you just downloaded and install
      • Windows 7 and Vista: may need to right-click the installer and choose "Run as Administrator"
    • Start Firefox and check your version again or test the installation by going back to the download link below
    • Download and information: http://www.adobe.com/software/flash/about/
      • Use Firefox to go to the above site to update the Firefox plugin (will also install plugin for most other browsers; except IE)
      • Use IE to go to the above site to update the IE ActiveX
    • Download Manual installers.
Funda le mpendulo ngokuhambisana nalesi sihloko 84

Eminye Imininingwane Yohlelo

Fakela amapulagi

  • np-mswmp
  • 2.0.0048.0
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.448
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • DjVu browser plugin
  • Winamp Application Detector
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.2"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Shockwave Flash 10.2 r152
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.60129.0
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Live Update v1.4
  • NPWLPG
  • Version 1.1.7, copyright 1996-2011 The VideoLAN Teamhttp://www.videolan.org/

Isisebenziso

  • I-ejenti Engumsebenzisi: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.9) Gecko/20100824 Firefox/3.6.9 Facicons

Eminye Imininingwane

Helper7677 165 izisombululo 1653 izimpendulo
Kuphostiwe

Isisombululo Esikhethiwe

You are posting from a system using Firefox 3.6.9----Correct?

One of the changes in Firefox 4: by default Firefox 4 does not display the warning message when closing multiple tabs, but it can be turned back on by changing some preferences.

  1. Type about:config in the URL/Location/Address bar and press the Enter key
  2. Accept the warning message (promise to be careful)
  3. The preferences page/list will open
  4. Filter = browser.tabs.warnOnClose
  5. If its value is set to false, double-click on it (in the lower panel) to toggle its value to true
  6. Repeat steps 4 and 5 for these following 3 preferences also:
    • browser.warnOnQuit
    • browser.warnOnRestart
    • browser.showQuitWarning
  7. See:




Other issues needing your attention

The information submitted with your question indicates that you have out of date plugins with known security and stability issues that should be updated. To see the plugins submitted with your question, click "More system details..." to the right of your original question post. You can also see your plugins from the Firefox menu, Tools > Add-ons > Plugins.

  • Shockwave Flash 10.2 r152
    • Security update just released
  1. Check your plugin versions on either of the following links':
  2. Update the Flash plugin to the latest version.
    • Download and SAVE to your Desktop so you can find the installer later
    • If you do not have the current version, click on the "Player Download Center" link on the "Download and information" or "Download Manual installers" below
    • After download is complete, exit Firefox
    • Click on the installer you just downloaded and install
      • Windows 7 and Vista: may need to right-click the installer and choose "Run as Administrator"
    • Start Firefox and check your version again or test the installation by going back to the download link below
    • Download and information: http://www.adobe.com/software/flash/about/
      • Use Firefox to go to the above site to update the Firefox plugin (will also install plugin for most other browsers; except IE)
      • Use IE to go to the above site to update the IE ActiveX
    • Download Manual installers.
You are posting from a system using Firefox 3.6.9----Correct? One of the changes in Firefox 4: '''''by default''''' Firefox 4 does not display the warning message when closing multiple tabs, but it can be turned back on by changing some preferences. #Type '''''about:config''''' in the URL/Location/Address bar and press the Enter key #Accept the warning message (promise to be careful) #The preferences page/list will open #Filter = '''''browser.tabs.warnOnClose''''' #If its value is set to false, double-click on it (in the lower panel) to toggle its value to true #Repeat steps 4 and 5 for these following 3 preferences also: #*'''''browser.warnOnQuit''''' #*'''''browser.warnOnRestart''''' #*'''''browser.showQuitWarning''''' #**Note: last pref is new in Firefox 4b12, may need to add (boolean) #**Info/Instruction for using '''''about:config''''': http://kb.mozillazine.org/About:config #See: #*https://support.mozilla.com/en-US/questions/785169 #*http://forums.mozillazine.org/viewtopic.php?f=23&t=2105039&p=10434467&sid=fd2a35945bb2c633687f7b50d8c53989 #*http://blog.zpao.com/post/3174360617/about-that-quit-dialog <br /> --------------------------- <br /> '''Other issues needing your attention''' The information submitted with your question indicates that you have out of date plugins with known security and stability issues that should be updated. To see the plugins submitted with your question, click "More system details..." to the right of your original question post. You can also see your plugins from the Firefox menu, Tools > Add-ons > Plugins.<br /> <br /> *Shockwave Flash 10.2 r152 **Security update just released #'''''Check your plugin versions''''' on either of the following links': #*http://www.mozilla.com/en-US/plugincheck/ #*https://www-trunk.stage.mozilla.com/en-US/plugincheck/ #*'''Note: plugin check page does not have information on all plugin versions''' #'''Update the [[Managing the Flash plugin|Flash]] plugin''' to the latest version. #*Download and SAVE to your Desktop so you can find the installer later #*If you do not have the current version, click on the "Player Download Center" link on the "'''Download and information'''" or "'''Download Manual installers'''" below #*After download is complete, exit Firefox #*Click on the installer you just downloaded and install #**Windows 7 and Vista: may need to right-click the installer and choose "Run as Administrator" #*Start Firefox and check your version again or test the installation by going back to the download link below #*'''Download and information''': http://www.adobe.com/software/flash/about/ #**Use Firefox to go to the above site to update the Firefox plugin (will also install plugin for most other browsers; except IE) #**Use IE to go to the above site to update the IE ActiveX #*'''Download Manual installers'''. #**http://kb2.adobe.com/cps/191/tn_19166.html#main_ManualInstaller #**Note separate links for: #***Plugin for Firefox and most other browsers #***ActiveX for IE

Okulungisiwe ngu Helper7677

Umnikazi wombuzo

No, I posted it from firefox 4 (downloaded from: http://www.mozilla.com/en-US/products/download.html?product=firefox-4.0&os=win&lang=en-US).

The problem is not about Firefox not displaying warning when closing multiple tabs..but I'd like Firefox to remember the tabs I am opening when I close/quit Firefox, so when I start Firefox again, it will reopen the last tabs I am opening.

No, I posted it from firefox 4 (downloaded from: http://www.mozilla.com/en-US/products/download.html?product=firefox-4.0&os=win&lang=en-US). The problem is not about Firefox not displaying warning when closing multiple tabs..but I'd like Firefox to remember the tabs I am opening when I close/quit Firefox, so when I start Firefox again, it will reopen the last tabs I am opening.
mahouneko 0 izisombululo 1 izimpendulo
Kuphostiwe

The solution that Helper7677 provided works. I had to go into about:config and set those booleans back to TRUE in order for FireFox to remember the tabs that were open when I closed FireFox.

The solution that Helper7677 provided works. I had to go into about:config and set those booleans back to TRUE in order for FireFox to remember the tabs that were open when I closed FireFox.

Okulungisiwe ngu mahouneko

birleypete 0 izisombululo 3 izimpendulo
Kuphostiwe

You must be joking!!! If that's the best solution for saving app tabs I'm going back to Safari.

You must be joking!!! If that's the best solution for saving app tabs I'm going back to Safari.

Umnikazi wombuzo

Actually, the solution given by Helper7677 is working. Thanks. :)

Actually, the solution given by Helper7677 is working. Thanks. :)

Umnikazi wombuzo

By the way, I posted this question using newly installed Firefox 4..but why do the SystemDetails (at the right-hand side of the question) display it as Firefox 3.6.9? That's why I was confused when Helper7677 said thatI posted the question from a system using Firefox 3.6.9.

By the way, I posted this question using newly installed Firefox 4..but why do the SystemDetails (at the right-hand side of the question) display it as Firefox 3.6.9? That's why I was confused when Helper7677 said thatI posted the question from a system using Firefox 3.6.9.
Helper7677 165 izisombululo 1653 izimpendulo
Kuphostiwe

mdArch:

Something you installed/downloaded may have changed your User-agent.

Reset your User-agent. See:

Also see: http://en.wikipedia.org/wiki/User_Agent

Finding your Firefox version: Help > About Firefox

'''mdArch''': Something you installed/downloaded may have changed your User-agent. Reset your User-agent. See: *http://support.mozilla.com/es/kb/Websites%20or%20add-ons%20incorrectly%20report%20incompatible%20browser *http://support.mozilla.com/en-US/kb/new?title=Web+sites+or+add-ons+incorrectly+report+incompatible+browser Also see: http://en.wikipedia.org/wiki/User_Agent Finding your Firefox version: Help > About Firefox

Okulungisiwe ngu Helper7677

puppydog12 0 izisombululo 3 izimpendulo
Kuphostiwe

Helper7677 reply work for me with Firefox 4RC Thanks a lot saving tabs on restart and exit was important to me Just follow each step.

Helper7677 reply work for me with Firefox 4RC Thanks a lot saving tabs on restart and exit was important to me Just follow each step.

Okulungisiwe ngu puppydog12

k2mcd 0 izisombululo 1 izimpendulo
Kuphostiwe

Impendulo Ewusizo

Another solution is to go into the Preferences, under General select "When Firefox starts: Show my windows and tabs from last time." This will bring up your tabs after restarting.

Another solution is to go into the Preferences, under General select "When Firefox starts: Show my windows and tabs from last time." This will bring up your tabs after restarting.

Okulungisiwe ngu k2mcd

birleypete 0 izisombululo 3 izimpendulo
Kuphostiwe

Already tried it............ still doesn't work. Goodbye Firefox!

Already tried it............ still doesn't work. Goodbye Firefox!

Umnikazi wombuzo

@birleypete: The first solution should work. Type about:config in the URL/Location/Address bar and press the Enter key. Accept the warning message (promise to be careful). Set each value of these preferences to true (by double-click):

   browser.tabs.warnOnClose

   browser.warnOnQuit
   browser.warnOnRestart
   browser.showQuitWarning
@birleypete: The first solution should work. Type ''about:config'' in the URL/Location/Address bar and press the Enter key. Accept the warning message (promise to be careful). Set each value of these preferences to '''true '''(by double-click): '''browser.tabs.warnOnClose browser.warnOnQuit browser.warnOnRestart browser.showQuitWarning'''
carole2 0 izisombululo 1 izimpendulo
Kuphostiwe

Thank you. Works perfectly now!

Thank you. Works perfectly now!
TheAntiM 0 izisombululo 3 izimpendulo
Kuphostiwe

Mine actually was set by default to "true," and it doesn't save the tabs upon closing, nor give the option. All it does is warn - "warning, you are closing four tabs." I'm not interested in whether it will tell me I'm closing the program, I'm interested in it saving the tabs. It's one of the great features of the old Firefox.

Mine actually was set by default to "true," and it doesn't save the tabs upon closing, nor give the option. All it does is warn - "warning, you are closing four tabs." I'm not interested in whether it will tell me I'm closing the program, I'm interested in it saving the tabs. It's one of the great features of the old Firefox.
Soapmachine 0 izisombululo 1 izimpendulo
Kuphostiwe

I found that "Firefox>Preferences>General>When Firefox starts: Show my windows and tabs from last time" works for me!

I found that "'''Firefox>Preferences>General>When Firefox starts: ''Show my windows and tabs from last time'''''" works for me!

Okulungisiwe ngu Soapmachine

Defender 0 izisombululo 3 izimpendulo
Kuphostiwe

Dear Helper7677,

Your solution worked fine! And, it's different and preferable to setting the general options as: "When Firefox starts: Show my windows and tabs from last time."

I like my browser to launch either as a blank page to avoid wasting time waiting for the pages to load, or as a frequently used page such as the local weather or webmail. Thank you!

Dear Helper7677, Your solution worked fine! And, it's different and preferable to setting the general options as: "When Firefox starts: Show my windows and tabs from last time." I like my browser to launch either as a blank page to avoid wasting time waiting for the pages to load, or as a frequently used page such as the local weather or webmail. Thank you!

Okulungisiwe ngu Defender

Defender 0 izisombululo 3 izimpendulo
Kuphostiwe

I should clarify my remarks. I like having the option of the last session to relaunch on occasion if I'm not done with my work. But generally, I like just a blank page or one oft used quick page to quickly launch. The "Save and Quit" option provides the convenience of quickly having Firefox remember and re-launch with my tabs where I left off when needed. Thanks.

I should clarify my remarks. I like having the option of the last session to relaunch on occasion if I'm not done with my work. But generally, I like just a blank page or one oft used quick page to quickly launch. The "Save and Quit" option provides the convenience of quickly having Firefox remember and re-launch with my tabs where I left off when needed. Thanks.

Umnikazi wombuzo

@TheAntiM: Actually, Firefox 4 does have this "save tabs" feature. Have you check the configuration in about:config? Mine were also set to "true" by default (which I think was from the previous version before I upgraded it to Firefox 4), except for the last preference (browser.showQuitWarning - which Helper7677 said is new in Firefox 4) which was set to "false" by default. Check it again to make sure all the 4 preferences are set to "true".

Or you can try another way: Change "When Firefox starts" to "Show my windows and tabs from last time" in option window.

@TheAntiM: Actually, Firefox 4 does have this "save tabs" feature. Have you check the configuration in about:config? Mine were also set to "true" by default (which I think was from the previous version before I upgraded it to Firefox 4), except for the last preference (browser.showQuitWarning - which Helper7677 said is new in Firefox 4) which was set to "false" by default. Check it again to make sure all the 4 preferences are set to "true". Or you can try another way: Change'' "When Firefox starts"'' to ''"Show my windows and tabs from last time"'' in option window.
birleypete 0 izisombululo 3 izimpendulo
Kuphostiwe

''mdArch'' Did all this but still didn't work! I've gone back to Firefox 3. Thanks for trying anyway.

'''''''mdArch''''''' Did all this but still didn't work! I've gone back to Firefox 3. Thanks for trying anyway.

Okulungisiwe ngu birleypete

mwright12 0 izisombululo 1 izimpendulo
Kuphostiwe

I was having this exact same problem when I upgraded to firefox 4.0. I didnt realise though that the solution is actually really simple. Just go into tools > Options > General Tab > The option that says "When firefox starts", instead of the default "show my homepage", select from the drop down menu the "show my windows and tabs from last time" option. Firefox will then never ask again but saves your tab every time you close. Simple.

I was having this exact same problem when I upgraded to firefox 4.0. I didnt realise though that the solution is actually really simple. Just go into tools > Options > General Tab > The option that says "When firefox starts", instead of the default "show my homepage", select from the drop down menu the "show my windows and tabs from last time" option. Firefox will then never ask again but saves your tab every time you close. Simple.
Mugsy 2 izisombululo 47 izimpendulo
Kuphostiwe

I only had to toggle "browser.warnOnRestart" and "browser.showQuitWarning". The other two were already set to True.

I only had to toggle "browser.warnOnRestart" and "browser.showQuitWarning". The other two were already set to True.