Showing questions tagged: Show all questions

Alpha overlays appear to have screen corruption on some sites

This question relates to my use of Firefox 88 on MacOS 10.14.6 on a dual-GPU retina MacBook Pro (15-inch, 2018). I'm using a dual external monitor set-up, and still runni… (read more)

This question relates to my use of Firefox 88 on MacOS 10.14.6 on a dual-GPU retina MacBook Pro (15-inch, 2018). I'm using a dual external monitor set-up, and still running 10.14 due to 32-bit compatibility issues with some of my (scientific, bespoke) software.

I am pretty sure that there is a very odd, browser-level bug in alpha display on my system that leads to, for example, the overlay of YouTube's UI appearing peppered with row-wise stripes of other colours; or PDF page previews not displaying properly. There is nothing relevant displayed in either the (JS) console log; `dmesg` or MacOS's Console.app application. The appearance of the stripes / corruption is randomly different each time: it is different in private browsing mode to not, for example, and refreshing the page alters their exact appearance.

I have done the obvious things of disabling hardware acceleration -- no change -- trying in a new private window with no extensions / addons loaded -- no difference -- but I do not necessarily want to nuke everything and try again. This problem has existed for as long as I have used FF on this computer, but I am just reporting it now. Mostly it's fine, aside from one variety of captcha that I cannot solve!

I have no idea how to go about debugging this and alas I don't have the time to do it "properly" -- I am on a system with SIP disabled and can easily load up FF in lldb, for example, if someone could give me targeted advice. I am not a web developer and do not know the exact api call that causes this -- but it appears to be used in pdf.js' sidebar page overlay code, but not the actual page itself. Most PNGs, SVGs etc are fine.

Please see the attached series of screenshots – if it's not clear what I've done (the same youtube video in and out of private browsing mode with no extensions, a PDF viewer; and that page reloaded showing a different pattern), please don't hesitate to ask -- the corruption is pretty visible in all cases, I think. The fact that I can screenshot this and share it with you means, I think, that it is not an OS-level graphics driver bug and is probably a rendering bug.

Thanks for your help, and sorry if this is the wrong forum!

Asked by landak123 1 hour ago

Last reply by landak123 1 hour ago

In-view extensions freeze Firefox for 60 seconds

I just installed Firefox (88.0) on a brand new Surface Pro, signed in to my Firefox Account, which gets me my stuff synced over, such as the Grammarly, LastPass and Pushb… (read more)

I just installed Firefox (88.0) on a brand new Surface Pro, signed in to my Firefox Account, which gets me my stuff synced over, such as the Grammarly, LastPass and Pushbullet extensions. I log into those respective applications as needed. I start browsing.

Now, when I open either of those extensions from the menu bar, they open their little in-place window. If I now touch anything in these windows, about 80% of the time the following happens:

  • The little in-place window closes
  • Firefox becomes unresponsive (menus, other controls, web pages, close window)
  • This lasts for 60 seconds (reliably)

However:

  • If the extension is visible on the menu bar: problem happens
  • If the extension is tucked away in ">>" (More tools...): no problem (this is also a decent-ish workaround)

Given that this affects multiple extensions, I'd expect this to be a Firefox issue. Also, I have no idea how to troubleshoot this (I have not been able to find logs).

Things I tried to no avail:

  • Refresh (through installer)
  • Cleaned out profile manually
  • Tried extensions before logging them in

Thank you for your help.

Asked by Sander Verhagen 2 hours ago

Last reply by Sander Verhagen 2 hours ago

SSL_ERROR_BAD_CERT_DOMAIN happening with email links again

Hi all, I'm having a repeat of this issue: https://support.mozilla.org/en-US/questions/1291551 Again some links from emails have been giving me the "Warning: Potential Se… (read more)

Hi all,

I'm having a repeat of this issue: https://support.mozilla.org/en-US/questions/1291551

Again some links from emails have been giving me the "Warning: Potential Security Risk Ahead" page with the error message "SSL_ERROR_BAD_CERT_DOMAIN". I get this in safe mode but not in private browsing. I have tried all of the fixes suggested last time I asked about this problem including deleting cert9.db but that hasn't worked this time (so maybe it wasn't the fix last time either).

To be explicit, I've tried all fixes on these pages so please don't suggest them again without providing an explanation about why you think it will work (a technical explanation please): https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message https://support.mozilla.org/en-US/kb/connection-untrusted-error-message http://kb.mozillazine.org/Error_loading_websites https://support.mozilla.org/en-US/kb/what-does-your-connection-is-not-secure-mean https://support.mozilla.org/en-US/kb/websites-dont-load-troubleshoot-and-fix-errors

And also this one, which is actually related to the message (none of the above are): https://support.mozilla.org/en-US/kb/what-does-your-connection-is-not-secure-mean#w_ssl-error-bad-cert-domain

Some examples of links that I get this message for: https://click.mail10.smallworldlabs.net/ls/click?upn=4FIN3hZFvI-2BP9iq5nue2vk-2BIMF5sm7TLqXM-2BBHmHs4tQjfdaurWm34ztLj9SPiVE4gseyCl-2FaqSWT59ygV9BpAcDzFkriqc5NC2qBiwl5aOaxL8F5mgo-2BFX-2Fgbi7iwZeFhIlJVBY5pUPWQy6owSYMskwXWDY7Y1aaoMS-2BkHbmCPTNSg29Z4JoYD7fjx9bZW5b2-2Fg5dX2SSuZS5csOf3H6IGmB8UNGulRns8j4EzznpinCvgJxocujRrlszMnMzDFaGlZcc-2BWOcJNASuRsaEH6HcXAoqMnLhDAoAdn0UChLWOY-2FfbP2Ib-2FUEDr6NloUbD-2FnHqHVVYd821nihjMp740-2F5x7GMXZmwRiFR7H2o2PqTC4rmR-2BSqxJ-2BuAl15SvxjWYbO9ClP8PSHw5pY80IikJqK10tVO8wFNKUY0vnffi80-3DW8m3_a4b-2FpboTDHPk-2BrdoYKQMvkNzRfSbL-2BRxE8OVpRrBC237mTF3qcpluLuTnfAWEU7fFwhhtOg-2BbDd1pxD5bmCpb3y8948sPEH5oTF-2Fsg1k82R-2Be5SnCvGNogmdD1MB5K11JV0Ow8rxc63etMs7M6GZzfslGWbxLHW9hydaH2RME5RPXqcBAsIRau-2FizQsq15rW5BclijLm23gWXw-2BvlJjO8gxiJ-2BQwpw2wvKihYGT4DKxPTObnz-2Fpn1ua2ng0ah-2BN1xDub-2Bav5GSEDaq4OPiG8JUArfSPtya-2ByoEn6CzLpZaqsLJ5rbTCztuAV25pOmNhojUORS-2Fnyv8FFlz-2Fh4EX6xolAvA1UgOdaXT3xescKfmROnAvFsYyB88QxIKBXi1-2Br

Web sites prove their identity via certificates. Firefox does not trust this site because it uses a certificate that is not valid for click.mail10.smallworldlabs.net. The certificate is only valid for the following names: *.sendgrid.net, sendgrid.net

Error code: SSL_ERROR_BAD_CERT_DOMAIN

https://click.topgear.bbc.com/?qs=c719f0befb99016fe4d64e88dc7ec435f7eee7452916295aaa562fc47d530c91af5900c5d298ac67019e3560abca9b8eab0be3a91e8e632f

Firefox does not trust this site because it uses a certificate that is not valid for click.topgear.bbc.com. The certificate is only valid for origin-click.s6.exacttarget.com.

Error code: SSL_ERROR_BAD_CERT_DOMAIN

Please tell me if you need more info. All helpful suggestions much appreciated.

Thanks :)

Asked by madbilly 2 hours ago

Downloading attachments causes email to close and return to inbox - how to stop this?

Every time I try to download attachments, the original email closes and I am returned to the inbox. Not so much of a problem if I am working from the inbox, but an absolu… (read more)

Every time I try to download attachments, the original email closes and I am returned to the inbox. Not so much of a problem if I am working from the inbox, but an absolute pain when I am working from sub-folders.

How can I stop this?

Thanks,

Shaun.

Asked by Shaun D. McLewin 4 hours ago

Browser Display Issues

Hello, Since the last windows update, I have been having trouble with Firefox. Please see attached images for example. I have tried a refresh and even a re-install of the… (read more)

Hello,

Since the last windows update, I have been having trouble with Firefox. Please see attached images for example. I have tried a refresh and even a re-install of the browser but no resolution.

I appreciate your help.

Asked by mghaly 14 hours ago

Last reply by jscher2000 6 hours ago

Widevinecdm crashing since updating to 78.10.0esr

Streaming accounts like Spotify, Netflix, Apple TV+, Disney+, etc are all no longer playing since I updated to 78.10.0esr This version is supposed to be compatible with m… (read more)

Streaming accounts like Spotify, Netflix, Apple TV+, Disney+, etc are all no longer playing since I updated to 78.10.0esr This version is supposed to be compatible with my version of OS X 10.9.5 I keep having Firefox crash with this error. Widevinecdm plugin has crashed. Learn more...and when I click on Learn more, there's nothing there that helps.

Can anyone help? Thank you.

Asked by brad46 7 hours ago

Last reply by HenricuzHotmail 7 hours ago

Amazon Music Crashing: Widevinecdm?

Amazon Music suddenly won't play/started crashing. A yellow bar comes up on top of the screen saying The Widevinecdm has crashed. It was running fine until yesterday and … (read more)

Amazon Music suddenly won't play/started crashing. A yellow bar comes up on top of the screen saying The Widevinecdm has crashed. It was running fine until yesterday and I can't think of any changes I've made. Or did I update Firefox, it's so automatic I don't remember. I'm running OS 10.9.5 on an older Macbook Pro with Firefox 78.10. Thanks.

Asked by sabatia7 9 hours ago

Last reply by HenricuzHotmail 7 hours ago

Grumpy old fogey says why not leave what is working work...

I am an old fart (76) and had firefox reasonably set up and nor this tired old brain must remember how it was and how to jump through the hoops that the juveniles thought… (read more)

I am an old fart (76) and had firefox reasonably set up and nor this tired old brain must remember how it was and how to jump through the hoops that the juveniles thought as better... Give me a break !! the complaint I had which I found a workaround was to DELETE up to 1G of cookies so I had a little usable ram and space on my HDD... Some of the cookies were HUGE... My OS has been Linux mint or other flavours of Linux since about 1990 and used to boot in less than 20 seconds, then it would load the previous days applications where I left off in another 10 seconds... Now, judging by the sixes of the files downloaded to refresh Firefox you are writing BLOATWARE WTF... Why do you think I would not touch Intel & windoze? DAZE of compulsory Amerikan speling & corporate spying are numbered if this keeps deteriorating... 20,000 cookies a day? and how big is the file to install firefox... That is what I call BLOATWARE...

I watch informative YT but when it gets boringly repetitive I just scan what is force fed in the vain hope I will spot something of interest... 90% is crap, or dumb'ed down BS to find a few paste jewels...

My brain is somewhat addled with Dementia, and afflicted with aspects of Asperger's Syndrome, Bi polar disorder... Give me a break Please...

Asked by Brian Ballard 7 hours ago

WidevineCdm plugin crash

Last week (14 April 2021) I was able to watch videos on netflix and hulu. This week (21 April 2021), however, a yellow bar appears across the top of the page, saying, on … (read more)

Last week (14 April 2021) I was able to watch videos on netflix and hulu. This week (21 April 2021), however, a yellow bar appears across the top of the page, saying, on the left-hand side: "The WidevineCdm plugin has crashed Learn more...", and, on the right-hand side, "[Reload page] [Submit a crash report]". Repeated submissions of crash reports, as well as repeated reloading of the page, results in exactly the same: same yellow bar, same inability to watch videos. Likewise, clicking on "Learn more" merely results in the widevine.com page, which states that the company does not service end-users. In addition, last week (14 April 2021), I purchased a video on youtube, and watched part of it. This week (21 April 2021), wanting to watch the rest of the video, all I encounter is: "Your browser can't play this video. Learn more." Clicking on "Learn more" yields "Your browser is up to date. You can use YouTube's latest features!" Repeat ad nauseam. So, it seems that, even though my browser is up-to-date, I am still unable to watch videos on either youtube, hulu, or netflix.

Asked by maikstrik 1 day ago

Last reply by HenricuzHotmail 11 hours ago

WidevineCdm Crash

When I try to use a platform like Netflix i get repeated error messages that WidevineCdm has crashed. This happens also in other browsers. I am not very tech savvy, but I… (read more)

When I try to use a platform like Netflix i get repeated error messages that WidevineCdm has crashed. This happens also in other browsers. I am not very tech savvy, but I've tried all the solutions I was able to understand on here and through Google, but nothing seems to fix the problem. Can any one advise?

Not sure if this helps, but here is one of the many crash reports I've sent: https://crash-stats.mozilla.org/report/index/75e61622-4282-4a83-b86e-9861a0210422

Asked by jennifer.juba 15 hours ago

Last reply by FredMcD 11 hours ago

Widevine CDM plug-in issue. Not able to stream any video..

I'm not able to stream any content on Netflix, Amazon Prime, channel 4, 5 using firefox. The error message is 'The widevine CDM plugin has crashed'. I looked up in pref… (read more)

I'm not able to stream any content on Netflix, Amazon Prime, channel 4, 5 using firefox. The error message is 'The widevine CDM plugin has crashed'. I looked up in preferences/ extensions and themes/ plug ins and it seems like the widevine CDM plug-in was automatically updated today (21.4.2021) and now it's crashing. My firefox is 78.10, the latest for OSX 10.9. Can anyone suggest how to resolve this ?

Asked by n.akhtar42 1 day ago

Last reply by HenricuzHotmail 11 hours ago

Initiating PayPal

When using Paypal to pay for a purchase, from EBAY, the login screen for Paypal hangs, is not displayed, It does work when using IE (last version). It did work properly… (read more)

When using Paypal to pay for a purchase, from EBAY, the login screen for Paypal hangs, is not displayed, It does work when using IE (last version). It did work properly up to a couple of weeks ago.

Asked by gshillington 13 hours ago

Last reply by FredMcD 11 hours ago

  • Solved

Firefox not working at all.

Was deleting bloatware, being very careful of course. Somehow VCRUNTIME140_1.dll got deleted/corrupted. Firefox could not find the dll file. Found, and installed new dll … (read more)

Was deleting bloatware, being very careful of course. Somehow VCRUNTIME140_1.dll got deleted/corrupted. Firefox could not find the dll file. Found, and installed new dll file. I can download and run browser, but the bookmarks I have left after install don't work, starting Firefox in safe mode was no help. Trying to change profile, typing about:profiles in address bar does not take me anywhere. I have uninstalled and reinstalled Firefox many times, to no avail. I'm turning to you for help, suggestions please.

Asked by jbriordan 16 hours ago

Answered by TyDraniu 15 hours ago

Page Display Issues

I've recently started seeing Firefox not displaying correctly. This includes the page itself as well as the tabs. Letters will be missing, colors incorrect, as well as ju… (read more)

I've recently started seeing Firefox not displaying correctly. This includes the page itself as well as the tabs. Letters will be missing, colors incorrect, as well as just being illegible as in the images provided. Image 1 - tab names missing and the green color is not the correct one for that part of the page. Image 2 - Get Help menu options unreadable along with tab names missing.

Asked by fnr 1 day ago

Last reply by ·´¯`·...¸>-)))º> ~dbben 16 hours ago

WidevineCdm plugin crashing

Hello, since the last automatic update of the Widevine Content Decryption Module (updated today, automatically) the plugin keeps crashing when I want to watch "TV" waipu… (read more)

Hello,


since the last automatic update of the Widevine Content Decryption Module (updated today, automatically) the plugin keeps crashing when I want to watch "TV" waipu.tv. I have already re-installed firefox etc, it just won't work.

I have submitted several crash reports, this is the latest: bp-7bc4b8a4-e59b-4f7e-a840-7c0720210422

See screenshot of "crashed"-notice below.

What can I do to fix this?

Asked by Kat 16 hours ago

Firefox hangs for hours when starting or opening new tab or window.

I rarely ask for help and try on my own and frequently help others, but I have a problem that I cannot solve and need your help, please. I have tried the typical things … (read more)

I rarely ask for help and try on my own and frequently help others, but I have a problem that I cannot solve and need your help, please.

I have tried the typical things such as restarting, starting in safe mode, refreshing, reinstalling, uninstall and delete folders and profiles then re-install, uninstall and delete folders and profiles and remove all Mozilla/FF entries in the registry then reinstall. No plugins or addons installed.

I tried disabling my anti-virus software.

I have FF version 87.0 64 bit version and even tried with an older 32 bit version. My OS is Windows 10 version 20H2 OS Build 19042.928. Both are the latest versions at the time of this post.


Regardless of what I try, my problem below persists:

When I start FF it almost starts but hangs. I can see it listed in the Task Manager. There is a little activity with Memory and CPU usage for a few seconds then no more. I cannot End Task if I try. It will hang like this for hours. Eventually I will get the home screen. If I attempt to visit a website right away it hangs (two dots blinking left & right like a school bus in the tab). If I do not try to visit a website but wait for a few more hours it will usually connect and be OK. However, if I open a new tab or Private Window I have the same problem in the new one.

Once it is up and running it appears to be working normally except for the new tabs. I have been hibernating my computer with FF open rather than shut down so that I can use it the next day. However, after a number of hours or on another day it will suddenly hang again for an unknown reason. Then I reboot and start the procedure all over.

I have tried every fix I can think of for FF. The problem may be an issue with Windows, but Microsoft has no bulletins or fixes for this one. I have updated to the latest build/version but nothing has changed. Very frustrating.

Any suggestions beyond the things I have already tried would be greatly appreciated. Thank you.

Asked by LakesideRon 19 hours ago

Last reply by LakesideRon 17 hours ago

shutdownhang Firefox

The browser hangs while loading pages for a few minutes, then works fine for a while and the same thing again. The crash description says: MOZ_CRASH Reason (Sanitized) Sh… (read more)

The browser hangs while loading pages for a few minutes, then works fine for a while and the same thing again. The crash description says: MOZ_CRASH Reason (Sanitized) Shutdown hanging at step profile-before-change. Something is blocking the main-thread. ID crashes bp-6d847054-2b84-48de-85db-d854f0210422 bp-23a15938-bbd1-4c13-94fc-08db10210422 bp-d8cb25b9-82dc-4212-8173-f3cb20210422

What can I do to fix the problem? Reinstalling the browser did nothing

Asked by artszulc 19 hours ago

Last reply by FredMcD 17 hours ago