X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Firefox 29 is full of problems.

Posted

- Session restore brings up tabs that I had closed before closing Firefox. Sometimes it even selects a tab that I didn't have selected when I closed it.

- Leaking memory like nobody's business. It went from 500 MB to 1.5 GB overnight (i.e. while it was "idling" minimized on the desktop).

- The config.trim_on_minimize setting is missing. Why is this?

- When the memory usage gets above ~1 GB (FYI, this is a guess), I start seeing problems with Firefox displaying web-page graphics and even, in one instance, shutting down text input on a web page (this was within Facebook).

- Randomly crashes for no apparent reason. FYI, this happened after I updated to Firefox 28 as well.

None of these problems ever happened before I upgraded to Firefox 28 and 29. I'm very close to abandoning Firefox altogether if these problems are not resolved promptly and permanently. In other words, I've nearly had enough of this. Whatever happened to "If it ain't broke, don't fix it"?

- Session restore brings up tabs that I had closed before closing Firefox. Sometimes it even selects a tab that I didn't have selected when I closed it. - Leaking memory like nobody's business. It went from 500 MB to 1.5 GB overnight (i.e. while it was "idling" minimized on the desktop). - The config.trim_on_minimize setting is missing. Why is this? - When the memory usage gets above ~1 GB (FYI, this is a guess), I start seeing problems with Firefox displaying web-page graphics and even, in one instance, shutting down text input on a web page (this was within Facebook). - Randomly crashes for no apparent reason. FYI, this happened after I updated to Firefox 28 as well. None of these problems ever happened before I upgraded to Firefox 28 and 29. I'm very close to abandoning Firefox altogether if these problems are not resolved promptly and permanently. In other words, I've nearly had enough of this. Whatever happened to "If it ain't broke, don't fix it"?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 13.0 r0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 10.55.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Shockwave Flash 12.0 r0
  • 5.1.30214.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • iTunes Detector Plug-in
  • Citrix Online App Detector Plugin
  • wpidetector
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0

More Information

Moses
  • Moderator
412 solutions 3340 answers

- Leaking memory like nobody's business. It went from 500 MB to 1.5 GB overnight (i.e. while it was "idling" minimized on the desktop).

Please see: https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram

- When the memory usage gets above ~1 GB (FYI, this is a guess), I start seeing problems with Firefox displaying web-page graphics and even, in one instance, shutting down text input on a web page (this was within Facebook). 

Try disabling Hardware Acceleration.

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

- Randomly crashes for no apparent reason. FYI, this happened after I updated to Firefox 28 as well. 

Can you give me your crash reports?

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and paste them into your response here.
- Leaking memory like nobody's business. It went from 500 MB to 1.5 GB overnight (i.e. while it was "idling" minimized on the desktop). Please see: https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram - When the memory usage gets above ~1 GB (FYI, this is a guess), I start seeing problems with Firefox displaying web-page graphics and even, in one instance, shutting down text input on a web page (this was within Facebook). Try disabling Hardware Acceleration. <br> #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. - Randomly crashes for no apparent reason. FYI, this happened after I updated to Firefox 28 as well. Can you give me your crash reports? #Enter ''about:crashes'' in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below. #Copy the '''5''' most recent Report IDs that start with '''bp-''' and paste them into your response here.

Question owner

Regarding Adobe Flash Player, I never had to change the hardware-acceleration settings before. Why should I have to now? What's changed with Firefox?

I don't consider the link you gave about memory usage to be helpful. Again, what has changed with Firefox since version 28/29? My browsing experience has gotten worse, not better.

Here are my last 5 crash report IDs:

bp-097b4458-9e78-4e97-a9c7-2244e2140503 bp-eb664b37-4769-4c79-97e6-0999d2140502 bp-c59ca660-a87c-4c29-acee-871362140501 bp-2e6c4e68-1fb3-4a1a-bda9-464f62140429 bp-1aaaa437-f79c-405c-93b4-2b6f42140215

Regarding Adobe Flash Player, I never had to change the hardware-acceleration settings before. Why should I have to now? What's changed with Firefox? I don't consider the link you gave about memory usage to be helpful. Again, what has changed with Firefox since version 28/29? My browsing experience has gotten worse, not better. Here are my last 5 crash report IDs: bp-097b4458-9e78-4e97-a9c7-2244e2140503 bp-eb664b37-4769-4c79-97e6-0999d2140502 bp-c59ca660-a87c-4c29-acee-871362140501 bp-2e6c4e68-1fb3-4a1a-bda9-464f62140429 bp-1aaaa437-f79c-405c-93b4-2b6f42140215

Question owner

Firefox just crashed on me again: bp-0c3a566d-3b05-4fdf-aaa8-a8b5c2140506

Firefox just crashed on me again: bp-0c3a566d-3b05-4fdf-aaa8-a8b5c2140506
Moses
  • Moderator
412 solutions 3340 answers


I don't consider the link you gave about memory usage to be helpful. Again, what has changed with Firefox since version 28/29? My browsing experience has gotten worse, not better. '

I find that link extremely useful in your case. If Firefox is using too much RAM that should fix it. Here's another one for that above case

That crash report above is associated with graphics which is the reason I suggested you turn off hardware acceleration. I actually gave you the wrong advice to try as the above is for Flash and not Firefox.

Perform these steps for firefox 29.0 version and above:

  • Click the menu button New Fx Menu and select {button Options} for Windows or {button Preferences} on Mac or Linux. For firefox 28.0 and previous versions click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

''<br>I don't consider the link you gave about memory usage to be helpful. Again, what has changed with Firefox since version 28/29? My browsing experience has gotten worse, not better. ' I find that link extremely useful in your case. If Firefox is using too much RAM that should fix it. Here's another one for that above case *https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix That crash report above is associated with graphics which is the reason I suggested you turn off hardware acceleration. I actually gave you the wrong advice to try as the above is for Flash and not Firefox. Perform these steps for firefox 29.0 version and above: *Click the menu button [[Image:New Fx Menu]] and select {button Options} for Windows or {button Preferences} on Mac or Linux. For firefox 28.0 and previous versions click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]]

Modified by Moses

Moses
  • Moderator
412 solutions 3340 answers

Also, two of your crash reports has a @NS_ABORT_OOM and a @moz_alloc signature which means that your system ran out of memory. You can try to increase the size of the page file in Windows to see if that helps any.

Also, two of your crash reports has a @NS_ABORT_OOM and a @moz_alloc signature which means that your system ran out of memory. You can try to increase the size of the page file in Windows to see if that helps any. *http://support.microsoft.com/kb/2160852

Helpful Reply

With all due respect, either you don't understand what I've been saying, or you're deliberately ignoring it. Before I upgraded to version 28, Firefox didn't crash due to memory issues. It would use over 1.5 GB on my system (as shown by Process Explorer) with no problems. So I ask you again, what has changed with Firefox?

Same thing with your advice to disable hardware acceleration for Firefox graphics. I didn't have to do this before. Is hardware acceleration a new feature in Firefox 28/29? Or what? Again... what has changed with Firefox?

Same thing with your advice to increase the size of the page file in Windows. I didn't have to do this before, when Firefox was taking up even more memory while running on my system. So for the third time (in this post)... What. Has. Changed. With. Firefox?

With all due respect, either you don't understand what I've been saying, or you're deliberately ignoring it. Before I upgraded to version 28, Firefox didn't crash due to memory issues. It would use over 1.5 GB on my system (as shown by Process Explorer) with no problems. So I ask you again, what has changed with Firefox? Same thing with your advice to disable hardware acceleration for Firefox graphics. I didn't have to do this before. Is hardware acceleration a new feature in Firefox 28/29? Or what? Again... what has changed with Firefox? Same thing with your advice to increase the size of the page file in Windows. I didn't have to do this before, when Firefox was taking up even more memory while running on my system. So for the third time (in this post)... What. Has. Changed. With. Firefox?
Moses
  • Moderator
412 solutions 3340 answers

With all due respect, either you don't understand what I've been saying, or you're deliberately ignoring it. Before I upgraded to version 28, Firefox didn't crash due to memory issues. It would use over 1.5 GB on my system (as shown by Process Explorer) with no problems. So I ask you again, what has changed with Firefox?

I understand what you're saying, I'm not stupid. Every system is different in how it handles the newest version. My computer jacks up Firefox's RAM usage to 3.5 GB all the time and I have 8GB and I disabled hardware acceleration. Didn;t have to in 28. Works fine in 32.0a2. That said, it's a system-by-system case. What's happening for you may not be happening for others. I'm sorry if I don't have a better explanation than that.

Same thing with your advice to disable hardware acceleration for Firefox graphics. I didn't have to do this before. Is hardware acceleration a new feature in Firefox 28/29? Or what? Again... what has changed with Firefox?

Read above...

Same thing with your advice to increase the size of the page file in Windows. I didn't have to do this before, when Firefox was taking up even more memory while running on my system. So for the third time (in this post)... What. Has. Changed. With. Firefox?

I saw your crash reports. If you want to break it down for you, I will

1. First linked crash report (https://crash-stats.mozilla.com/report/index/097b4458-9e78-4e97-a9c7-2244e2140503)

  • Your system ran out of memory. Notice the OOM (out-of-memory) Your System Use Percentage was at 74. Pretty normal for a OOM crash

2. Second linked crash report (https://crash-stats.mozilla.com/report/index/eb664b37-4769-4c79-97e6-0999d2140502)

  • The crash signature @gfxContext::PushGroupAndCopyBackground(gfxContentType tells me that this is an issue with graphics. Disabling HA and updating your graphics card fix this. (case-by-case)

3. Third linked crash report (https://crash-stats.mozilla.com/report/index/c59ca660-a87c-4c29-acee-871362140501)

  • Crash signature is moz_alloc which means Firefox had trouble allocating memory. That's why I suggested increasing the page file

4. Fourth linked crash report (https://crash-stats.mozilla.com/report/index/2e6c4e68-1fb3-4a1a-bda9-464f62140429)

  • The crash signature @gfxContext::PushGroupAndCopyBackground(gfxContentType tells me that this is an issue with graphics. Disabling HA and updating your graphics card fix this. (case-by-case)

5. Fifth linked crash report (https://crash-stats.mozilla.com/report/index/bp-1aaaa437-f79c-405c-93b4-2b6f42140215)

  • Crash signature is moz_alloc which means Firefox had trouble allocating memory. That's why I suggested increasing the page file

6. Sixth linked crash report (https://crash-stats.mozilla.com/report/index/0c3a566d-3b05-4fdf-aaa8-a8b5c2140506)

  • The crash signature @gfxContext::PushGroupAndCopyBackground(gfxContentType tells me that this is an issue with graphics. Disabling HA and updating your graphics card fix this. (case-by-case)
''With all due respect, either you don't understand what I've been saying, or you're deliberately ignoring it. Before I upgraded to version 28, Firefox didn't crash due to memory issues. It would use over 1.5 GB on my system (as shown by Process Explorer) with no problems. So I ask you again, what has changed with Firefox? '' I understand what you're saying, I'm not stupid. Every system is different in how it handles the newest version. My computer jacks up Firefox's RAM usage to 3.5 GB all the time and I have 8GB and I disabled hardware acceleration. Didn;t have to in 28. Works fine in 32.0a2. That said, it's a system-by-system case. What's happening for you may not be happening for others. I'm sorry if I don't have a better explanation than that. ''Same thing with your advice to disable hardware acceleration for Firefox graphics. I didn't have to do this before. Is hardware acceleration a new feature in Firefox 28/29? Or what? Again... what has changed with Firefox? '' Read above... ''Same thing with your advice to increase the size of the page file in Windows. I didn't have to do this before, when Firefox was taking up even more memory while running on my system. So for the third time (in this post)... What. Has. Changed. With. Firefox? '' I saw your crash reports. If you want to break it down for you, I will 1. First linked crash report (https://crash-stats.mozilla.com/report/index/097b4458-9e78-4e97-a9c7-2244e2140503) *Your system ran out of memory. Notice the OOM (out-of-memory) Your System Use Percentage was at 74. Pretty normal for a OOM crash 2. Second linked crash report (https://crash-stats.mozilla.com/report/index/eb664b37-4769-4c79-97e6-0999d2140502) *The crash signature '''@gfxContext::PushGroupAndCopyBackground(gfxContentType''' tells me that this is an issue with graphics. Disabling HA and updating your graphics card fix this. (case-by-case) 3. Third linked crash report (https://crash-stats.mozilla.com/report/index/c59ca660-a87c-4c29-acee-871362140501) *Crash signature is moz_alloc which means Firefox had trouble allocating memory. That's why I suggested increasing the page file 4. Fourth linked crash report (https://crash-stats.mozilla.com/report/index/2e6c4e68-1fb3-4a1a-bda9-464f62140429) *The crash signature '''@gfxContext::PushGroupAndCopyBackground(gfxContentType''' tells me that this is an issue with graphics. Disabling HA and updating your graphics card fix this. (case-by-case) 5. Fifth linked crash report (https://crash-stats.mozilla.com/report/index/bp-1aaaa437-f79c-405c-93b4-2b6f42140215) *Crash signature is moz_alloc which means Firefox had trouble allocating memory. That's why I suggested increasing the page file 6. Sixth linked crash report (https://crash-stats.mozilla.com/report/index/0c3a566d-3b05-4fdf-aaa8-a8b5c2140506) *The crash signature '''@gfxContext::PushGroupAndCopyBackground(gfxContentType''' tells me that this is an issue with graphics. Disabling HA and updating your graphics card fix this. (case-by-case)

Modified by Moses

Question owner

If you can't explain to me what has changed with Firefox in version 28 and/or 29, then please get me someone who can.

If you can't explain to me what has changed with Firefox in version 28 and/or 29, then please get me someone who can.
Moses
  • Moderator
412 solutions 3340 answers

If you can't explain to me what has changed with Firefox in version 28 and/or 29, then please get me someone who can.

Alright then. I've tagged this thread as escalate. I'll drop myself from this thread since my suggestions prove to be ignored.


Note: You should really try to do the steps I've suggested since I spent about 5 minutes to actually spell out what the crashes mean and since they would normally fix crashes like this but instead you choose to argue with me over the changes which can be found from a Google search by doing it yourself

''If you can't explain to me what has changed with Firefox in version 28 and/or 29, then please get me someone who can. '' Alright then. I've tagged this thread as escalate. I'll drop myself from this thread since my suggestions prove to be ignored. ---- Note: You should really try to do the steps I've suggested since I spent about 5 minutes to actually spell out what the crashes mean and since they would normally fix crashes like this but instead you choose to argue with me over the changes which can be found from a Google search by doing it yourself *http://www.mozilla.org/en-US/firefox/29.0/releasenotes/

Modified by Moses

Question owner

Thanks for the escalation. Let me make myself clearer: what I want is for the *causes* of these issues to be *identified* and *fixed*. In other words, I'm looking for *fixes*, not *work-arounds*. I thought that was implied by what I wrote previously, but I guess I was wrong.

I don't consider those release notes to be helpful. But I see you felt the need to try to backhandedly insult my intelligence. Not exactly becoming of a *moderator* in a *support forum*, is it? I don't think so.

Thanks for the escalation. Let me make myself clearer: what I want is for the *causes* of these issues to be *identified* and *fixed*. In other words, I'm looking for *fixes*, not *work-arounds*. I thought that was implied by what I wrote previously, but I guess I was wrong. I don't consider those release notes to be helpful. But I see you felt the need to try to backhandedly insult my intelligence. Not exactly becoming of a *moderator* in a *support forum*, is it? I don't think so.

Modified by robbyrob

Moses
  • Moderator
412 solutions 3340 answers

But I see you felt the need to try to backhandedly insult my intelligence. Not exactly becoming of a *moderator* in a *support forum*, is it? I don't think so.

You do know I'm a volunteer, right? No Mozilla developers or employees post here. I come on my free time and assist users and tell them the information I have. Almost everyone on this site are volunteers doing this on their own time. Also, I apologize if my last message proved insulting. I meant no disrespect.

Thanks for the escalation. Let me make myself clearer: what I want is for the *causes* of these issues to be *identified* and *fixed*. In other words, I'm looking for *fixes*, not *work-arounds*. I thought that was implied by what I wrote previously, but I guess I was wrong.

Mozilla is releasing an 29.0.1 on Friday that will fix issues that have been reported in the forum and on Mozilla's bug tracking platform, Bugzilla. I don't know what's been gathered but it should fix problems.

EDIT: SEE https://support.mozilla.org/en-US/forums/contributors/710243?last=59399#post-59399 for the list of changes happening in 29.0.1

However, this update won't fix your crashes. The suggestions provide above will.

''But I see you felt the need to try to backhandedly insult my intelligence. Not exactly becoming of a *moderator* in a *support forum*, is it? I don't think so. '' You do know I'm a volunteer, right? No Mozilla developers or employees post here. I come on my free time and assist users and tell them the information I have. Almost everyone on this site are volunteers doing this on their own time. Also, I apologize if my last message proved insulting. I meant no disrespect. ''Thanks for the escalation. Let me make myself clearer: what I want is for the *causes* of these issues to be *identified* and *fixed*. In other words, I'm looking for *fixes*, not *work-arounds*. I thought that was implied by what I wrote previously, but I guess I was wrong. '' Mozilla is releasing an 29.0.1 on Friday that will fix issues that have been reported in the forum and on Mozilla's bug tracking platform, Bugzilla. I don't know what's been gathered but it should fix problems. '''EDIT: SEE https://support.mozilla.org/en-US/forums/contributors/710243?last=59399#post-59399 for the list of changes happening in 29.0.1''' However, this update won't fix your crashes. The suggestions provide above will.

Question owner

Whether you're a volunteer or not is irrelevant to my point. The last thing I'd expect of a moderator in a support forum is to (try to) belittle someone who came in to report sudden, unexpected problems with his installation of the software that the support forum is *ostensibly* there to, you know, *support*. If you really didn't mean any disrespect, then I guess I'll take your word for it, but I don't really know how else to take that comment of yours except as a "parting shot" because I wouldn't just sit down, shut up, and (try to) use the work-arounds like a good little boy.

To date, the problems I've reported with Firefox 28/29 have not at all been resolved to my satisfaction. I'll repeat that I do *not* consider work-arounds to be solutions. If I have to disable hardware acceleration to keep the latest version of Firefox from randomly crashing, when previously I didn't have to do so, then I consider the latest version of Firefox to be *broken*. And it will *remain* broken in my mind until it stops randomly crashing. I don't know how many ways I can say this. In my mind, Firefox's software quality has severely decreased with these latest two releases. And to date, I've received exactly zero explanations for *why*. Clearly I'm more than a bit frustrated, and I think it's easy to understand (but I'm probably biased).

I've been using Firefox for years. I've never been 100% happy with it, to be honest. It uses way too much memory IMO, even before these latest releases (but now I think it's much, much worse). Also, not too long ago there was the whole rigamarole with Mozilla pushing a new "native" PDF reader in Firefox - but this PDF reader sucked. I posted an answer to another support question outlining the relative pain I went through to get the Adobe Reader plugin working properly again. However, none of that was enough to motivate me to abandon Firefox in favor of another browser. I still thought Firefox was better than the alternatives. This situation is different. I was hoping to not see the PDF-reader fiasco as the start of a trend of Mozilla alienating its users, but now I'm starting to think I was foolish for hoping that. Things seem to be getting worse with Firefox, not better. If they continue to get worse, it won't be long before I leave - for whatever that's worth.

Whether you're a volunteer or not is irrelevant to my point. The last thing I'd expect of a moderator in a support forum is to (try to) belittle someone who came in to report sudden, unexpected problems with his installation of the software that the support forum is *ostensibly* there to, you know, *support*. If you really didn't mean any disrespect, then I guess I'll take your word for it, but I don't really know how else to take that comment of yours except as a "parting shot" because I wouldn't just sit down, shut up, and (try to) use the work-arounds like a good little boy. To date, the problems I've reported with Firefox 28/29 have not at all been resolved to my satisfaction. I'll repeat that I do *not* consider work-arounds to be solutions. If I have to disable hardware acceleration to keep the latest version of Firefox from randomly crashing, when previously I didn't have to do so, then I consider the latest version of Firefox to be *broken*. And it will *remain* broken in my mind until it stops randomly crashing. I don't know how many ways I can say this. In my mind, Firefox's software quality has severely decreased with these latest two releases. And to date, I've received exactly zero explanations for *why*. Clearly I'm more than a bit frustrated, and I think it's easy to understand (but I'm probably biased). I've been using Firefox for years. I've never been 100% happy with it, to be honest. It uses way too much memory IMO, even before these latest releases (but now I think it's much, much worse). Also, not too long ago there was the whole rigamarole with Mozilla pushing a new "native" PDF reader in Firefox - but this PDF reader sucked. I posted an answer to another support question outlining the relative pain I went through to get the Adobe Reader plugin working properly again. However, none of that was enough to motivate me to abandon Firefox in favor of another browser. I still thought Firefox was better than the alternatives. This situation is different. I was hoping to not see the PDF-reader fiasco as the start of a trend of Mozilla alienating its users, but now I'm starting to think I was foolish for hoping that. Things seem to be getting worse with Firefox, not better. If they continue to get worse, it won't be long before I leave - for whatever that's worth.
guigs
  • Top 25 Contributor
  • Administrator
  • Moderator
1038 solutions 11342 answers

Hi robbyrob, First, thank you for the crash reports. This is an on going issue with graphics acceleration and it is being addressed in

  • Bug 805406 - crash in gfxContext::PushClipsToDT with Direct2D 1.1 (d3d11.dll 6.2 or 6.3)

https://bugzilla.mozilla.org/page.cgi?id=etiquette.html

D2d is blocklisted for Firefox 21, and the current nightly version 31/32 is being monitored to less crashes. Now there are patches pending and performance monitoring being preformed on the patches.

For identification:

  • Bug 902952 - Use Direct2D 1.1 on mozilla-central , please feel free to look at different bug descriptions at your leisure for *fixed* :-)

For current plan:

  • Milestone for this issue is version 30. So it will be a while before non Firefox Beta is affected by the changes made.

It is not a work around, but the changes can be seen in version 30. If you continue to see crashes in the next version, I am happy to add them to the bug to see if there is more info. If you have any other questions, we are happy to help.

Hi robbyrob, First, thank you for the crash reports. This is an on going issue with graphics acceleration and it is being addressed in *Bug 805406 - crash in gfxContext::PushClipsToDT with Direct2D 1.1 (d3d11.dll 6.2 or 6.3) [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html] D2d is blocklisted for Firefox 21, and the current nightly version 31/32 is being monitored to less crashes. Now there are patches pending and performance monitoring being preformed on the patches. For identification: *Bug 902952 - Use Direct2D 1.1 on mozilla-central , please feel free to look at different bug descriptions at your leisure for *fixed* :-) For current plan: *Milestone for this issue is version 30. So it will be a while before non Firefox Beta is affected by the changes made. It is not a work around, but the changes can be seen in version 30. If you continue to see crashes in the next version, I am happy to add them to the bug to see if there is more info. If you have any other questions, we are happy to help.

Question owner

Thanks for the reply. However, I'm not sure whether those bugs are applicable to my situation. My system is running Windows XP, whereas Direct2D is only supported by Windows Vista and above.

Thanks for the reply. However, I'm not sure whether those bugs are applicable to my situation. My system is running Windows XP, whereas Direct2D is only supported by Windows Vista and above.
renascent 0 solutions 21 answers

I want the add on bar at the bottom for my Reminder Fox and Weather. HOW do we get this back? It was there in FF 28. I loathe the constant tabs at the top as well. I did download the add on to help with this and I did change the configuration to false. It does nothing for FF29. I really wish Firefox would just do security updates and leave the rest alone. I will leave as well and go to Chrome if this isn't resolved.

I want the add on bar at the bottom for my Reminder Fox and Weather. HOW do we get this back? It was there in FF 28. I loathe the constant tabs at the top as well. I did download the add on to help with this and I did change the configuration to false. It does nothing for FF29. I really wish Firefox would just do security updates and leave the rest alone. I will leave as well and go to Chrome if this isn't resolved.
Moses
  • Moderator
412 solutions 3340 answers

renascent:

You can use either of the following add-ons.

If you don't want to install an add-on, put the following style in the userChrome.css file and restart Firefox. You can use the Stylish add-on instead, if you have it installed.


@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);
/* The above line should appear only once in the file */

#TabsToolbar { -moz-box-ordinal-group: 99 !important }

Also see

renascent: You can use either of the following add-ons. * https://addons.mozilla.org/firefox/addon/tabs-on-bottom/ * https://addons.mozilla.org/firefox/addon/classicthemerestorer/ If you don't want to install an add-on, put the following style in the ''userChrome.css'' file and restart Firefox. You can use [https://addons.mozilla.org/firefox/addon/stylish/ the Stylish add-on] instead, if you have it installed. * http://kb.mozillazine.org/UserChrome.css ---- <pre><nowiki>@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul); /* The above line should appear only once in the file */ #TabsToolbar { -moz-box-ordinal-group: 99 !important }</nowiki></pre> ---- Also see * [[How to make the new Firefox look like the old Firefox]]
renascent 0 solutions 21 answers

I already got the tabs at the top but I still don't know how or don't have the icons for weather and Reminder Fox on the bottom task bar. I don't want everything up top.

I already got the tabs at the top but I still don't know how or don't have the icons for weather and Reminder Fox on the bottom task bar. I don't want everything up top.

Question owner

I don't know how this stacks up to other support questions, but I'll note that quite a few people seem to share my sentiments - 31 at last count.

By the way, I still haven't gotten a response to how those bugs concerning Direct2D don't apply to me, since I'm using Windows XP (which doesn't support Direct2D).

Oh and by the way, I still haven't gotten an answer as to why the config.trim_on_minimize setting has been removed.

I don't know how this stacks up to other support questions, but I'll note that quite a few people seem to share my sentiments - 31 at last count. By the way, I still haven't gotten a response to how those bugs concerning Direct2D don't apply to me, since I'm using Windows XP (which doesn't support Direct2D). Oh and by the way, I still haven't gotten an answer as to why the config.trim_on_minimize setting has been removed.
guigs
  • Top 25 Contributor
  • Administrator
  • Moderator
1038 solutions 11342 answers

Hi robbyrob,

For your last question, it is possible to add it back on the about:config page. Right click on the page, select New then boolean. In the text box enter config.trim_on_minimize and then set it to what you want. If its not a boolean, select the expected feature from before. Its still there: http://lxr.mozilla.org/mozilla/search?string=config.trim_on_minimiz... but its history is pretty old see https://bugzilla.mozilla.org/show_bug.cgi?id=76831 Firefox uses too much memory (RAM) - How to fix

You are right Direct2D 1.1 is not for your operating system. Does disabling it minimize crashes on this system?

Hi robbyrob, For your last question, it is possible to add it back on the about:config page. Right click on the page, select New then boolean. In the text box enter config.trim_on_minimize and then set it to what you want. If its not a boolean, select the expected feature from before. Its still there: [http://lxr.mozilla.org/mozilla/search?string=config.trim_on_minimize&luckytricky=1] but its history is pretty old see [https://bugzilla.mozilla.org/show_bug.cgi?id=76831] [[Firefox uses too much memory (RAM) - How to fix]] You are right Direct2D 1.1 is not for your operating system. Does disabling it minimize crashes on this system?

Question owner

Okay, I added config.trim_on_minimize back in, but I'm not sure if it's working the way it used to. Furthermore, I still don't understand why it's no longer included by default. I could be wrong, but I thought it had been included by default in Firefox up to and including version 27.

How can I disable Direct2D if it's not on my operating system to begin with? Or am I missing something here?

Okay, I added config.trim_on_minimize back in, but I'm not sure if it's working the way it used to. Furthermore, I still don't understand why it's no longer included by default. I could be wrong, but I thought it had been included by default in Firefox up to and including version 27. How can I disable Direct2D if it's not on my operating system to begin with? Or am I missing something here?