Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New email notifications not working.

  • 5 replies
  • 4 have this problem
  • 6149 views
  • Last reply by hepatica1

more options

The last few weeks I am receiving no alerts, tray icon or sounds even though I have not changed any settings. I have been using Thunderbird for years, and this machine for over a year, and yet I have had no issues until recently. I looked through the boards and there has been no solution which doesnt involve making sure everything is checked, which I have already done.

Does anyone happen to have another solution?

Thanks!!

Chosen solution

Assuming that in Thunderbird

   Preferences > General > When new messages arrive > Play a sound 

has not been turned off accidentally and that you do indeed have an IMAP setting, you may try going to the "Config Editor" the same way as before and search for "mail.imap.use_status_for_biff" and toggle to "false".

This setting is said to take a bit longer (perhaps more so on older computers or slower internet connections).

What it does [1]:

"It causes Thunderbird to explicitly select each folder to update the message summaries, rather than use the STATUS command. It has more overhead, but some IMAP servers don't return STATUS correctly."

[1] References: http://kb.mozillazine.org/Offline_folders and others.

Read this answer in context 👍 1

All Replies (5)

more options

Do you have a Gmail account with IMAP? If so, this post might help (see Chosen Solution):

https://support.mozilla.org/en-US/questions/991323

more options

That got the pop up notifications and icon working, which is a very good start, thanks!

The sound still didnt function. If anyone has any suggestions there it would be great.

more options

Chosen Solution

Assuming that in Thunderbird

   Preferences > General > When new messages arrive > Play a sound 

has not been turned off accidentally and that you do indeed have an IMAP setting, you may try going to the "Config Editor" the same way as before and search for "mail.imap.use_status_for_biff" and toggle to "false".

This setting is said to take a bit longer (perhaps more so on older computers or slower internet connections).

What it does [1]:

"It causes Thunderbird to explicitly select each folder to update the message summaries, rather than use the STATUS command. It has more overhead, but some IMAP servers don't return STATUS correctly."

[1] References: http://kb.mozillazine.org/Offline_folders and others.

more options

That did it, thanks!

more options

I don´t get an email notification when I am in safe mode. When I press the TB icon messages appear and tray icon comes up and the sound is playing.