Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I install Firefox in romansh/rumantsch under Ubuntu?

  • 9 replies
  • 4 have this problem
  • 3 views
  • Last reply by Davent

more options

I'm using Ubuntu in german. But I want to use my favorite browser in my favorite language. I tried to install the language pack (.xpi) and change the UI with the Quick Locale Switcher, but it doesn't work. All I got was the english UI. Can you help me?

Chosen solution

Davent wrote:

general.useragent.locale is set to "rm", but the UI is still german...

On Linux, you also need to set intl.locale.matchOS to false

Read this answer in context 👍 3

All Replies (9)

more options
  1. Install the language pack from the following page. Verify that it shows up in the Add-ons Manager, Languages category.
  2. Type about:config into the address bar and press Enter.
  3. To bypass the warning, press the big button labeled "I'll be careful, I promise!".
  4. In the search box, paste intl.locale.matchOS
  5. In the search results, make sure intl.locale.matchOS is set to false — double-click it to toggle its status.
  6. In the search box, paste general.useragent.locale
  7. In the search results, double-click general.useragent.locale and set its value to the ISO 639-1 language code. For Romansh, that's rm
  8. Restart Firefox for the change to take effect.

You can also change the interface language with an add-on like Locale Switcher.

Modified by Gingerbread Man

more options

Thank you very much for your fast answer. But unfortunately it didn't work. I've already tried this before and now again: It doesn't work. Did it work for you? Have you tried these steps? The add-on is installed, general.useragent.locale is set to "rm", but the UI is still german... (And: Yes, I restarted Firefox)

more options

Do you have the Firefox version from the Mozilla server or one provided by your Ubuntu distribution.

You can try to create a "/distribution/bundles" folder in the Firefox installation folder and install the language pack(s) in that folder.

  • /questions/984445 How do I install a language XPI globally and make it the default language?

This is a bit more tricky and you also won't be able to update the language automatically when Firefox updates.

You need to create a folder with the ID of the language pack in the /distribution/bundles folder and extract all the files in the XPI (ZIP) archive this folder.

  • /distribution/bundles/langpack-rm@firefox.mozilla.org
more options

Thank you for your answer. My Firefox version is provided by my Ubuntu distribution. I tried to follow the steps you indicated. I created a folder called "bundles" with a subfolder called "langpack-rm@firefox.mozilla.org" containing all the files I extracted from "rumantsch_language_pack-28.0-fx.xpi". After this I tried to move the folder to usr/lib/firefox/distribution, which failed. So I started Nautilus from the terminal with "sudo nautilus". After this I was able to move the folder.

Now there is a directory like this: /usr/lib/firefox/distribution/bundles/langpack-rm@firefox.mozilla.org/ containing the stuff from the xpi.

But the terminal is full of errors like "** (nautilus:7618): WARNING **: nautilus_canvas_view_remove_file() - directory not canvas view model, shouldn't happen. file: 0x1615960:file:///usr/lib/python2.7/htmlentitydefs.py, dir: 0x9a66a0:x-nautilus-search://0/, model: 0xb0ba40:file:///usr/lib, view loading: 1 If you see this, please add this info to http://bugzilla.gnome.org/show_bug.cgi?id=368178"

And Firefox still speaks german...

Would it be easier to solve this problem if I install the Mozilla provided version of Firefox? How can I install it?

more options

You can find the full version of the current Firefox 28.0 release in all languages and for all Operating Systems here:

See also:

more options

Thank you very much. This works!

Unfortunately it's not too user-friendly... Do I have to install updates manually? Is there a way to install a specific language version (like rumantsch) using a repository?

more options

Firefox will be updating to Fx29 with the next few days. ( Tuesday 29th April )

The Mozilla builds of Firefox on Ubuntu should attempt to download and update themselves. Once the updates are available check by using

more options

Chosen Solution

Davent wrote:

general.useragent.locale is set to "rm", but the UI is still german...

On Linux, you also need to set intl.locale.matchOS to false

more options

It works! Great. Thank you, Gingerbread Man and cor-el!