Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

why is a special character  inserted into my drafts?

  • 22 replies
  • 24 have this problem
  • 10955 views
  • Last reply by Mattmozilla

more options

After I save a draft, and then return later to finish it.... I frequently (more times than not) find that Thunderbird has inserted a ton of  characters in the email, all over. Usually at the end of every sentence. Often the are 3 in a row, with spaces between:   Â

My Character Encoding, inbound and outbound: Weatern ISO-8859-1

Any thoughts? Thank you kindly.

All Replies (20)

more options

Thanks Matt.... I will. Let's see what happens. I'll re-post with the results.

Fingers crossed....

more options

Are you replying to a message you received, or composing a new message?

more options

Thanks christ1.... They are new messages.

One thing: I went through the folder, looking for the  character which is/was in more than one message.... and I am unable to find any.

Wondering if the UTF-8 change made the difference. But it may be too soon to tell.

  :-)
more options

Heppened to me and I solved it by fixing the default Character Encoding, as suggested by Matt (with little detail ;-) Here's where you can change it:

In Linux: Edit → Preferences → Display → Formatting → Fonts → Advanced... → Character Encodings → Outgoing Mail: UTF-8

In Mac OS X: Tools → Options → Display →...

Have no Windows in this location; should be close though.

more options

Thank you all for your replies.... I really appreciate it.

Unfortunately, the Encoding change to UTF-8 did not fix the problem.

   : -(
more options

I have had the same problem for a long time. Setting the code to UTF-8 only changes characters that are inserted for extra spaces or special characters -- currently a ? in a black diamond. My husband' s version of T'bird on a Win 7 computer has NO character encoding set. Why can't I turn off character encoding on my XP laptop? (We both have T'bird 24.6.0.)

more options

@ELMorrison. Turning off character encoding would not be a good thing. without character encoding of HTML the page does not display in the language it is meant to. Unfortunately because most of the email software in the world originates in the US of A where they simply don't appear to get that there are languages that are not US English default encoding of email is an absolute mess.

Add to that the default character set used by most us English, German and Northern European email locales is not utf 8 but the older ASCII character sets and you start seeing mail with poor characters appearing. This situation is greatly exacerbated by the use of old operating systems and older email programs. Outlook express and Eudora spring to mind.

Note that the setting in Tools menu (alt+T) > options > display > advanced has an incoming and an outgoing default and the option to set it and force incoming mail (usually not a good idea)

@Kozaki, this web page is very handy in deciphering the menu differences vis Linux/Mac/Windows. http://kb.mozillazine.org/Menu_differences_in_Windows,_Linux,_and_Mac

more options

So... the answer is, because I'm still on XP, I can't do anything about it. Next computer will be a Mac.

more options

MACs dump you faster than Microsoft.... so do not let that be the influence in your decision making.

Seriously I suggest you force Thunderbird to use UTF-8 on all email using options. That will end almost all of the formatting rot, or should.

more options

Okay -- the default is now UTF-8 for both incoming and outgoing. We'll see if it makes a difference... Thanks.

more options

I've been having the same problem recently. Checked the character encoding and it was set for utf-8. After several tests, I found that setting incoming and outgoing encoding to Western ISO-8850-1 solved the problem.

more options

Hmmm... There is no Western (ISO-8850-1) on my Character Encoding menu; just Western *ISO 8859-1) and -15. This could well be the problem -- again, thanks to XP. Patience...

more options

You're right! -- I mis-typed. It should have been Western ISO 8859-1.

more options

Oh, okay. I've changed mine now; let's see what happens... HA! Fixed it! Thanks!

more options

I'm using Thunderbird 31.0 for Mac, and I've had similar problems of strange extra characters showing up in emails I've had saved in Drafts, and also occasionally when I reply to a message, they show up in the quoted original message (even though they weren't in the original).

I think I may have found a solution to this problem at last.

I would prefer to use Unicode (UTF-8) because it seems more versatile and more common these days (e.g., I believe Gmail uses it by default, at least in the USA).

The first thing I tried was Ctrl-clicking on the Inbox folder, clicking Properties, and changing Fallback Character Encoding to Unicode (UTF-8). I did NOT check the checkbox labeled "Apply encoding to all messages in the folder..." because it looks like that disables auto-detection. I did the same for my Drafts folder. This seems to have cleared up the problem for drafts.

It was still happening sometimes in quoted reply text, though, so I did the following: Preferences --> Display --> Fonts & Colors --> Advanced... and changed the character encodings for both incoming and outgoing mail to Unicode (UTF-8) and checked the box "When possible, use the default character encoding in replies". This seems to have eliminated the problem. I'll report back here if I encounter it again.

(Note: I don't know if it's necessary, but when I adjusted these settings, I closed and reopened Thunderbird.)

Good luck!

more options

Thanks! I only had part of that solution. Fingers crossed that it's working.  ; )

more options

Thought I found a clue to this problem but am not positive. I use W7 OS and my Thunderbird Character encoding is listed as "Western" in TB 31.1.1 but I feel sure it is Western ISO 8859-1. There are no  characters in my outgoing email or drafts.

However, incoming email can contain funny looking characters. Most of the  characters appear to come in email from certain individuals, not with every email into my in-boxes. This morning an advertising email from Apple arrived with "  Pre‑order now " all over the text.

I suspect the character  comes from email sent to me by Apple, Mac or iPads computers. Another quirk I see coming into TB from iPads are email with text that extends in long sentences where the email has to be spread out wide to read the full text and with characters like this: ❤ï.

In my situation I just have to persevere with weird characters from certain Apple computers. Hope this helps some of your concerns.

more options

Couple of points, if you look in the source of emails there is a character set specified.

To quote the email I got that brought me back here

MIME-Version: 1.0
Content-Type: text/html; charset="utf-8"
Content-Transfer-Encoding: 7bit

So there is no auto detect, there is use what is specified or use what I say.

Second point is Western ISO 8859-1 is an ascii character set. UTF-8 on the other hand is unicode. ASCII came first and Unicode extends ASCII to thousands of characters in a character set while maintaining backward compatibility to ASCII by having the same characters mapped to the same locations for the first 256 characters (normal keyboard characters is you use a western/US qwerty keyboard. This means that on the whole there is compatibility.

Now unfortunately for the rest of the world Apple decided that like Microsoft they were free to innovate. They chose to inovate by implementing a non standard UTF-8 implementation that is know as UTF-8-mac in the OSX operating system. Way to go Apple!

Add that to that windows breaks lines on a carriage return line feed pair in a text document and the unix/Linux world simply use a line feed and you will start to see some of the oddball interactive issues that crop up. Remembering of course that OSX and IOS a both largely UNIX operating systems with large parts directly ported from NEXTsTEP and BSD UNIX

Perhaps that goes someway to explaining the quirks of line feeds and character encoding. I tried :)

more options

Interesting, and helpful, Matt. Raises the next logical question: Is there a workaround, or a way to force Apple output to display properly on a Windows device?

  1. 1
  2. 2