Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Most times when I want to open a document, Firefox saves it in Downloads, rather than just letting me read it. How do I prevent this?

  • 2 replies
  • 4 have this problem
  • 13 views
  • Last reply by cor-el

more options

In earlier versions of Firefox, I was able to open a document e.g. an email attachment or a document following a link in a website, and then decide if I wanted to save it or just read it. Now more often than not, it automatically saves it to Downloads, though not every time. The choices in Settings/General relate only to choosing which folder to save them in, and not to opt not to save at all. By way of example, I went to www.overseal.org, then chose Documents and Budget 2013-2014. This means that nothing appears to happen on screen, and to view the document, I have to go to Downloads, and subsequently delete it from there if I don't want to keep it. Can I change a setting somewhere to revert to previous practice please? John White

Chosen solution

You can rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

You can use this button to go to the currently used Firefox profile folder:

Read this answer in context 👍 2

All Replies (2)

more options
more options

Chosen Solution

You can rename (or delete) the mimeTypes.rdf file in the Firefox profile folder to reset all file actions.

You can use this button to go to the currently used Firefox profile folder: