X
Tap here to go to the mobile version of the site.

Support Forum

Trouble with error: Secure Connection Failed, SSL received a record with an incorrect Message Authentication Code. (Error code: ssl_error_bad_mac_read)

Posted

For the past 24 hours, I have visited multiple websites such as Facebook, Yahoo, Google, and YouTube, and three things have happened: Either the web page has not fully loaded, or I get these two errors - Secure Connection Failed, SSL received a record with an incorrect Message Authentication Code. (Error code: ssl_error_bad_mac_read) and SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long).

I have already reset Firefox, performed a Full Scan with Kaspersky 3.0, and changed my settings to where I am not using a proxy. Does anyone know what I can do to fix this problem? Thanks.

For the past 24 hours, I have visited multiple websites such as Facebook, Yahoo, Google, and YouTube, and three things have happened: Either the web page has not fully loaded, or I get these two errors - Secure Connection Failed, SSL received a record with an incorrect Message Authentication Code. (Error code: ssl_error_bad_mac_read) and SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long). I have already reset Firefox, performed a Full Scan with Kaspersky 3.0, and changed my settings to where I am not using a proxy. Does anyone know what I can do to fix this problem? Thanks.

Chosen solution

This still sounds that a proxy is being used.

What are the current connection settings?

  • Tools > Options > Advanced > Network : Connection > Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.


Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if this helps.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 12.0 r0
  • Google Update
  • Unity Player 4.3.3f1
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06
  • iTunes Detector Plug-in
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • WildTangent Games App V2 Presence Detector

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
16648 solutions 150459 answers

Chosen Solution

This still sounds that a proxy is being used.

What are the current connection settings?

  • Tools > Options > Advanced > Network : Connection > Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.


Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if this helps.

This still sounds that a proxy is being used. What are the current connection settings? *Tools > Options > Advanced > Network : Connection > Settings If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. ---- Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if this helps.
cor-el
  • Top 10 Contributor
  • Moderator
16648 solutions 150459 answers

You can also try to disable IPv6.

You can also try to disable IPv6. *http://kb.mozillazine.org/Error_loading_websites#IPv6

Question owner

These seemed to have solved the issue at least for the time being. Thanks for the help!

These seemed to have solved the issue at least for the time being. Thanks for the help!