Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I add new search engines to Firefox they don't show up at all.

  • 4 replies
  • 1 has this problem
  • 102 views
  • Last reply by jscher2000

more options

Hi,

I'm trying to change the search engine tool on Firefox to ixquick. I go to the search engine manager and go to add a new search engine. I search for ixquick and click 'add to firefox' then it comes up with a pop up asking for confirmation, i tick the box saying 'start using right away.'

Not only does it not come up in the search bar, but even when i visit the search engine manager, ixquick is nowhere to be seen.

Also, in preferences I've been trying to change my homepage, but whenever i restart firefox, it changes back to a website called 'MyStart.' the search engine tool also changes back to 'MyStart'

This is very annoying any help would be greatly appreciated.

All Replies (4)

more options

MyStart sounds familiar, probably an unwanted extension. Try this:

Disable ALL nonessential or unrecognized extensions on the Add-ons page. Either:

  • Command+Shift+a
  • Tools menu > Add-ons

In the left column, click Extensions. Then, if in doubt, disable.

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Before restarting, though, you can use the following extension to reset your home page, new tab page, and search engine back to factory defaults if you don't want to change the settings manually:

https://addons.mozilla.org/firefox/addon/searchreset/

more options

The forum software detected your Firefox as version 9. Is that correct?

Version 9 is not secure; Mozilla discloses security flaws after each new release. Is something holding you back from upgrading to Firefox 28? Please let us know so we can suggest solutions or workarounds.

If Help > About Firefox shows Firefox 28.0, you may need to clear the preference that is misreporting your version number. See: Websites say that Firefox is outdated or incompatible even though it's the latest version.

more options

Hi there, yes I've already tried disabling all the add ons and extensions i don't need, it didn't seem to make a difference unfortunately. I've updated to the latest version of Firefox but for some reason this hasn't fixed anything. Now when I try to delete 'MyStart' from the search engines manager, Firefox crashes completely and on restarting MyStart is still there.

Thanks for your help, any ideas on what this might be?

more options

Let's try to track down the search plugin.

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Open in Finder" button

Look for a file named search.json that contains the data on the currently active search plugins. This is a text file you can view in a text editor, but as it is does not have line breaks, it is difficult to read.

You can search in the file for mystart (or another part of the URL of the results page) and then read forward looking for the "filePath" parameter. If you get to "_id" that's the beginning of the next plugin, so work backwards again.

Can you find the file location?

Assuming you can remove the actual search plugin file, you also can have Firefox regenerate search.json. You probably want to fully Quit Firefox before renaming search.json to something like search_json.old.