Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why are my Sent messages no longer showing in Sent folder?

  • 6 replies
  • 11 have this problem
  • 76608 views
  • Last reply by guigs

more options

When I send a message to a recipient, a copy of the sent message no longer appears in my Sent Folder. I don't know where the message is being saved, if at all... Thank you. :)

Chosen solution

I don't know where the problem lay, but I have solved it (as least temporarily) as follows:

1. Made a new folder in my account; 'SentOld'. 2. Moved all my sent emails from 'Sent' into this folder. 3. Closed Thunderbird 4. Navigated to my Mail folder and deleted 'Sent.msf' and 'Sent' 5. Opened Thunderbird and allowed it to reinstall 'Sent' and a 'Sent.msf' folders. 6. Checked that a sent message now appears in the 'Sent' folder.

Read this answer in context 👍 0

All Replies (6)

more options

Hi micheleray, Thank you for your post. I understand that messages are no longer showing up in your sent folder in Thunderbird. We are happy to help.

  1. Click on your email name, or account name with the globe with lock icon on it
  2. Click on account settings
  3. Click on "Copies and Folders"
  4. Make sure Place a copy of the sent messages in the sent folder is checked.

If the above information does not resolve your issue, please consider creating a new thread containing the specific details of your issue.

Doing so will allow the Mozilla volunteers to give you solutions that are more helpful to you. This may help them to solve your problem faster and more efficiently.

Please, feel free to post the link to your thread on this thread for volunteers interested in assisting you.

Thank you.

more options

All settings to save sent messages are correct; the system has worked perfectly over the past few years, but over the past couple of days has stopped working. Sent messages disappear from Thunderbird and never end up in my sent folder.

more options

It may need a reset, but you can try to safe the preference to give it a kickstart as well: From http://forums.mozillazine.org/viewtopic.php?f=39&t=763585 If it is not there at all

Under Tools->Account Settings->Copies & Folders make certain that you have selected "Place a copy in" and that you have chosen a folder to be the Sent folder for that account.

Do you have more than one connection to the email server? Navigate to the Server Settings section of your account and click on the Advanced button. Change the Maximum number of server connections to cache to be 1 (setting this value to '2' may also work)

more options

" Under Tools->Account Settings->Copies & Folders make certain that you have selected "Place a copy in" and that you have chosen a folder to be the Sent folder for that account." This has been done from day one. Now checked again and ok, A copy of sent messages does not go there.

"Do you have more than one connection to the email server? Navigate to the Server Settings section of your account and click on the Advanced button. Change the Maximum number of server connections to cache to be 1 (setting this value to '2' may also work)". When I navigate to Advanced I get no option to change the number of server connections. Just see two options for storing incoming pop mail and a box to tick 'Include this server when getting new mail'.

I have read http://forums.mozillazine.org/viewtopic.php?f=39&t=763585. This does not seem to be applicable to me, as I have a Sent Mail box, and this includes all sent mail up to about two weeks ago.

I have worked around the problem by copying all outgoing mail back to myself, but this is extremely inelegant.

Any other solutions?

Thanks

more options

Chosen Solution

I don't know where the problem lay, but I have solved it (as least temporarily) as follows:

1. Made a new folder in my account; 'SentOld'. 2. Moved all my sent emails from 'Sent' into this folder. 3. Closed Thunderbird 4. Navigated to my Mail folder and deleted 'Sent.msf' and 'Sent' 5. Opened Thunderbird and allowed it to reinstall 'Sent' and a 'Sent.msf' folders. 6. Checked that a sent message now appears in the 'Sent' folder.

more options

Carman, this is brilliant. I am wondering if this has to do woth the folder becoming corrupt/old/too big. What has been recommended is to compact folders to maintain their 'functions' so to speak. An elaborate explanation of this can also be seen here> Compacting Folders I will mark your solution for now, but if this starts to happen again please feel free to open a new thread.

Modified by guigs