Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Video embeds show up as empty black squares

  • 10 replies
  • 58 have this problem
  • Last reply by imagio

more options

Related to:

In firefox 27, 28, and nightly youtube embeds frequently show up as blank black squares. I cannot even right click them to inspect the iframe containing the video. No controls whatsoever are available. Safe mode does not change this behavior. Disabling the Shockwave Flash plugin causes the videos to load correctly as html5 video. Flash youtube embeds work fine in IE11 and chrome.

Ex: the 4th and 5th video embedded in this page are blank while the first 3 load fine and appear to be using the html5 player.

Edit: If I go to and modify the URL in the iframes of the offending videos to remove the "http:" or "https:" the video loads correctly. It seems that flash youtube embeds are broken in firefox if the URL is prefixed with "http:" or "https:"

Modified by imagio

All Replies (10)

more options

The pattern I see is a problem with the videos in iframes that use a secure (HTTPS) URL. The player loads into the iframe, but the media never loads.

You can extract the iframe src URLs and display them above the iframes for diagnosis using a little snippet of script.

Open Firefox's Web Console below the page by pressing Ctrl+Shift+k. Then paste the following next to the caret (») and press Enter to run it:

var ifs=document.getElementsByTagName("iframe"); for (var i=0; i<ifs.length; i++) {var p=document.createElement("p"); p.appendChild(document.createTextNode("iframe src="+ifs[i].getAttribute("src")));"red"; ifs[i].parentNode.insertBefore(p, ifs[i]);}

But... I can't figure out why there is a problem. ??

more options

By the way, omitting the protocol when specifying the src URL (starting with the //) will lead Firefox to use the same protocol as the page. So it is a flexible way to adapt to either secure or non-secure addresses. If that works for you, that seems to be the way to go.

more options

Unfortunately it seems to be a bug with firefox that any flash youtube embed with "http:" or "https:" instead of just "//" will not work. The way sites choose to embed videos is not under my control, so changing that is not really a viable option for me or other users facing this issue. It seems that this needs to be fixed by firefox or adobe, but given that it works in IE and chrome it seems to be a problem only with firefox and not with flash.

more options

The first three, iframes using an http: URL, which matches the http: URL of the page, work fine for me. I thought you said they work fine for you as well.

The problem is where the protocol on the iframe src doesn't match the protocol of the page.

Usually it's perfectly fine to embed https: in http: so this is very strange. Someone with a more intimate knowledge of the logic applied to iframes will need to dive into Youtube's code to figure out why those aren't working in Firefox.

more options

Sorry if my previous post was misleading -- the first 3 videos work fine on that page. I think they work because they are using the html5 video player. The two that do not work are using the flash video player. Those two can be made to work by removing the http: from their urls. The issue seems to be only *flash* embeds -- html5 ones work fine.

more options

All videos on the page work in the current Nightly build (30.0a1), but not in the current release and later (Beta, Aurora) builds. This looks more like an issue with CSS code where the player isn't positioned properly as I can't right-click in the player area.

more options

I am on 30.0a1 and the last two videos on that page do not work for me (the flash ones).

more options

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem

more options

One bit of experimental evidence in favor of the CSS problem hypothesis is that the Flash players become visible if you use:

View menu > Page Style > No Style

(If you use the compact menu/orange Firefox button, tap the Alt key to display the classic menu bar)

You can see all 5 play buttons if you then reload the page. Strange.

I'm running Firefox 27.0.1, so never mind!

Modified by jscher2000

more options

Creating a new profile had no effect on the issue. I am seeing this issue on firefox 28 and nightly across several different computers.