Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefoy consumes high CPU time displaying Facebook compared to other browsers.

  • 11 replies
  • 67 have this problem
  • 1373 views
  • Last reply by Boblebad

more options

Why id Firefox consuming so much more CPU cycles then the same (Facebook page) on other browsers? You may see the difference in this screen capture FF27 vs IE11 Is there another way to fix this then the AdBlock filter suggested before? This might maybe temporary fix the issue but who knows what problem it introduces for next?

All Replies (11)

more options

Here the screen shot that was impossible to add in the original question...

more options

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure.

If a plugin is not the cause, take a look here. for other possible solutions.

more options

Hi George, Yes, the plugins are up to date. I also reset FF and reinstalled it from scratch. Starting FF in safe-mode with all plugins deactivated didn't change anything.

Further if I have several tabs in FF pointing to different sites and I switch the focus from Facebook to another tab, CPU usage drops immediately. If I come back to the Facebook tab, CPU cycles grow immediately back. Depending on the processor, I experienced only for Facebook, CPU levels of 20% (Intel i7) to 60% on core2duo with lots of cooling fan noise...

Let me say also:

1. this happens only on FF (not IE not Opera, not Chrome)

2. this happens in some webpages only (like Facebook)

3. this happens on all my computers and if you check the web, other people complain too...

Modified by taglich

more options

In my case it seems to be because of flash player running in protected mode. In the mms.cfg file I added the line, "ProtectedMode=0", closed my Facebook tab and reopened it.

My Task Manager no longer shows the two FlashPlayerPlugin_xx_xxx_xxx.exe processes and the Firefox.exe cpu usage has remained low ever since.

I didn't need to restart Firefox but you may need to close all tabs that are using Flash - I didn't have any other than Facebook so I haven't tested this.

On my Vista system, mms.cfg was in C:\Windows\System32\Macromed\Flash\

more options

Hi, I already use "Flash Block 4.20.13" extension. There is no flash activity without my express consent in FireFox. And indeed, if I would not use it, the CPU would rather be at the double... Thanks for the tip anyway.

more options

Again, this is NOT "my" problem. This has been proved to be a FireFox special behavior regarding "something" mishandled on the FaceBook profile page (see above). I have no problem to switch to IE. My intent was to inform FB but apparently, it isn't of any interest.

more options

It's all about the left column.

I'm on Thinkpad T60P, Core2Duo T7400 2.16GHz, 2GB memory. Linux Mint 16 Caja. FB uses around 90% CPU.

Install Adblock Plus: https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/

and

Element Hiding Helper for Adblock Plus: https://addons.mozilla.org/en-US/firefox/addon/elemhidehelper/

On Linux the shortcut is Ctrl+shift+F3 to open Element hiding helper, start hiding/blocking the whole left column, i have a drop to 15-20% CPU usage :) - facebook.com###leftCol

Turn it back on, you can't use FB without the left column. Now start hiding what you really don't need in the left column using Element hiding helper, just hover over the titel, and then a little around them till jo get the red square that makes that block-part of the left column you want to hide.

Check your resource manager, see what happens when you hide the block-parts of the left column one by one :)

On my system, the nastiest block-part is the Groups, the CPU usage drops around 25%: facebook.com###groupsNav

The next nastiest one is Pages, 20-25% drop in CPU usage: facebook.com###pagesNav

The other ones is responsible for about 2-5% decrease in CPU usage each, så hide/block what you don't need.

facebook.com###appsNav ; facebook.com###developerNav facebook.com###interestsNav ; facebook.com###listsNav facebook.com###pinnedNav

The groups and pages you can find in the top search field where you can find friends and other people. That way if you really want to decrease CPU usage, you can hide/block those two.

I tried hiding/blocking a single element of a block-part, but it just hides/blocks the whole thing.

I think the main problem is that FB keeps track of what is posted on the Pages we like and in the Groups where we are members of, so the more Pages you like and Groups you are a member of - IF they are very active, many updates a.s.o. - it will use more and more CPU - IN FireFox!

It IS a FireFox problem.

All the best, Carsten

Modified by Boblebad

more options

Hi Carsten, Thank you very much for your detailed post. Indeed, deactivating "things" will drop CPU usage, that's a fact! Unfortunately, this still doesn't explain why the same on IE, Chrome or Safari has not the same CPU usage (from far). I still wish to know why FF is different regarding this and if its a bug then have it repaired.

more options

I completely agree.

That is why i wrote "It IS a FireFox problem", and that's why it is something the FF team needs to fix, actually it should have bin fixed ages ago, it has bin a know problem for years, that just have gotten bad'er and bad'er over the years.

The worst ever is ver 27.

In 26 i could have 60+ tabs open, incl. FB, i still took a good amount of memory and CPU, but in 27 i get the same load on memory and CPU with just 20 tabs open, so something got all wrong with this update.

It IS a bug, it can't be otherwise, how would you else explain this behaviour and especially that it's the only browser that has this problem - it sure aint a FB problem.

more options

Yes. Lets see if they pick it up now?

I don't like open problems without confirmation. I can live with "we know we work on it", but we cannot complain. It's free, isn't i? I will not tag your post as the answer so they maybe browse the open posts... Thanks anyway...

more options

It's only a temporary fix on the FB page, and it isen't really a fix, cause hiding/blocking something that shoul be visible isen't a fix, it's maybe more of a work-around :)