X
Tap here to go to the mobile version of the site.

Support Forum

How do I make Firefox spell check my Office 365 email account?

Posted

I have tried clicking the "check spelling as I type" box under the "Firefox" tab, but I am still not getting spell check on my Office 365 email. (I am getting it here as I type, however, and also when I type into Google's text box, for example.) I don't understand why Firefox isn't also spell-checking my email. I do have spell check on my Office 365 email account with Safari, but I like Firefox so much better. I'd really appreciate any help you could give me. Thanks!!!

~Julianna Crider

I have tried clicking the "check spelling as I type" box under the "Firefox" tab, but I am still not getting spell check on my Office 365 email. (I am getting it here as I type, however, and also when I type into Google's text box, for example.) I don't understand why Firefox isn't also spell-checking my email. I do have spell check on my Office 365 email account with Safari, but I like Firefox so much better. I'd really appreciate any help you could give me. Thanks!!! ~Julianna Crider

Chosen solution

Try this: misspell a word, highlight it, right click and make sure that "Check Spelling" is checked.

 I need to do this for each site. Occasionally more than once.
Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Facebook Video Calling by Skype
  • 5.1.10411.0
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Shockwave Flash 10.3 r183
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Office Live Update v1.0
  • http://www.facebook.com/fbplugin/
  • npmnqmp 071505000006
  • iPhoto6

Application

  • Firefox 16.0.2
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:16.0) Gecko/20100101 Firefox/16.0
  • Support URL: http://support.mozilla.org/1/firefox/16.0.2/Darwin/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x2a02
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureBackend': u'quartz'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRendererMessage: [u'blockedOSVersion']
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 716800
  • browser.places.importBookmarksHTML: False
  • browser.places.importDefaults: False
  • browser.places.leftPaneFolderId: -1
  • browser.places.migratePostDataAnnotations: False
  • browser.places.smartBookmarksVersion: 4
  • browser.places.updateRecentTagsUri: False
  • browser.search.param.tsoxprid: ZNfox003RXUS
  • browser.search.param.tsoxtbid: 69ED4926-B2C8-468C-81AD-AD898569417E-TS
  • browser.search.suggest.enabled: False
  • browser.startup.homepage: http://www.google.com/
  • browser.startup.homepage_override.buildID: 20121024073032
  • browser.startup.homepage_override.mstone: 16.0.2
  • browser.zoom.full: False
  • extensions.lastAppVersion: 16.0.2
  • keyword.URL: http://yahoo.genieo.com/results.html?v=w3i11&cid=6477&p=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1392037261
  • places.history.expiration.transient_current_max_pages: 53688
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
Edward27821 22 solutions 225 answers

Chosen Solution

Try this: misspell a word, highlight it, right click and make sure that "Check Spelling" is checked.

 I need to do this for each site. Occasionally more than once.
Try this: misspell a word, highlight it, right click and make sure that "Check Spelling" is checked. I need to do this for each site. Occasionally more than once.
cor-el
  • Top 10 Contributor
  • Moderator
12126 solutions 112672 answers

Current Firefox versions hide Check Spelling in the right-click context menu of a text area if the web page disables the spelling check via a spellcheck="false" attribute of this element.

You can right-click in the text editor area and use "Inspect Element" to see if this text area has a spellcheck="false" attribute.

Removing this spellcheck="false" attribute by selecting it via a double-click and using the Delete or Backspace key should make the Check Spelling item in the right-click context menu reappear.

Current Firefox versions hide Check Spelling in the right-click context menu of a text area if the web page disables the spelling check via a spellcheck="false" attribute of this element. You can right-click in the text editor area and use "Inspect Element" to see if this text area has a spellcheck="false" attribute. Removing this spellcheck="false" attribute by selecting it via a double-click and using the Delete or Backspace key should make the Check Spelling item in the right-click context menu reappear.

Question owner

Thanks, Edward, this was great!

Thanks, Edward, this was great!

Question owner

Thanks for the help, Cor-el, I really appreciate it!

Thanks for the help, Cor-el, I really appreciate it!
cor-el
  • Top 10 Contributor
  • Moderator
12126 solutions 112672 answers

You're welcome.

I had missed that you have an older Mac OS X that doesn't support the current Firefox release, so you won't be affected with this.

You can enable or disable spell checking globally:

  • Firefox > Preferences > Advanced : General: Browsing: "Check my spelling as I type"
You're welcome. I had missed that you have an older Mac OS X that doesn't support the current Firefox release, so you won't be affected with this. You can enable or disable spell checking globally: *Firefox > Preferences > Advanced : General: Browsing: "Check my spelling as I type" *https://support.mozilla.org/kb/Using+the+spell+checker *http://kb.mozillazine.org/Spell_checking
Edward27821 22 solutions 225 answers

@ jcrider

You're very welcome. I'm glad I could help. Thank you for selecting my answer.

@ Cor-el

Thank you. I had no clue what to do with "inspect element". Is there a blog or document that explains more?

@ jcrider You're very welcome. I'm glad I could help. Thank you for selecting my answer. @ Cor-el Thank you. I had no clue what to do with "inspect element". Is there a blog or document that explains more?
cor-el
  • Top 10 Contributor
  • Moderator
12126 solutions 112672 answers

You can see this for instance on the Google Translate page.

<textarea id="source" class="goog-textarea" autocorrect="off" autocomplete="off" autocapitalize="off" spellcheck="false" dir="ltr" tabindex="0" wrap="SOFT" name="text" style="-moz-box-sizing: border-box; overflow-y: hidden; overflow-x: auto; padding-right: 20px;"></textarea>
You can see this for instance on the Google Translate page. *http://translate.google.com/?hl=en&ie=UTF-8&sl=auto&tl=en&text= <pre>&lt;textarea id="source" class="goog-textarea" autocorrect="off" autocomplete="off" autocapitalize="off" <u>spellcheck="false"</u> dir="ltr" tabindex="0" wrap="SOFT" name="text" style="-moz-box-sizing: border-box; overflow-y: hidden; overflow-x: auto; padding-right: 20px;"&gt;&lt;/textarea&gt;</pre>