X
Tap here to go to the mobile version of the site.

Support Forum

Since Firefox 27, continual lag during browsing

Posted

Firefox used to be working fine,but ever since the upgrade to version 27.0.1, everything that I do inside the browser lags from time to time, quite frequently. I try to watch a video on Youtube, it lags for a bit in the middle of the video. I try to open a new tab, it lags a bit. I try to scroll down a page, it lags. I try to write an email, it lags while typing. The lag is a few seconds at arbitrary intervals.

I've tried restarting firefox with all addons disabled and it didn't work. What do you suggest I do next?

Firefox used to be working fine,but ever since the upgrade to version 27.0.1, everything that I do inside the browser lags from time to time, quite frequently. I try to watch a video on Youtube, it lags for a bit in the middle of the video. I try to open a new tab, it lags a bit. I try to scroll down a page, it lags. I try to write an email, it lags while typing. The lag is a few seconds at arbitrary intervals. I've tried restarting firefox with all addons disabled and it didn't work. What do you suggest I do next?

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 12.0 r0
  • Unity Player 4.3.3f1
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • VLC media player Web Plugin 2.1.0
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Bitdefender QuickScan Web Netscape Plugin
  • Pando Web Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Nitro PDF plugin for Firefox and Chrome
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Wacom Dynamic Link Library

Application

  • Firefox 27.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
  • Support URL: http://support.mozilla.com/1/firefox/27.0.1/WINNT/en-GB/eu/

Extensions

  • Adblock Edge 2.0.9 ({fe272bd1-5f76-4ea4-8501-a05d35d823fc})
  • Adblock Plus 2.4.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Bitdefender QuickScan 0.9.9.119 ({e001c731-5e37-4538-a5cb-8168736a2360})
  • Click&Clean 4.1 (clickclean@hotcleaner.com)
  • colorPicker 1.5 (colorPicker@colorPicker)
  • DownloadHelper 4.9.21 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Google Similar Images 0.5 (nishan.naseer.googimagesearch@gmail.com)
  • Lightbeam 1.0.8 (jid1-F9UJ2thwoAm5gQ@jetpack)
  • Skype Click to Call 7.0.14735.1561 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A})
  • TrafficLight 0.2.16 (trafficlight@bitdefender.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • URLtoQRcode initial.rev81 (jid0-ka1TZOfoMg9n3hOnAtSHYjg6GC4@jetpack)
  • XKit 7.4.3 (xkit@studioxenix.com)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2: NVIDIA GeForce GT 635M
  • adapterDeviceID: 0x0166
  • adapterDeviceID2: 0x0de3
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 2048
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 8-19-2013
  • driverDate2: 8-29-2013
  • driverVersion: 10.18.10.3277
  • driverVersion2: 9.18.13.2702
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.casesensitive: 1
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140212131424
  • browser.startup.homepage: http://www.google.com/
  • browser.startup.homepage_override.buildID: 20140212131424
  • browser.startup.homepage_override.mstone: 27.0.1
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 27.0.1
  • font.internaluseonly.changed: True
  • gfx.direct2d.disabled: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1392883904
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1390849803

Misc

  • User JS: No
  • Accessibility: Yes
Aman Routh 77 solutions 607 answers

Usually slowness after one upgrade requires disabling hardware acceleration, or a possible new regression (hopefully not).

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Usually slowness after one upgrade requires disabling hardware acceleration, or a possible new regression (hopefully not). You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: * Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. * In the Firefox options window click the Advanced tab, then select "General". * In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox. * Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] [[Upgrade your graphics drivers to use hardware acceleration and WebGL]]

Question owner

Hi Aman,

Thank you for your reply. I had hardware acceleration off from a previous "why does this lag" period so that was not the problem.

I did manage to solve this, however, unfortunately the solution is one of two:

  1. I downgraded back to version 26, which was the last one that worked properly for me
  2. I disabled Skype Click and Call or whatever it's called.

Now I'm back to smooth scolling and browsing. I personally believe it was Skype's fault, the only way I can check this is to upgrade back to 27 again and see if the problem reappears.

Hi Aman, Thank you for your reply. I had hardware acceleration off from a previous "why does this lag" period so that was not the problem. I did manage to solve this, however, unfortunately the solution is one of two: # I downgraded back to version 26, which was the last one that worked properly for me # I disabled Skype Click and Call or whatever it's called. Now I'm back to smooth scolling and browsing. I personally believe it was Skype's fault, the only way I can check this is to upgrade back to 27 again and see if the problem reappears.
David Vo 2 solutions 71 answers

Skype has long been known for its problematic addon. It tends to cause lag when loading pages and with websites that modify the page frequently (as in the case of YouTube and Gmail).

I personally recommend keeping Skype's addon disabled and upgrading to Firefox 27 again.

Good luck!

Skype has long been known for its problematic addon. It tends to cause lag when loading pages and with websites that modify the page frequently (as in the case of YouTube and Gmail). I personally recommend keeping Skype's addon disabled and upgrading to Firefox 27 again. Good luck!