X
Tap here to go to the mobile version of the site.

Support Forum

mouse hover drop down menu not shown

Posted

recently (about few months ago), i found the profile drop down menu on www.zhihu.com no longer works. i also noticed that other mouse over funtions are disabled too.

oddly, the problem only seems to appear on firefox on my laptop. other browsers on this computer(ie, chrome) or firefox on my other desktop computer works completely fine. so i don't think it's a website-related issue.

methods tried but didn't help: turning off hardware accelaeration. clear cookies. safe mode. reset firefox. migrating profiles and firefox program files from desktop computer to laptop. completely reinstall firefox.

any idea?

and sorry for my poor english expression, it is a second language and i'm not very good at it :-)

recently (about few months ago), i found the profile drop down menu on www.zhihu.com no longer works. i also noticed that other mouse over funtions are disabled too. oddly, the problem only seems to appear on firefox on my laptop. other browsers on this computer(ie, chrome) or firefox on my other desktop computer works completely fine. so i don't think it's a website-related issue. methods tried but didn't help: turning off hardware accelaeration. clear cookies. safe mode. reset firefox. migrating profiles and firefox program files from desktop computer to laptop. completely reinstall firefox. any idea? and sorry for my poor english expression, it is a second language and i'm not very good at it :-)

Chosen solution

thank you jscher2000, i believe you're right!

disabling 'HID-compliant touch screen' in the Windows Device Manager did solve my problem.

since i don't really use touch devices on laptop, i'm very glad that the problem bothered me for few months finally worked out.

i'm also a software developer myself. with a certain understanding of computers, i'm still very confused how devices could influence firefox behaviours. because changing dom.w3c_touch_events.enabled didn't solve my problem.

i wonder whether it's a windows 8 systematic malfunction or just a firefox bug.

but anyway, i can't thank you enough :-)

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.9 r900

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0

More Information

jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Helpful Reply

This could be related to your new hardware.

In order to be "mobile friendly" some websites may change menu behavior for devices with a touchscreen.

Does your laptop have a touchscreen?

To disable Firefox from telling websites that you have a touchscreen, you can make a change to a hidden setting.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste touch and pause while the list is filtered

(3) Double-click the dom.w3c_touch_events.enabled preference and change the value to 0 (that's a zero) and click OK. Here are the options for this setting:

  • 0 = disabled
  • 1 = enabled
  • 2 = auto-detect (default)

To see whether the site behaves differently, you may need to clear cache and cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does hover work normally again?


A user with an HP all-in-one was not successful with a setting change, and reported that the only way he found to end the problem was to turn off the touch capability in the Windows Device Manager (post 522974). I hope that is not necessary in your case.

This could be related to your new hardware. In order to be "mobile friendly" some websites may change menu behavior for devices with a touchscreen. Does your laptop have a touchscreen? To disable Firefox from telling websites that you have a touchscreen, you can make a change to a hidden setting. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''touch''' and pause while the list is filtered (3) Double-click the '''dom.w3c_touch_events.enabled''' preference and change the value to 0 (that's a zero) and click OK. Here are the options for this setting: * 0 = disabled * 1 = enabled * 2 = auto-detect (default) ---- To see whether the site behaves differently, you may need to clear cache and cookies for the site. (1) Bypass Firefox's Cache Use Ctrl+Shift+r to reload the page fresh from the server. Alternately, you also can clear Firefox's cache completely using: orange Firefox button (or Tools menu) > Options > Advanced On the Network mini-tab > Cached Web Content : "Clear Now" If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click and choose View Page Info > Security > "View Cookies" * Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page. Does hover work normally again? ---- A user with an HP all-in-one was not successful with a setting change, and reported that the only way he found to end the problem was to turn off the touch capability in the Windows Device Manager ([https://support.mozilla.org/questions/971084?page=2#answer-522974 post 522974]). I hope that is not necessary in your case.

Chosen Solution

thank you jscher2000, i believe you're right!

disabling 'HID-compliant touch screen' in the Windows Device Manager did solve my problem.

since i don't really use touch devices on laptop, i'm very glad that the problem bothered me for few months finally worked out.

i'm also a software developer myself. with a certain understanding of computers, i'm still very confused how devices could influence firefox behaviours. because changing dom.w3c_touch_events.enabled didn't solve my problem.

i wonder whether it's a windows 8 systematic malfunction or just a firefox bug.

but anyway, i can't thank you enough :-)

thank you jscher2000, i believe you're right! ''' disabling 'HID-compliant touch screen' in the Windows Device Manager''' did solve my problem. since i don't really use touch devices on laptop, i'm very glad that the problem bothered me for few months finally worked out. i'm also a software developer myself. with a certain understanding of computers, i'm still very confused how devices could influence firefox behaviours. because changing '''dom.w3c_touch_events.enabled''' didn't solve my problem. i wonder whether it's a windows 8 systematic malfunction or just a firefox bug. but anyway, i can't thank you enough :-)

Modified by revantis

jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Hopefully someone is working on this issue, because there really should be a way to force sites to serve non-touch versions of pages without actually disabling the touchscreen.

Hopefully someone is working on this issue, because there really should be a way to force sites to serve non-touch versions of pages without actually disabling the touchscreen.