X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Where to download Firefox 26? My add-on doesn't work with 27.

Posted

I use Roboform, which isn't yet compatible with Firefox 27. I need to reinstall Firefox 26. Where can I download it from? Thanks.

Post a Reply

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.107 Safari/537.36

More Information

VSSKANAND 4 solutions 32 answers

Link removed. See my second post.

Modified by Moses

Was this helpful to you?
Reply

Helpful Reply

Hello vsskanand,

The download worked fine and installed Firefox 26. During the install, I deselected 'Install Maintenance Service'. However, after I installed Firefox 26, I went to 'Help' > 'About' in order to just confirm that it was indeed 26. When I did that, Firefox automatically downloaded 27 and activated it on next start up.

So I had to uninstall 27 and reinstall 26 again. I just mention this for others who may go through the same thing. Once you install 26, if you go to 'Help' > 'About', Firefox will auto-upgrade to 27, even if you deselected 'Install Maintenance Service'.

Thanks for your help in getting me what I needed. I will close this problem.

Was this helpful to you? 1
Reply

Question owner

Firefox 26 appeared to work fine but after I rebooted my PC, Firefox won't start up. I have to uninstall 26 and reinstall 27 in order to get Firefox to run. But then it's incompatible with RoboForm. I really don't want to switch browsers. Need help if anyone knows the resolution. Thanks.

Was this helpful to you?
Reply
Moses
  • Top 10 Contributor
  • Moderator
139 solutions 1430 answers

Helpful Reply

@VSSKANAND Please do not post links outside of Mozilla sources. Previous versions of Firefox can be found at http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/ I have removed your link.

@sgracer The reason Firefox updates automatically again is because you haven't disabled it. Go to https://support.mozilla.org/en-US/kb/what-mozilla-maintenance-service to disable it. then report back to us.

Additionally, you may choose to contact Roboform at http://www.roboform.com/support to see if they plan to update Roboform to work with Firefox 27 as it is out of Mozilla's control.

Modified by Moses

Was this helpful to you? 1
Reply
VSSKANAND 4 solutions 32 answers

@moses Thanks for telling me.

Was this helpful to you?
Reply

Question owner

Moses,

Which version of 26 should I download? There are about ten of them out there. Should I just go with the lastest one?

I did contact Roboform but they haven't responded yet.

Thanks.

Was this helpful to you?
Reply
Moses
  • Top 10 Contributor
  • Moderator
139 solutions 1430 answers

Chosen Solution

If you are running Windows, click http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/26.0/win32/en-US/ and select either one.

Mac: http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/26.0/mac/en-US/

Linux i686: http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/26.0/linux-i686/en-US/

Linux amd64: http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/26.0/linux-x86_64/en-US/

Click the link that best supports your operating system,.

Was this helpful to you? 1
Reply

Question owner

Thank you Moses. All set.

Was this helpful to you?
Reply
James
  • Top 25 Contributor
  • Moderator
437 solutions 3164 answers

sgracer wrote: Which version of 26 should I download? There are about ten of them out there. Should I just go with the lastest one?

The 26.0b1 to b10 were Beta builds of 26.0

.

Ideally you should use the latest Release due to security fixes. https://www.mozilla.org/security/known-vulnerabilities/firefox.html

Was this helpful to you?
Reply

Question owner

bermea, I tried downloading with the 26 link you sent but Firefox installed version 27 anyway.

Was this helpful to you?
Reply
Moses
  • Top 10 Contributor
  • Moderator
139 solutions 1430 answers

sgracer: I contacted Roboform about this issue and got this response:

Moses, Sorry for the delay. Currently everything is working with the latest Firefox version. They must have the latest version of RoboForm as well. I wasn't able to find the customers in our system. they will need to make sure the addon has been enabled. Here is the steps on how to do it. Firefox version 8 and above disables RoboForm after the installation due to RoboForm being installed as a 3rd party program. To re-enable the RoboForm Addon within Firefox select Tools >> Addons >> Extensions >> RoboForm Toolbar 7.6.2 (and or Latest Version), Enable if you have any more questions please let me know.

Please follow those steps as Roboform is working for me without any problems.

Was this helpful to you?
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.