X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Thursday, April 2, between 3pm and 5pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Firefox will not play youtube on forums that use the [youtube]xxx [/youtube] tag.

Posted

On forums that use the [youtube]/youtube tag videos will not play. They will play on websites and on Youtube.com

I have tried safe mode Firefox, clearing history and cookies and disabling all plugins and extensions.

Currently have Firefox 27 and this happens on both a Win 7 and XP machine.

I have also tried resetting Firefox too.

When someone enters a [youtube]xxx/youtube or when I enter on a new post nothing shows up but a blanck space where the window would be.

On forums that use the [youtube][/youtube] tag videos will not play. They will play on websites and on Youtube.com I have tried safe mode Firefox, clearing history and cookies and disabling all plugins and extensions. Currently have Firefox 27 and this happens on both a Win 7 and XP machine. I have also tried resetting Firefox too. When someone enters a [youtube]xxx[/youtube] or when I enter on a new post nothing shows up but a blanck space where the window would be.

Modified by Red Raspberry

Chosen solution

Thank for the test results, that's very interesting. I think there may be circumstances where Firefox goofs and fails to display the shield, but I don't know why an extension (if that is the culprit) would affect that. If you return to normal mode and just disable extensions relating to video, does that make any difference?

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.06

Application

  • Firefox 27.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:27.0) Gecko/20100101 Firefox/27.0
  • Support URL: https://support.mozilla.org/1/firefox/27.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.4.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Add-on Compatibility Reporter 2.0.1 (compatibility@addons.mozilla.org)
  • avast! Online Security 9.0.2013.75 (wrc@avast.com)
  • Better Gmail 2 1.2 (bettergmail2@ginatrapani.org)
  • Broadband Speed Test and Diagnostics 1.2.5 (speedtest@gotomyhelp.com)
  • FEBE 7.3.0.1 ({4BBDD651-70CF-4821-84F8-2B918CF89CA3})
  • Flagfox 4.2.17 ({1018e4d6-728f-4b20-ad56-37578a4de76b})
  • Freeze.com NetAssistant 3.6.5 ({1266764D-FC4F-4FA7-B63B-884D53B1680F})
  • Garmin Communicator 4.1.0 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Google Shortcuts 2.1.7.1 ({5C46D283-ABDE-4dce-B83C-08881401921C})
  • Image Zoom 0.6.3 ({1A2D0EC4-75F5-4c91-89C4-3656F6E44B68})
  • Logitech Device Detection 1.23.0.5 (DeviceDetection@logitech.com)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b})
  • Open in IE 1.4 (openinie@wittersworld.com)
  • QuickPrint 0.1.2 ({09408840-3f84-11dd-ae16-0800200c9a66})
  • RoboForm Toolbar for Firefox 7.9.3.9 ({22119944-ED35-4ab1-910B-E619EA06A115})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Youtube to MP3 Plugin 2.0 (flv2mp3@hotger.com)
  • Youtube™ Search 1.0.5 (a000b9@wips.com)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Mobile Intel(R) 4 Series Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2a42
  • adapterDeviceID2:
  • adapterDrivers: igxprd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedDriver']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 7-23-2012
  • driverDate2:
  • driverVersion: 6.14.10.5420
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Mobile Intel(R) 4 Series Express Chipset Family Direct3D9 vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.fixup.alternate.enabled: False
  • browser.history_expire_days.mirror: 180
  • browser.newtab.url: about:blank
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20140127194636
  • browser.startup.homepage: https://mail.google.com/mail/u/0/?shva=1#inbox
  • browser.startup.homepage_override.buildID: 20140127194636
  • browser.startup.homepage_override.mstone: 27.0
  • browser.tabs.warnOnClose: False
  • browser.tabs.warnOnOpen: False
  • browser.urlbar.default.behavior: 2
  • dom.max_chrome_script_run_time: 60
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 27.0
  • keyword.URL: http://www.google.com/search?sourceid=navclient&hl=en&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1392066305
  • places.history.expiration.transient_current_max_pages: 91401
  • places.last_vacuum: 1313882594
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.flash: 0
  • plugin.state.java: 0
  • plugin.state.npdeployjava: 0
  • plugin.state.npdrmv: 0
  • plugin.state.npdsplay: 0
  • plugin.state.npgarmin: 0
  • plugin.state.npgeplugin: 0
  • plugin.state.npgoogleupdate: 0
  • plugin.state.nplogitechdevicedetection: 0
  • plugin.state.nppdf: 1
  • plugin.state.npqtplugin: 0
  • plugin.state.npvlc: 0
  • plugin.state.npwmsdrm: 0
  • plugin.state.npwpf: 0
  • privacy.cpd.offlineApps: True
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1390948416

Misc

  • User JS: Yes
  • Accessibility: Yes
jscher2000
  • Top 10 Contributor
8957 solutions 73389 answers

Helpful Reply

Does the forum use a secure (HTTPS) address? In that case, please check for a "shield" icon to the left of the padlock, which might indicate that the code the site is using to embed the video is using an HTTP address, triggering Firefox's "mixed content" block. This article has more information on that issue: Mixed content blocking in Firefox


If that isn't it, could you try disabling the avast! Online Security extension? It has been associated with missing content on some sites (such as Disqus comment sections). You can do that on the Add-ons page. Either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions. Firefox will inform you if you need to restart before the change takes effect.

Does the forum use a secure (HTTPS) address? In that case, please check for a "shield" icon to the left of the padlock, which might indicate that the code the site is using to embed the video is using an HTTP address, triggering Firefox's "mixed content" block. This article has more information on that issue: [[How does content that isn't secure affect my safety?]] ---- If that isn't it, could you try disabling the avast! Online Security extension? It has been associated with missing content on some sites (such as Disqus comment sections). You can do that on the Add-ons page. Either: * Ctrl+Shift+a * orange Firefox button (or Tools menu) > Add-ons In the left column, click Extensions. Firefox will inform you if you need to restart before the change takes effect.

Question owner

Thanks for your help.

Yes the site uses HTTPS.

I have the Avast plug in disabled.

But there is no shield icon to click and disable the protection on the individual page. Just the padlock.

Thanks for your help. Yes the site uses HTTPS. I have the Avast plug in disabled. But there is no shield icon to click and disable the protection on the individual page. Just the padlock.

Helpful Reply

I started FF in safe mode and went to a page with the embedded youtube. Here the shield showed up, it did not when starting FF normally.

I clicked on the shield and disabled the protection. This now allows the youtube video to show.

So I guess now the question is how to get the shield to show up when the protection has been added and running FF in normal mode?

I started FF in safe mode and went to a page with the embedded youtube. Here the shield showed up, it did not when starting FF normally. I clicked on the shield and disabled the protection. This now allows the youtube video to show. So I guess now the question is how to get the shield to show up when the protection has been added and running FF in normal mode?
jscher2000
  • Top 10 Contributor
8957 solutions 73389 answers

Chosen Solution

Thank for the test results, that's very interesting. I think there may be circumstances where Firefox goofs and fails to display the shield, but I don't know why an extension (if that is the culprit) would affect that. If you return to normal mode and just disable extensions relating to video, does that make any difference?

Thank for the test results, that's very interesting. I think there may be circumstances where Firefox goofs and fails to display the shield, but I don't know why an extension (if that is the culprit) would affect that. If you return to normal mode and just disable extensions relating to video, does that make any difference?

Question owner

It was Adobe Flash plugin that was being blocked. But it was disabled.

I just could not see the shield once you block the content. I have to go back and restart FF in safe mode, then I can see the shield and can enable the content.

If I choose to disable the content while in safe mode the shield will again disappear and I have to restart FF in safe mode again to again see the shield. If you allow the content then the shield shows up all the time.

But the problem has been resolved and all on the forum who were affected thank you. This has been going on since last summer some time.

It was Adobe Flash plugin that was being blocked. But it was disabled. I just could not see the shield once you block the content. I have to go back and restart FF in safe mode, then I can see the shield and can enable the content. If I choose to disable the content while in safe mode the shield will again disappear and I have to restart FF in safe mode again to again see the shield. If you allow the content then the shield shows up all the time. But the problem has been resolved and all on the forum who were affected thank you. This has been going on since last summer some time.

Modified by Red Raspberry