X
Tap here to go to the mobile version of the site.

Support Forum

media.windows-media-foundation.enabled set to false doesn't stop MP3 files from playing instead of saving. I want my file saving preference back. How?

Posted

I used to be able to click on MP3 files and they would save, as per the the setting in my Options. Now when I click on a link to an MP3 it goes to a player page, which I don't want.

I looked through the help here, and it suggested changing media.windows-media-foundation.enabled to false. I did this, and it didn't make any difference. (Rebooting after making the change didn't help either.)

I'm using version 26.0 in Windows XP. I hadn't downloaded MP3s since July, so I don't know which version this started.

I used to be able to click on MP3 files and they would save, as per the the setting in my Options. Now when I click on a link to an MP3 it goes to a player page, which I don't want. I looked through the help here, and it suggested changing media.windows-media-foundation.enabled to false. I did this, and it didn't make any difference. (Rebooting after making the change didn't help either.) I'm using version 26.0 in Windows XP. I hadn't downloaded MP3s since July, so I don't know which version this started.

Chosen solution

Windows XP doesn't use Media Foundation, it uses DirectShow (DirectX). To disable it, there is a different preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media. and pause while the list is filtered

(3) Double-click the media.directshow.enabled preference to switch it from true to false.

I don't know whether that changes takes effect immediately or after you exit and restart Firefox.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Google Update
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • DivX VOD Helper Plug-in
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0

More Information

jscher2000
  • Top 10 Contributor
8432 solutions 68777 answers

Chosen Solution

Windows XP doesn't use Media Foundation, it uses DirectShow (DirectX). To disable it, there is a different preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste media. and pause while the list is filtered

(3) Double-click the media.directshow.enabled preference to switch it from true to false.

I don't know whether that changes takes effect immediately or after you exit and restart Firefox.

Windows XP doesn't use Media Foundation, it uses DirectShow (DirectX). To disable it, there is a different preference: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''media.''' and pause while the list is filtered (3) Double-click the '''media.directshow.enabled''' preference to switch it from true to false. I don't know whether that changes takes effect immediately or after you exit and restart Firefox.

Question owner

Thank you very much! That fixed the issue :)

Thank you very much! That fixed the issue :)
blindfred 0 solutions 5 answers

Does anyone know how to fix it on Windows 7?

I usually download 50+ mp3s each week and have switched back to FF17.

Or perhaps someone knows of a "safe" recent version which doesn't have this problem?

Thanks

Does anyone know how to fix it on Windows 7? I usually download 50+ mp3s each week and have switched back to FF17. Or perhaps someone knows of a "safe" recent version which doesn't have this problem? Thanks
jscher2000
  • Top 10 Contributor
8432 solutions 68777 answers

Hi blindfred, to stop Firefox from playing MPEG-encoded media in a page or in a stand-alone tab on Windows Vista/7/8, you need to change the following preferences:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste media. and pause while the list is filtered

(3) Double-click media.windows-media-foundation.enabled to switch its value from true to false. (This is the standard method for Windows Vista/7/8)

(4) Double-click media.directshow.enabled to switch its value from true to false. (This is an additional method available on Windows XP/Vista/7/8)

Hi blindfred, to stop Firefox from playing MPEG-encoded media in a page or in a stand-alone tab on Windows Vista/7/8, you need to change the following preferences: (1) In a new tab, type or paste <strong>about:config</strong> in the address bar and press Enter. Click the button promising to be careful. (2) In the filter box, type or paste <strong>media.</strong> and pause while the list is filtered (3) Double-click <strong>media.windows-media-foundation.enabled</strong> to switch its value from true to false. (This is the standard method for Windows Vista/7/8) (4) Double-click <strong>media.directshow.enabled</strong> to switch its value from true to false. (This is an additional method available on Windows XP/Vista/7/8)
blindfred 0 solutions 5 answers

Thank you, that's really appreciated. Blindfred

Thank you, that's really appreciated. Blindfred