X
Tap here to go to the mobile version of the site.

Support Forum

Memory problems (/questions/967643)

Posted

FIrefox uses 1 gig+ of RAM with almost nothing running.

FIrefox uses 1 gig+ of RAM with almost nothing running.

Chosen solution

So far, I added "noscript" to firefox, and it is making an immediate difference. I have 12 tabs open, and ram usage is only 290 megs. So, seems like problem solved.... I hope

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Google Update
  • GEPlugin
  • McAfee MSS+ NPAPI Plugin
  • LogMeIn, Inc. Remote Access Components
  • 115.COM Upload Plugin For Firefox and Netscape
  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • DivX Plus Web Player version 2.2.0.52
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.0.61118.0
  • DivX VOD Helper Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.4"
  • npmnqmp 989898989877
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.1465
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • Firefox 26.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0
  • Support URL: https://support.mozilla.org/1/firefox/26.0/WINNT/en-US/

Extensions

  • LogMeIn, Inc. Remote Access Plugin 1.0.0.1024 (LogMeInClient@logmein.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • DivX Plus Web Player HTML5 <video> 2.1.2.145 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)
  • Java Quick Starter 1.0 (jqs@sun.com) (Inactive)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)
  • Move Media Player 7 (moveplayer@movenetworks.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: RADEON X300 SE 128MB HyperMemory
  • adapterDescription2:
  • adapterDeviceID: 0x5b60
  • adapterDeviceID2:
  • adapterDrivers: ati2dvag
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 8-3-2005
  • driverDate2:
  • driverVersion: 8.162.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'9.6']
  • numTotalWindows: 2
  • webglRendererMessage: [u'tryNewerDriver', u'9.6']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 26.0
  • font.internaluseonly.changed: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1388967929
  • places.history.expiration.transient_current_max_pages: 48162
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1386894814

Misc

  • User JS: No
  • Accessibility: No
guigs 1072 solutions 11697 answers

Helpful Reply

I would be happy to help you free some of that extra memory that Firefox is using on your machine.

First please check out the hardware and software troubleshooting parts of this article and select the Operating system and Firefox version at the top of the article to get the right information: Firefox uses too much memory (RAM) - How to fix http://mzl.la/LnX4ca

If you open the Task Manager on a Windows machine or the Activity Monitor on a Mac machine Applications -> Utilities or on a Linux from the command line you can Check your /var/log/message my favorite reference: http://rimuhosting.com/howto/memory.jsp

With these tools we will be able to see memory change as we troubleshoot.

This typically happens when a browser has been sitting for a long time or the settings of the browser allow the browser to use the free memory on the computer. However it can also be the connection, a large cache of user data, a certificate issue, or Firefox may need to be updated.

All of the built in browser tools and network information found in the browser have a high level of detail in that help article. If the issue persists after optimizing the memory for your platform, please do not hesitate to ask any other questions.

I would be happy to help you free some of that extra memory that Firefox is using on your machine. First please check out the hardware and software troubleshooting parts of this article and select the Operating system and Firefox version at the top of the article to get the right information: [[Firefox uses too much memory (RAM) - How to fix]] [http://mzl.la/LnX4ca] If you open the Task Manager on a Windows machine or the Activity Monitor on a Mac machine Applications -> Utilities or on a Linux from the command line you can Check your /var/log/message my favorite reference: http://rimuhosting.com/howto/memory.jsp With these tools we will be able to see memory change as we troubleshoot. This typically happens when a browser has been sitting for a long time or the settings of the browser allow the browser to use the free memory on the computer. However it can also be the connection, a large cache of user data, a certificate issue, or Firefox may need to be updated. All of the built in browser tools and network information found in the browser have a high level of detail in that help article. If the issue persists after optimizing the memory for your platform, please do not hesitate to ask any other questions.
guigs 1072 solutions 11697 answers

You can also free unused memory if you enter "about:memory" in the url bar and minimize it here.

You can also free unused memory if you enter "about:memory" in the url bar and minimize it here.
iamjayakumars 489 solutions 5951 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.

Chosen Solution

So far, I added "noscript" to firefox, and it is making an immediate difference. I have 12 tabs open, and ram usage is only 290 megs. So, seems like problem solved.... I hope

So far, I added "noscript" to firefox, and it is making an immediate difference. I have 12 tabs open, and ram usage is only 290 megs. So, seems like problem solved.... I hope
Lianne 0 solutions 1 answers

How do you add "noscript" to firefox? I've tried several other alternatives and last night firefox was using 2.1 gigs with 4 tabs open

How do you add "noscript" to firefox? I've tried several other alternatives and last night firefox was using 2.1 gigs with 4 tabs open