Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Starting 1/4/14, Instagram videos no longer play in my Firefox. They work fine in Safari and Chrome, just not FF.

  • 15 replies
  • 8 have this problem
  • 8090 views
  • Last reply by jscher2000

more options

I haven't had any problems playing Instagram videos in Firefox previous to 1/4/14. I've updated all my plug ins, turned off AdBlock, but nothing is working.

Chosen solution

Firefox would not complete the Forget this Site process, and I had to force quit. I tried 3 times, and then I just went into the cookies and deleted all Instagram cookies. Once I did that, I was able to see the videos again in Firefox. I really never thought something that simple to clear up the issue!

Thanks to everyone for their help!

Read this answer in context 👍 0

All Replies (15)

more options

Are they "real" videos or animated GIFs with sequences of still images?


More generally, when you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Command+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

Firefox menu > Preferences > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

more options

I noticed you have Greasemonkey installed. Do any of your userscripts operate on Instagram? If you click the little triangle next to the monkey icon on the toolbar, the pop-up should show a checkmark for any active scripts.

more options

Real videos.

more options

No Instagram userscripts associated with Greasemonkey.

more options

You seem to have a duplicate plug-in - Version 4.9.1.16010 and Version 4.8.2.15856. I would try deleting the older one and also disabling both the newer one and Google Talk Video and Voice Plug-in.

more options

If you wouldn't mind looking at a couple of things.

Apologies if you are tired of holiday music, but this is a short video, so useful for testing: http://instagram.com/p/iMZ8PBEbBS/

(1) When you load the page, does Firefox display any notification icons in the address bar (to the left of the globe or padlock icon)? If so, please click and see what it's about.

(2) Does Firefox's Browser Console show any relevant errors?

To open the console, either:

  • Command + Shift + j
  • Tools > Developer Tools > Browser Console

Click the Clear button, then switch over to the tab with the test video and reload the page. In the console, there likely will be a lot of stuff. You can "unclick" the CSS button to reduce the noise and scan down looking for any errors in retrieving parts of the page. You would expect mostly "200 OK" and "304 Not Modified" results on the right side.

Assuming nothing interesting, back in the test tab, try to play the video and then see whether any new errors appear in the console.

Note: I'm testing on Windows 7, so Firefox is playing the MP4 media using Windows Media Foundation, which does not exist on Mac, so I probably can't get too detailed on what is normal for you.

more options

Disabled all the Google plug-ins, but couldn't delete the older one. That didn't seem to solve the issue.

more options

(1) No notifications showing.

(2) Did all the console steps, and when I tried to play the video, I get this error:

TypeError: this.player is null DesktopPPage.js:419:52:08.864 Use of getPreventDefault() is deprecated. Use defaultPrevented instead.

more options

Hmm, I'm not loading "DesktopPPage.js" on Windows (just "ppage.js"). I can view that script (http://d36xtkk24g8jdx.cloudfront.net/.../DesktopPPage.js) but it's too tangled for me to make any useful suggestions. Hopefully a volunteer with MacOS can test the page and spot the issue.

more options

Thanks for trying! I do appreciate it. It was working fine a couple of days ago, and I haven't changed anything, so it's just strange that it's stopped.

more options

Line 4 of that script inject some CSS code.

function (n, t, e) {
    e(2).injectCSS('IGDialog', '......', 'IGDialog.scss')
}

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks.

You can't recover from this 'forget' unless you have a backup of the involved files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.


Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.

more options

Chosen Solution

Firefox would not complete the Forget this Site process, and I had to force quit. I tried 3 times, and then I just went into the cookies and deleted all Instagram cookies. Once I did that, I was able to see the videos again in Firefox. I really never thought something that simple to clear up the issue!

Thanks to everyone for their help!

more options

Thank you for reporting back. (And now you see why it's our first suggestion.)

more options

I totally and completely missed the bottom part of your first message suggesting the cookie deletion yesterday! I am so sorry! I was focused on answering the question about videos, and then I was looking into the Greasemonkey stuff.

more options

No worries. Happens all the time. Because volunteers' schedules don't always permit a sequential back and forth, you tend to get multiple sometimes conflicting suggestions all at once. And the lack of threaded replies makes it even harder to follow. But... back to the next post. :-)