X
Tap here to go to the mobile version of the site.

Support Forum

How do I stop video autoplay? This just started a few weeks ago. At first I thought it was a Facebook thing but it now also happens on other websites.

Posted

Seems to have started with Firefox 26. I use Windows 8.1 and am sometimes using their START screen to play a few games. BUT my Firefox is still open in the background. I have had the sound from an autoplayed video on Firefox come through when I was on the Windows screen. VERY ANNOYING.

Seems to have started with Firefox 26. I use Windows 8.1 and am sometimes using their START screen to play a few games. BUT my Firefox is still open in the background. I have had the sound from an autoplayed video on Firefox come through when I was on the Windows screen. VERY ANNOYING.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • McAfee MSC FF plugin DLL
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • Citrix Online App Detector Plugin
  • Coupons, Inc. Coupon Printer 4.0.2.0
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components

Application

  • Firefox 26.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
  • Support URL: https://support.mozilla.org/1/firefox/26.0/WINNT/en-US/

Extensions

  • CouponsHelper 1.1.8 ({239cc760-75a9-4276-b1fc-c0ceb963f373})
  • InvisibleHand 3.9.19 (canitbecheaper@trafficbroker.co.uk)
  • McAfee SafeKey 2.1.4 ({072844D3-7DEE-45F6-A406-E87F76302E4B})
  • Norton Vulnerability Protection 12.0.4.5 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB})
  • RealDownloader 1.3.3 ({DF153AFF-6948-45d7-AC98-4FC4AF8A08E2})
  • Slick Savings 2.8 (savingsslider@mybrowserbar.com)
  • Start Page 1.0 ({58d2a791-6199-482f-a9aa-9b725ec61362})
  • Translate This! 3.0.1 (jid0-k75TfRGfOXPHfEZmJ9cKu5eCgLc@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Norton Toolbar 2013.4.3.7 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)
  • YTD Toolbar 8.5 (ytd@mybrowserbar.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 10-1-2013
  • driverDate2:
  • driverVersion: 10.18.10.3316
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.param.yahoo-fr: chr-greentree_ff&ilc=12&type=937811
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage: about:newtab
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • browser.tabs.loadInBackground: False
  • browser.tabs.warnOnOpen: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 26.0
  • font.internaluseonly.changed: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • keyword.URL: http://search.yahoo.com/search?fr=greentree_ff1&ei=utf-8&ilc=12&type=937811&p=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1388359549
  • places.history.expiration.transient_current_max_pages: 104053
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npconduitfirefoxplugin: 0
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.downloads: False
  • privacy.clearOnShutdown.formdata: False
  • privacy.clearOnShutdown.history: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.promptOnSanitize: False
  • privacy.sanitize.sanitizeOnShutdown: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1386098524

Misc

  • User JS: No
  • Accessibility: No
Diego Victor 658 solutions 4175 answers

Hello,

I found this old question:

This way you need access the about:config:

Hello, I found this old question: *[https://support.mozilla.org/pt-BR/questions/961940 questions/961940] This way you need access the about:config: *[http://kb.mozillazine.org/About:config About:config] *[http://www.techsupportalert.com/freeware-forum/showthread.php?p=90869 Stop Autoplay]

Question owner

Thanks, I found that answer earlier myself but it does not solve my problem. In about:config the click-to-play already has TRUE next to it and Click-to-play does not show up in my Plugins list.

Any other ideas?

Thanks, I found that answer earlier myself but it does not solve my problem. In about:config the click-to-play already has TRUE next to it and Click-to-play does not show up in my Plugins list. Any other ideas?
jscher2000
  • Top 10 Contributor
8801 solutions 71984 answers

Helpful Reply

It's a little complicated because Firefox plays some video formats itself without a plugin. For others it may use Flash, the Windows Media Player, QuickTime, or another plugin depending on what the page specifies and what plugins you have installed.

Also, some sites use a script to start the video after the page loads. Facebook is now doing this as you scroll down, playing when a video comes into view and pausing when it goes out of view. Fun, hunh?

Because of this, there's no universal solution for clamping down on all videos.

Here are a couple of built-in settings that might help:

(1) For videos Firefox plays itself in the built-in HTML5 video player, there is a preference you can change: media.autoplay.enabled (but scripts in the page can bypass that)

(2) For plugins, you can set "Ask to Activate" on the ones you do not want to run automatically. Visit the Add-ons page using either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Plugins.

When you visit a site that wants to use the plugin, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page.

Beyond that, you would need to find one or more add-ons.

It's a little complicated because Firefox plays some video formats itself without a plugin. For others it may use Flash, the Windows Media Player, QuickTime, or another plugin depending on what the page specifies and what plugins you have installed. Also, some sites use a script to start the video after the page loads. Facebook is now doing this as you scroll down, playing when a video comes into view and pausing when it goes out of view. Fun, hunh? Because of this, there's no universal solution for clamping down on all videos. Here are a couple of built-in settings that might help: (1) For videos Firefox plays itself in the built-in HTML5 video player, there is a preference you can change: media.autoplay.enabled (but scripts in the page can bypass that) (2) For plugins, you can set "Ask to Activate" on the ones you do not want to run automatically. Visit the Add-ons page using either: * Ctrl+Shift+a * orange Firefox button (or Tools menu) > Add-ons In the left column, click Plugins. When you visit a site that wants to use the plugin, you should see a notification icon in the address bar and one of the following: a link in a black rectangle in the page or an infobar sliding down between the toolbar area and the page. Beyond that, you would need to find one or more add-ons.

Question owner

Thanks. It does sound complicated. I appreciate your response.

Looks like it may be something I just have to learn to live with.

Thanks. It does sound complicated. I appreciate your response. Looks like it may be something I just have to learn to live with.
jscher2000
  • Top 10 Contributor
8801 solutions 71984 answers

You can try switching a plugin or two to Ask to Activate and see whether it helps. It's easy to switch back if you decide it doesn't.

You can try switching a plugin or two to Ask to Activate and see whether it helps. It's easy to switch back if you decide it doesn't.