X
Tap here to go to the mobile version of the site.

Support Forum

How can I permanently disable the "allow?" pop-up when I go full screen?

Posted

I want to be able to expand web page pictures to full screen without one of two annoying pop-up mini wdws always popping up.

-One is the instructional: "______ is now fullscreen; press esc. at any time to exit fullscreen"
-The second is along the same lines, something about: "allow ________ to be fullscreen?" with a checkbox to 'allow'

I KNOW how to exit full screen. I don't want to be reminded for a full second every single time I expand a picture. As far as allowing a website to expand a picture to full screen, if I click full screen, obviously I want to engage full screen on that web page. In fact, why would firefox even give the option to disallow the function? It seems like shooting a spider with a shotgun---when there's no spider in the first place.

Firefox 24.0

I want to be able to expand web page pictures to full screen without one of two annoying pop-up mini wdws always popping up. -One is the instructional: "______ is now fullscreen; press esc. at any time to exit fullscreen"<br /> -The second is along the same lines, something about: "allow ________ to be fullscreen?" with a checkbox to 'allow' I KNOW how to exit full screen. I don't want to be reminded for a full second every single time I expand a picture. As far as allowing a website to expand a picture to full screen, if I click full screen, obviously I want to engage full screen on that web page. In fact, why would firefox even give the option to disallow the function? It seems like shooting a spider with a shotgun---when there's no spider in the first place. Firefox 24.0

Modified by cor-el

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Google Update
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • GEPlugin
  • Pokki Download Helper
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NPWLPG
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

Brayden M 4 solutions 26 answers

This happens every time you go fullscreen? Because as far as I know once you allow the website to go fullscreen once it should not ever happen again on that same website.

By the way, I recommend you update to the latest Firefox 26 to avoid any future problems and to enhance your security

https://www.mozilla.org/en-US/firefox/new/

This happens every time you go fullscreen? Because as far as I know once you allow the website to go fullscreen once it should not ever happen again on that same website. By the way, I recommend you update to the latest Firefox 26 to avoid any future problems and to enhance your security https://www.mozilla.org/en-US/firefox/new/

Modified by Brayden M

cor-el
  • Top 10 Contributor
  • Moderator
13045 solutions 119454 answers

Helpful Reply

This happens as part of the full screen permissions as you can inspect on the "Tools > Page Info > Permissions" window for the current web page.
If you enter full screen mode via a button on a web page that uses the full screen API then you get this notification.

There are full-screen-api.* prefs tied to this feature that you can inspect on the about:config page.

  • full-screen-api.approval-required
This happens as part of the full screen permissions as you can inspect on the "Tools > Page Info > Permissions" window for the current web page.<br /> If you enter full screen mode via a button on a web page that uses the full screen API then you get this notification. There are full-screen-api.* prefs tied to this feature that you can inspect on the <b>about:config</b> page. *full-screen-api.approval-required

Question owner

Neither of these replies helped me (but thank you for trying).

I simply want to set whatever needs to be set so that I never have to look at either of the full screen permission/information mini pop-ups ever again.

Is this really dependent on some setting for each specific webpage?! How utterly bizarre, and what a case of horrible design.

Why would firefox or any other browser care if a webpage is allowed to go full screen? If a user to a webpage clicks full screen on his/her PC, the image/page should just simply go full screen---period.

It's like if I turned on the radio in my car and the radio would first ask me "Did you really mean to turn on the radio?" or "You are turning on the radio now. To turn off the radio, just rotate the knob counter clockwise".

Tell me this isn't as freakishly stupidly designed as it sounds.

Neither of these replies helped me (but thank you for trying). I simply want to set whatever needs to be set so that I never have to look at either of the full screen permission/information mini pop-ups ever again. Is this really dependent on some setting for each specific webpage?! How utterly bizarre, and what a case of horrible design. Why would firefox or any other browser care if a webpage is allowed to go full screen? If a user to a webpage clicks full screen on his/her PC, the image/page should just simply go full screen---period. It's like if I turned on the radio in my car and the radio would first ask me "Did you really mean to turn on the radio?" or "You are turning on the radio now. To turn off the radio, just rotate the knob counter clockwise". Tell me this isn't as freakishly stupidly designed as it sounds.
cor-el
  • Top 10 Contributor
  • Moderator
13045 solutions 119454 answers

I'm only seeing the message about how to leave full screen mode and not the notification if you want to allow the website to use full screen mode. I don't know if there is a way to hide this Exit message and it should disappear automatically. You can suppress the notification asking for permission to enter full screen mode once you have allowed the website (Tools > Page Info > Permissions).

I'm only seeing the message about how to leave full screen mode and not the notification if you want to allow the website to use full screen mode. I don't know if there is a way to hide this Exit message and it should disappear automatically. You can suppress the notification asking for permission to enter full screen mode once you have allowed the website (Tools > Page Info > Permissions).
justintamoore 0 solutions 7 answers

Helpful Reply

cor-el did have the solution in his first reply, sort of, he just didn't elaborate. I'm going to try to describe what to do in a way that future readers who find this page, who may have less experience than you or I, will get.

  • Go to about:config page (just type exactly that in the address box, not a search box)
  • READ the warning if you've never done this before, it's important! But don't worry, this one change is not a big one. Click "I'll be careful! I promise!"
  • Find full-screen-api.approval-required
  • Double click it, it will change the default value from "True" to "False." Done.

I haven't seen the "allow" message since, but I'm not sure if this covers the "How to exit full screen" message, I'll try to update here if I see it again.

This happened to me at seemingly random. Videos from visited sites would display this again sometimes, but not always. Videos from new sites often would not display this. Also, entering in a permission for each individual site where it's randomly not automatically changed, even after you've "allowed" it before, is a pain.

The "You are now viewing in full screen. Press esc to exit" message is just stupid. Your radio analogy is perfect.

It is very mystifying why these messages would ever come up. I mean, what purpose do they serve? Are there malicious sites that can try to force full screen? Is that even possible?

Update 4/2/14: still getting message "Press ESC to exit full screen mode" every time, but not the "allow" or the longer "How to exit" message. It's brief, and not a big deal, but still retarded.

cor-el did have the solution in his first reply, sort of, he just didn't elaborate. I'm going to try to describe what to do in a way that future readers who find this page, who may have less experience than you or I, will get. * Go to '''about:config''' page (just type exactly that in the address box, ''not'' a search box) * READ the warning if you've never done this before, it's important! But don't worry, this one change is not a big one. Click "I'll be careful! I promise!" * Find '''full-screen-api.approval-required ''' * Double click it, it will change the default value from "True" to "False." Done. I haven't seen the "allow" message since, but I'm not sure if this covers the "How to exit full screen" message, I'll try to update here if I see it again. This happened to me at seemingly random. Videos from visited sites would display this again sometimes, but not always. Videos from new sites often would not display this. Also, entering in a permission for each individual site where it's randomly not automatically changed, even after you've "allowed" it before, is a pain. The "You are now viewing in full screen. Press esc to exit" message is just stupid. Your radio analogy is perfect. It is very mystifying why these messages would ever come up. I mean, what purpose do they serve? Are there malicious sites that can try to force full screen? Is that even possible? Update 4/2/14: still getting message "Press ESC to exit full screen mode" every time, but not the "allow" or the longer "How to exit" message. It's brief, and not a big deal, but still retarded.

Modified by justintamoore

Question owner

Here's a screenshot of the other annoying popup to which I attempted to refer in my original posting.

Here's a screenshot of the other annoying popup to which I attempted to refer in my original posting.
justintamoore 0 solutions 7 answers

I hate that one, I know it all too well. It's one of the ones I was trying to refer to, as well. Thanks so much for the screenshot!

I haven't seen it since I did what I did posted above, so that's nice. It's such an erratic little annoyance, I can't promise a fix. If I see it again, I'll update here.

If anyone else sees it after doing what I posted above, or see a problem with what I posted above, please respond here.

I hate that one, I know it all too well. It's one of the ones I was trying to refer to, as well. Thanks so much for the screenshot! I haven't seen it since I did what I did posted above, so that's nice. It's such an erratic little annoyance, I can't promise a fix. If I see it again, I'll update here. If anyone else sees it after doing what I posted above, or see a problem with what I posted above, please respond here.

Modified by justintamoore

Michael_Schmid 0 solutions 2 answers

Setting full-screen-api.approval-required to false also disables the is-now-fullscreen notification.

Setting ''full-screen-api.approval-required'' to ''false'' also disables the is-now-fullscreen notification.

Question owner

Thank you for that, but I have no idea what you're talking about.

Specifically: 1. You seem to be saying some setting or other can be changed to fix this issue; 2. I have no idea where that setting is or how to access it; 3. I have no idea how to change that setting if I were to find it.

Thank you for that, but I have no idea what you're talking about. Specifically: 1. You ''seem ''to be saying some setting or other can be changed to fix this issue; 2. I have no idea where that setting is or how to access it; 3. I have no idea how to change that setting if I were to find it.
finitarry
  • Top 25 Contributor
243 solutions 3345 answers

Is this happening only with the api switching? I disabled the full-screen-api.enabled setup because it was annoying. I do not get any message box popup when using the keyboard shortcut to go to full screen.

Is this happening only with the api switching? I disabled the full-screen-api.enabled setup because it was annoying. I do not get any message box popup when using the keyboard shortcut to go to full screen.
cor-el
  • Top 10 Contributor
  • Moderator
13045 solutions 119454 answers

This is about when you click a button on a web page (e.g. in a media player) to switch to full screen mode. You will never be asked for confirmation if you switch to full screen mode manually.

Firefox asks for confirmation if you click such a button. See full-screen-api.* prefs like full-screen-api.approval-required (default: true).

This is about when you click a button on a web page (e.g. in a media player) to switch to full screen mode. You will never be asked for confirmation if you switch to full screen mode manually. Firefox asks for confirmation if you click such a button. See full-screen-api.* prefs like full-screen-api.approval-required (default: true).
finitarry
  • Top 25 Contributor
243 solutions 3345 answers

I see a message about pressing Esc to go back to normal with a full-screen video, but it lasts only a few seconds. I can put up with it for that long.

I see a message about pressing Esc to go back to normal with a full-screen video, but it lasts only a few seconds. I can put up with it for that long.
cor-el
  • Top 10 Contributor
  • Moderator
13045 solutions 119454 answers

That message to press Escape to leave full screen mode is a different notification.

When Firefox asks for permission to enter full screen mode then this is another notification that doesn't go away on its own.

  • bug 684625 - Display a warning when DOM full-screen mode entered or restricted key pressed

See:

That message to press Escape to leave full screen mode is a different notification. When Firefox asks for permission to enter full screen mode then this is another notification that doesn't go away on its own. *[https://bugzilla.mozilla.org/show_bug.cgi?id=684625 bug 684625] - Display a warning when DOM full-screen mode entered or restricted key pressed See: *http://blog.pearce.org.nz/2011/11/firefoxs-html-full-screen-api-enabled.html

Modified by cor-el

finitarry
  • Top 25 Contributor
243 solutions 3345 answers

I have never seen that, since I disabled the full-screen api. I found having that forced on me to be annoying. It is just as well that one now has a choice.

I have never seen that, since I disabled the full-screen api. I found having that forced on me to be annoying. It is just as well that one now has a choice.

Question owner

Re: finitarry's statement: "I see a message about pressing Esc to go back to normal with a full-screen video, but it lasts only a few seconds. I can put up with it for that long.", I appreciate that it is a minor annoyance and may not bother others, but it still bugs me. I file this under the category of 'Things that computers and technology shouldn't subject us to, given that they are designed by people about five times smarter than I am, and even I'd never design something that stupidly'.

Re: all the talk above about "full-screen-api.approval-required (default: true)", I have finally figured out what on earth justintamoore and others were referring to and have changed that setting to "false". We shall now see if that fixes the issue.

For others like me who crave every single step and don't like even the slightest assumption about either prior knowledge or assuming the 'helpee' knows what is being referred to, I will just add one step to justintamoore's otherwise helpful posting. That is, prior to his step one, I add: To get to an 'about:config' page, just open a new empty broswer page. Then type that exact phrase (about:config) into the address box of the empty brower page just as justintamoore says. This takes you to a whole crazy page(s) of background browser settings that amateur users would normally never fiddle with.

I appreciate all the help and discussion that has been simmering here since late December and has just recently come to a good boil.

Re: finitarry's statement: ''"I see a message about pressing Esc to go back to normal with a full-screen video, but it lasts only a few seconds. I can put up with it for that long."'', I appreciate that it is a minor annoyance and may not bother others, but it still bugs me. I file this under the category of '''Things that computers and technology shouldn't subject us to, given that they are designed by people about five times smarter than I am, and even I'd never design something that stupidly'.'' Re: all the talk above about ''"full-screen-api.approval-required (default: true)"'', I have finally figured out what on earth justintamoore and others were referring to and have changed that setting to "false". We shall now see if that fixes the issue. For others like me who crave '''every '''single step and don't like even the slightest assumption about either prior knowledge or assuming the 'helpee' knows what is being referred to, I will just add one step to justintamoore's otherwise helpful posting. That is, prior to his step one, I add: ''To get to an 'about:config' page, just open a new empty broswer page. Then type that exact phrase (about:config) into the address box of the empty brower page just as justintamoore says. This takes you to a whole crazy page(s) of background browser settings that amateur users would normally never fiddle with. '' I appreciate all the help and discussion that has been simmering here since late December and has just recently come to a good boil.

Question owner

One more little note about something I figured out in response to a suggestion from Brayden M way back in December, who mentioned: "...once you allow the website to go fullscreen once it should not ever happen again on that same website."

Very true (I assume). The thing is that I have my internet settings set to clear all cookies, browser history and pretty much every other trackable thingy every time I shut down my computer. So a website that I've clicked 'allow' for won't remember me next time I visit it.

One more little note about something I figured out in response to a suggestion from Brayden M way back in December, who mentioned: ''"...once you allow the website to go fullscreen once it should not ever happen again on that same website."'' Very true (I assume). The thing is that I have my internet settings set to clear all cookies, browser history and pretty much every other trackable thingy every time I shut down my computer. So a website that I've clicked 'allow' for won't remember me next time I visit it.
cor-el
  • Top 10 Contributor
  • Moderator
13045 solutions 119454 answers

Such choices are stored in the content-prefs.sqlite permissions.sqlite file as part of the Site Preferences.

In case you are using "Clear history when Firefox closes":

  • do not clear the Site Preferences

Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data.


Such choices are stored in the <strike>content-prefs.sqlite</strike> permissions.sqlite file as part of the Site Preferences. In case you are using "Clear history when Firefox closes": *do not clear the Site Preferences *Tools > Options > Privacy > Firefox will: "Use custom settings for history": [X] "Clear history when Firefox closes" > Settings *https://support.mozilla.org/kb/remove-browsing-search-and-download-history Clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, passwords, and other website specific data. ---- *http://kb.mozillazine.org/Profile_folder_-_Firefox

Modified by cor-el

Question owner

Ahh, that is very interesting, cor-el.

Would unchecking Site Preferences not allow me to be 'tracked' more easily in some way that we non-technological people wouldn't understand?

The reason I had set everything to clear when closing down my computer is that I read that it helped to keep from being tracked as easily.

Ahh, that is very interesting, cor-el. Would unchecking ''Site Preferences'' not allow me to be 'tracked' more easily in some way that we non-technological people wouldn't understand? The reason I had set everything to clear when closing down my computer is that I read that it helped to keep from being tracked as easily.
cor-el
  • Top 10 Contributor
  • Moderator
13045 solutions 119454 answers

Usually only cookies allow websites to track you as those are send to the server as part of the HTTP request headers.

You can use the Live Http Headers extension to see what is send to a web server.

Usually only cookies allow websites to track you as those are send to the server as part of the HTTP request headers. You can use the Live Http Headers extension to see what is send to a web server. *https://addons.mozilla.org/firefox/addon/live-http-headers/
finitarry
  • Top 25 Contributor
243 solutions 3345 answers

Clearing Site Preferences does not make sense to me. You would be clearing all the exceptions to whatever site data is allowed or blocked. You would maybe want to do that for one item, but not all at once. SeaMonkey does not even include that item in its list of data to clear, so why should Firefox?

Clearing Site Preferences does not make sense to me. You would be clearing all the exceptions to whatever site data is allowed or blocked. You would maybe want to do that for one item, but not all at once. SeaMonkey does not even include that item in its list of data to clear, so why should Firefox?