Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Remove OpenDNS redirect?

more options

I don't know why, but when I type a search term instead of being taken to google I'm taken to the crappy opendns site search, how do I stop this from happening? I don't recall ever installing anything related to opendns, I want nothing to do with the opendns site.

All Replies (6)

more options
more options

Unfortunately I didn't see anything in the info at that link that would help with the firefox android browser. I've never encountered the opendns site on my pc, it's only on my tabket that I've been seeing it.

more options

Hi praxus07:

Sounds like you have by accident installed the OpenDNS Search Provider as a search engine in Firefox for Android.

If that's the case, here's how to fix the problem:

Delete the OpenSearch search provider as follows:

1. Menu | Settings | Customize | Search settings

2. Long press on "Open DNS" (Open DNS should be at the top followed by Google) and then tap "Remove"

Hope that helps!

Happy Holidays!

...Roland

Modified by Roland Tanglao

more options

Thank you for your reply, unfortunately that isn't the solution. I've followed the steps you provided but opendns doesn't appear in the list. First is google, which is set as default, followed by bing/amazon/yahoo/wikipedia, which might be odd since I've never actually been to bing nor yahoo on this tablet. Long press also doesn't do anything, no option to remove/delete any of them appears, only asks if I want to set one as the default.

Thing is this was happening for several months, then I upgraded to android kitkat, which made my tablet (nexus 7) almost unusable, so I tried a factory reset, then actually downgraded back to jellybean which wiped the tablet clean, fresh installed everything, and still get the opendns redirect when doing some searches from the address bar.

So I'm at a loss here...lol...

more options

This can happen when you enter a one-word search (i.e., no spaces). Firefox will do a DNS lookup to see whether it is a valid server name. Many DNS providers simply report back "no" and Firefox continues to Google, but some return their own page of search results.

If you can't get rid of OpenDNS (probably set in your wi-fi router), the best workaround is to tap one of the buttons that appear next to the "g" icon (or other search provider icon) below the address bar rather than tapping the Go arrow or Enter key. Does that work for you?

Similar thread: Web searches getting redirected to OpenDNS. Cannot access these websites.

more options

Hi praxus07

Thanks for trying and confirming it's not a OpenDNS search engine setting in Firefox for Android (which means it's not a Firefox issue).

This means jscher2000 is right (as always, thanks jscher2000!!!! happy holidays j!) that openDNS is either a) set in your wifi router b) set by your ISP

a) for your wifi router: ask whoever installed (it could be you or it could be your ISP; more and more ISPs install WiFi routers for customers these days; when WiFi first became popular many people installed their own WiFi routers) to remove the OpenDNS settings or configure Google DNS or some other DNS provider

b) ask your ISP's technical support how to disable OpenDNS and configure Google DNS or some other DNS provider

Happy Holidays!

...Roland