X
Tap here to go to the mobile version of the site.

Support Forum

How do you disable the "Press ESC to exit fullscreen" warning from appearing when the pointer goes to the edge of the screen?

Posted

i've seen around the forums questions concerning the warning for enabling full screen, and i have no issues with the permission-giving warning.

my question is specifically when you are ALREADY in full screen, and your mouse goes to the edge of the display, and a warning that says something like:

<insert web address here> is now full screen. Press ESC to exit.

- appears. how do you remove/disable that warning? it's annoying esp. when you're playing a game and accidentally aim near the **upper edge of the screen. (i'm playing Kings Road on facebook btw lol) any help would be appreciated :)

i've seen around the forums questions concerning the warning for enabling full screen, and i have no issues with the permission-giving warning. my question is specifically when you are ALREADY in full screen, and your mouse goes to the edge of the display, and a warning that says something like: <insert web address here> is now full screen. Press ESC to exit. - appears. how do you remove/disable that warning? it's annoying esp. when you're playing a game and accidentally aim near the **upper edge of the screen. (i'm playing Kings Road on facebook btw lol) any help would be appreciated :)

Modified by Slaxx

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • DivX Web Player version 3.0.1.5
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • DivX VOD Helper Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • Kalydo Player Plugin
  • Pando Web Plugin
  • IGG Web3d Updater
  • JoyConect Game Shell
  • 5.1.10411.0
  • SOE Web Installer
  • GBoxRuner 1.0.0.9
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Yahoo Application State Plugin version 1.0.0.7
  • Unity Player 2.6.1f3
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 25.0.1
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0
  • Support URL: https://support.mozilla.org/1/firefox/25.0.1/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Microsoft .NET Framework Assistant 1.0 ({20a82645-c095-46ed-80e3-08825760534b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Mobility Radeon HD 4330
  • adapterDescription2:
  • adapterDeviceID: 0x9552
  • adapterDeviceID2:
  • adapterDrivers: ati2dvag
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate: 5-14-2009
  • driverDate2:
  • driverVersion: 8.593.1.1000
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'9.6']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'9.6']
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131112160018
  • browser.startup.homepage: www.google.com
  • browser.startup.homepage_override.buildID: 20131112160018
  • browser.startup.homepage_override.mstone: 25.0.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 25.0.1
  • font.internaluseonly.changed: False
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1385532073
  • places.history.expiration.transient_current_max_pages: 80511
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1385141541

Misc

  • User JS: No
  • Accessibility: No
Omar Al-Tamimi 1 solutions 9 answers

you can edit it here about:config

you can edit it here about:config

Helpful Reply

hello and thanks for the reply, but i don't think i know how to tweak this area xD mind helping me out? i've tried only 1 thing on this (the solution for fullscreen permission removal), it didn't really work for me, so i just set it back to its default setting. i don't know how to achieve my goal though...

hello and thanks for the reply, but i don't think i know how to tweak this area xD mind helping me out? i've tried only 1 thing on this (the solution for fullscreen permission removal), it didn't really work for me, so i just set it back to its default setting. i don't know how to achieve my goal though...
ideato
  • Top 25 Contributor
772 solutions 5539 answers

Helpful Reply

Hello Slaxx,

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.
  3. type/find(or copy/paste from here) full-screen-api.approval-required
  4. double-click on it to make it False
  5. exit firefox and restart it
Hello Slaxx, # In the [[Location bar autocomplete|Location bar]], type '''about:config''' and press '''Enter'''. The about:config "''This might void your warranty!''" warning page may appear. # Click '''I'll be careful, I promise!''', to continue to the about:config page. # type/find(or copy/paste from here) '''full-screen-api.approval-required''' # double-click on it to make it False # exit firefox and restart it

Modified by guigs

guigs
  • Top 10 Contributor
  • Administrator
  • Moderator
858 solutions 9541 answers

Hi slaxx, This is a really good question because I like to play games too. One way we can investigate what causes that pop up is to open up Web development tools and start the game. If you take note of the time and look at the logs that were generated at the time it can point you to the j's line that causes the browser action. Though something like this may not be an option to disable by default.

Do you happen to have any keyboard shortcuts other than the default ones?

Hi slaxx, This is a really good question because I like to play games too. One way we can investigate what causes that pop up is to open up Web development tools and start the game. If you take note of the time and look at the logs that were generated at the time it can point you to the j's line that causes the browser action. Though something like this may not be an option to disable by default. Do you happen to have any keyboard shortcuts other than the default ones?
cor-el
  • Top 10 Contributor
  • Moderator
13045 solutions 119464 answers

Do you have a one monitor (display) setup or do you have more than one monitor attached?

Do you have a one monitor (display) setup or do you have more than one monitor attached?

Question owner

i only have one monitor~

i only have one monitor~

Question owner

hmm i may have to try that.

nope, just the default shortcuts here~

hmm i may have to try that. nope, just the default shortcuts here~

Question owner

this is what i tried before, it doesn't work :(

anyway, i attached a picture of what i wish to disable. that black warning there. it blocks quite a big portion of the screen.

edit: let me just clear, it appears when the pointer gets to the UPPER edge of the screen.

this is what i tried before, it doesn't work :( anyway, i attached a picture of what i wish to disable. that black warning there. it blocks quite a big portion of the screen. edit: let me just clear, it appears when the pointer gets to the UPPER edge of the screen.

Modified by Slaxx

guigs
  • Top 10 Contributor
  • Administrator
  • Moderator
858 solutions 9541 answers

HI, it has been a while but I found that this is something in the Flash or Adobe software

It looks like it is built in.

HI, it has been a while but I found that this is something in the Flash or Adobe software *Found this on the Adobe help site [http://help.adobe.com/en_US/ActionScript/3.0_ProgrammingAS3/WS2E9C7F3B-6A7C-4c5d-8ADD-5B23446FBEEB.html] It looks like it is built in.
guigs
  • Top 10 Contributor
  • Administrator
  • Moderator
858 solutions 9541 answers

This was the answer to this question:

Ideato- this solved this as well https://support.mozilla.org/en-US/que.../980736? -guigs2, thank you thank you

And just kidding it looks like its an event in the browser: Bug 684625 - Display a warning when DOM full-screen mode entered or restricted key pressed

This was the answer to this question: Ideato- this solved this as well [https://support.mozilla.org/en-US/questions/980736?] -guigs2, thank you thank you And just kidding it looks like its an event in the browser: [https://bugzilla.mozilla.org/show_bug.cgi?id=684625 Bug 684625 - Display a warning when DOM full-screen mode entered or restricted key pressed ]

Modified by guigs

Question owner

and it looks to be built in as far as i can understand lol. soooo... it can't be changed?

that's only as much as i can gather from this lol. if it can't be changed... oh well :( but thanks for the reply :)

and it looks to be built in as far as i can understand lol. soooo... it can't be changed? that's only as much as i can gather from this lol. if it can't be changed... oh well :( but thanks for the reply :)