Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Is a Firefox version compatible with a Samsung Galaxy Tab 3 forth comming?

  • 7 replies
  • 26 have this problem
  • 465 views
  • Last reply by tgray98

more options

The Firefox for Android that is currently available is not compatible with my Samsung Galaxy Tab 3. Is a there a new version in the works that would be compatible?

Chosen solution

Update:

The mobile Firefox 26.0 released December 10 and is on Google Play now has support for Intel x86 mobile chipsets. You do not need to test the Beta builds anymore in order to use Firefox on Intel tablets like Galaxy Tab 3.

https://blog.mozilla.org/futurereleases/2013/12/10/firefox-for-android-optimized-for-devices-that-support-intel-x86-chipsets/

Read this answer in context 👍 3

All Replies (7)

more options

Sure it will be compatible, as long its on Android.

more options

Anushbmx, that is incorrect. Firefox for Android only runs on certain CPUs. For right now the ARMv7 and the ARMv6 CPUs are supported in the stable version. Firefox beta supports both of those as well as x86 (intel) CPUs, which the Galaxy Tab 3 10.1 uses.

We hope to be able to ship an x86 version of Firefox shortly.

more options

When I try to install "Firefox Browser for Android" from Google Play Store on my Samsung Galaxy Tab 3, I get the following message, "Package file is invalid".

more options

Because as kbrosnan said the Tab 3 has a Intel cpu so the Releases including the current 25.0.1 for Android will not work.

Try the Firefox 26.0 Beta on Google Play.

more options

Chosen Solution

Update:

The mobile Firefox 26.0 released December 10 and is on Google Play now has support for Intel x86 mobile chipsets. You do not need to test the Beta builds anymore in order to use Firefox on Intel tablets like Galaxy Tab 3.

https://blog.mozilla.org/futurereleases/2013/12/10/firefox-for-android-optimized-for-devices-that-support-intel-x86-chipsets/

Modified by James

more options

I'm trying to install on a Galaxy Tab 3 10.1. With the newest version I am no longer getting the "package file is invalid" message. I am however now getting a new error message "unknown error code:-24" and am still unable to install.

more options

I do not see the same screens on my Galaxy Tab 3 8.0 that are used in the help files --- very frustrating and disappointing!!!!!!!!!!!!!!!!!!!!