Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox takes a long time to load first time

  • 2 replies
  • 18 have this problem
  • 355 views
  • Last reply by gazzie

more options

Hi

When I turn on my pc and click Firefox icon on my desktop it takes about 2 minutes to get online and see my initial default Firefox page. Once connected the internet works fine. Also if I close Firefox and return after a while it will take a long time to log on again.

I have Windows XP, latest Firefox. This seems to be getting slower every day.

If I am already online and open a new Firefox window using the desktop launch icon then it is very quick - normal in fact.

I've read lots of posts about this and none of the fixes seem to work.

Ideas?

Thanks

Gaz

All Replies (2)

more options

What fixes have you tried already? This helps us not to repeat ourselves.

more options

Hi

After finding quite a few people on this Forum with the exact same problem, I saw what they had been advised to do and I tried the following. (By the way as far as I can tell none of them found a solution either!).

- I have upgraded to latest Firefox. I was on 21 and now 25.

- I have deleted Firefox from my AVG Firewall permissions list and then added it again.

- I have unchecked the hardware acceleration in Firefox Tools > Advanced > General.

- I have removed Firefox from my AVG PC Tuneup program, so it is never touched in the tune up tweaks.

- I tried to start in Firefox Safe mode, but it doesn't work - and for that matter never has! On my Start menu it is an option, but not on my Desktop icon. But even clicking "Firefox Safe Mode" just opens in normal mode. Holding doen "shift" makes no difference.

- All my plugins and extensions are up to date. They are the same ones that previously worked fine.

My symptoms are identical to many others I've seen on this forum. When I first turn my pc on and the go to Firefox it takes 1 to 2 minutes to get online and my Firefox default page to show. From then on browsing is perfectly normal speed. Also if I then click my desktop icon to open another Firefox window it opens straight away as it should.

If I log off and don't log on for a while, it again takes a minute to open the first screen.

It's as though my pc "forgets" what to do and the "remembers" once I've done it.

One thing that I also notice is that Firefox takes a lot of my pc resources and I get warnings from AVG that Firefox is using over 500 Mb of memory and it recommends I close and reopen to solve the issue. However this has been the same for a long time (couple of years) and the slow start up is recent - last month or so.

Any help appreciated.

Thanks

Gaz

Modified by gazzie