X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox Not Displaying Images Selected From Google Search Results!

Posted

I am a recent new Firefox user, since my IE8 on XP won't work with some sites. I am now on Firefox 25. Firefox has a couple of mixed content settings, and in fact, some change went in with 25 that was listed to be in 24, but wasn't (I have read).

Anyway, my IE8 and IE9 on Windows 8, I believe, have a warning that comes up in a box when I go to a web page with mixed content, so I can decide whether to allow display of the mixed content, and I make a judgement, based on whether I am on a bank or other secure site, etc.

This mixed content warning CHOICE seems to be missing from Firefox, and I am surprised!

Anyway, in Firefox 25, mixed active content is blocked, and when I do a google search on "2014 Nissan Rogue", some of the hits have little pictures called images. When I click on any of these images, a blank page comes up, with no way to allow the image to display. HELP!

Chosen solution

Looks like 25.0.01 that came out a few days ago, fixed the problem that did exist in 25 shipped a couple of weeks prior. Thanks!

Read this answer in context 0
Post a Reply

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.05
  • 5.1.20913.0
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Office Live Update v1.3
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.1483

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Hello,

Starting in Firefox 23, if a secure page includes certain types of insecure content, Firefox blocks the insecure content and a shield icon will appear in the address bar, as you have seen already. See this article for more information about the new mixed content blocker: How does content that isn't secure affect my safety?

To temporarily allow the mixed content to be displayed:

  • Click the shield icon Mixed Content Shield in the address bar and choose Disable Protection on This Page from the dropdown menu.

Fx23MixedContentBlocker


HOW TO DISABLE FOREVER

To allow insecure content to be displayed in all secure pages, enter about:config in the address bar and double-click on this preference, to toggle it from true to false:


security.mixed_content.block_active_content

You can also use this add-on instead, to toggle the preference:

You may want to do this only for the current session, then reset the preference back to "true" and check back with the site to see whether it's been fixed, since this is a global setting that exposes you on all sites, not just the one you care about.

Let us know if this helps!

Modified by Waka_Flocka_Flame

Was this helpful to you? 1
Reply

Question owner

There is no shield, but a little thing that says that the website does not supply identity information.

Get up a google, and type in 2014 nissan rogue, then click on one of the pics listed in a row as Images for 2014 Nissan Rogue. My Firefox shows a blank page on this search result images. MS IE always works fine.

Was this helpful to you?
Reply
jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

When I mouse over the images in that row, they are all to HTTP URLs, not HTTPS URLs. When I click them, they load in a separate page, so not mixed content. This is my search query URL:

https://www.google.com/search?q=2014+nissan+rogue

(Because this is a heavily customized profile, I'll have to try a clean profile in a little while as a double-check.)

Do you have both active and passive mixed content blocked?

Was this helpful to you?
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
Was this helpful to you?
Reply

Question owner

Thanks! I have the defaulted mixed active true, and passive false. I do have the option to tell the search engine not to collect my info, or whatever it is.

Most of the images that were giving problems seemed to have gone from google, but I type the search I indicated into the address bar, and this is the page that comes up: https://www.google.com/search?q=2014+nissan+rogue&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a&channel=fflb

Then when the blank page comes up, here is that page: http://www.google.com/imgres?imgurl=http://www.netcarshow.com/Nissan-Rogue-2014-wallpaper.jpg&imgrefurl=http://www.netcarshow.com/nissan/2014-rogue/&h=1920&w=2560&sz=538&tbnid=WHru2a__i4-T0M:&tbnh=92&tbnw=123&zoom=1&usg=__swgnoSzWt5chxYKR1jo56xHLYFk=&docid=Ckq1SJPkT-liDM&sa=X&ei=yoeEUtXDO4Tr2QXGkoGADw&ved=0CFcQ9QEwBQ

I paste the second url above into a FF tab, and I get a blank page. I paste into IE8, and this page comes up: http://www.netcarshow.com/nissan/2014-rogue/

Er, looks like google inserts a lot of stuff into the url that your mouse over does not see. On IE8, I get a little box that says something about the page and has just that picture on top of the web page, then I click the x in top right corner of the pic, and it goes away, and the full web page is left behind it. Although, now it just goes straight to the page, because it is now in cache, I suppose.

Modified by moz101mo

Was this helpful to you?
Reply

Question owner

Paste that second link into an address bar on FF, and it comes up blank, but on IE8, it works, as it always has. Weird google hocus pokus.

Modified by moz101mo

Was this helpful to you?
Reply
jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

Do you have any extensions that try to change or block tracking URLs? The Safe Mode test suggested by cor-el would be a quick way to determine whether extensions play any role in the issue.

Was this helpful to you?
Reply
cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Google passes such external links via their malware/phishing database and that is why the link is so complicated. so you also need to make sure not to block such a redirect.


Create a new profile as a (quick) test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.


Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Was this helpful to you?
Reply

Chosen Solution

Looks like 25.0.01 that came out a few days ago, fixed the problem that did exist in 25 shipped a couple of weeks prior. Thanks!

Was this helpful to you? 0
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.