X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

You are dishonest ! why do you spoil IDM through updating firefox?

Posted

It seems to me that you collaborate with other companies in order to save them from bankruptcy . I have had IDM for more than a year and I never wanted to update firefox or IDM since IDM always wanted me to do so just to destroy it BUT you asked me to update firefox - in a cunning way - not for firefox itself because your update is false : no new features , nothing to be compared with the old version of firefox - but only to dismantle the installation of my IDM !!! Do you get money for such a dirty job ? or Do you enjoy spoiling other people's time ? I do not know what to say because I have a hunch that you are either a hacking company or some kind of intelligence who spy on other people . I am sorry to tell you I lost confidence in your actions and your product so I am going to find another TRUE people. If you are angry at my message ,please do not bother to send a response unless you want to defend your position .

Chosen solution

Updates to Firefox do contain new features and fixes (security alone is a good reason to update Firefox, https://www.mozilla.org/security/known-vulnerabilities/firefox.html) and we release a new version of Firefox every 6 weeks, on the dot. IDM is a third-pary and has made their latest version of their program compatible with Firefox 25, you should update IDM. Read their own support site, http://www.internetdownloadmanager.com/register/new_faq/bi21.html for details. We don't break add-ons knowingly, and since add-ons are developed by independent third-parties it is their responsibility to keep add-ons updated and working in Firefox.

Read this answer in context 1
Post a Reply

Additional System Details

Installed Plug-ins

  • Google Update
  • npsitesafety
  • BonanzaDealsLive Update
  • Shockwave Flash 11.9 r900
  • Nokia Suite Enabler Plugin
  • Foxit Reader Plug-In For Firefox and Netscape
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • 4.0.50401.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20100101 Firefox/25.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8901 answers

Helpful Reply

hello, since you've made an unfounded statements about "some kind of intelligence who spy on other people": each update actually contains critical security fixes, so it's of paramount importance to stay up-to-date https://www.mozilla.org/security/known-vulnerabilities/firefox.html

there are documented cases where agencies have exploited vulnerabilities in out-dated firefox versions that have affected users who didn't update their browsers: https://lists.torproject.org/pipermail/tor-announce/2013-August/000089.html

Was this helpful to you? 2
Reply
Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Chosen Solution

Updates to Firefox do contain new features and fixes (security alone is a good reason to update Firefox, https://www.mozilla.org/security/known-vulnerabilities/firefox.html) and we release a new version of Firefox every 6 weeks, on the dot. IDM is a third-pary and has made their latest version of their program compatible with Firefox 25, you should update IDM. Read their own support site, http://www.internetdownloadmanager.com/register/new_faq/bi21.html for details. We don't break add-ons knowingly, and since add-ons are developed by independent third-parties it is their responsibility to keep add-ons updated and working in Firefox.

Was this helpful to you? 1
Reply

Question owner

First , I would like to apologize for "ill-belief" of mine. Secondly , I thank you for your support . it is really helpful and informative . Still my problem with IDM Thanks again

Was this helpful to you? 1
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.