X
Tap here to go to the mobile version of the site.

Support Forum

Mac 10.9 trackpad scroll not working

Posted

I am on firefox 25 and oxs 10.9, and all of a sudden for no reason, the 2 finger scrolling stopped working. its not the mac because scrolling works on everything else except for firefox. I don't really know what happened. I've already tried reseting firefox and the scrolling will work for a bit and then suddenly not work anymore. if i restart it, the scroll will work for a bout 5 minutes before disappearing.

I am on firefox 25 and oxs 10.9, and all of a sudden for no reason, the 2 finger scrolling stopped working. its not the mac because scrolling works on everything else except for firefox. I don't really know what happened. I've already tried reseting firefox and the scrolling will work for a bit and then suddenly not work anymore. if i restart it, the scroll will work for a bout 5 minutes before disappearing.

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Provides information about the default web browser
  • Version 4.8.2.15856
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Shockwave Flash 11.8 r800
  • DivX VOD Helper Plug-in
  • DivX Web Player version 3.0.0.155
  • Unity Web Player version 4.2.0f4. (c) 2013 Unity Technologies ApS. All rights reserved.
  • Plugin for Wacom tablets.
  • Picasa plugin.
  • 5.1.20125.0
  • Microsoft Office for Mac SharePoint Browser Plug-in

Application

  • Firefox 25.0
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:25.0) Gecko/20100101 Firefox/25.0
  • Support URL: https://support.mozilla.org/1/firefox/25.0/Darwin/en-US/

Extensions

  • Stylish 1.3.3 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • XKit 7.2.1 (xkit@studioxenix.com)
  • Adobe Acrobat - Create PDF 1.1 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Adobe Contribute Toolbar 6.0 ({01A8CA0A-4C96-465b-A49B-65C46FAD54F9}) (Inactive)
  • DivX Plus Web Player HTML5 <video> 2.1.2.145 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x6741
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 6750M OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.restore_on_demand: False
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131025151332
  • browser.startup.homepage_override.buildID: 20131025151332
  • browser.startup.homepage_override.mstone: 25.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 25.0
  • general.autoScroll: False
  • gfx.blacklist.direct2d: 3
  • gfx.blacklist.layers.direct3d9: 3
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.flip4mac wmv plugin: 0
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
ideato 893 solutions 6250 answers

Hello blinkingkills, see if the next is helpful : https://support.mozilla.org/en-US/forums/contributors/709697?last=54950#post-54832

thank you

Hello blinkingkills, see if the next is helpful : https://support.mozilla.org/en-US/forums/contributors/709697?last=54950#post-54832 thank you
David S. 3 solutions 32 answers

Helpful Reply

I started getting this problem shortly after upgrading to Firefox 26.0, didn't have the issue with 25.x. Mac OS X 10.9. iMac with Magic Trackpad.

Two-finger scrolling works fine for a few minutes after launching Firefox, then it stops working. Shutdown and restart of Firefox fixes it until it happens again. No problems with any other apps, e.g. Thunderbird 24.x, Safari 7, etc.

I started getting this problem shortly after upgrading to Firefox 26.0, didn't have the issue with 25.x. Mac OS X 10.9. iMac with Magic Trackpad. Two-finger scrolling works fine for a few minutes after launching Firefox, then it stops working. Shutdown and restart of Firefox fixes it until it happens again. No problems with any other apps, e.g. Thunderbird 24.x, Safari 7, etc.
David S. 3 solutions 32 answers

I'm dubious about the above bug being related as this only started happening with Firefox 26.0 and I've never seen it happen in any other app.

Possibly I've simply not used Safari often/long enough since upgrading to Mavericks to trigger it, but I'm switching to Safari full time now as this problem with Firefox is making it unusable, so we'll see. I do have two-finger swipe between pages set on, I'll see if switching that off helps also.

I'm dubious about the above bug being related as this only started happening with Firefox 26.0 and I've ''never'' seen it happen in ''any'' other app. Possibly I've simply not used Safari often/long enough since upgrading to Mavericks to trigger it, but I'm switching to Safari full time now as this problem with Firefox is making it unusable, so we'll see. I do have two-finger swipe between pages set on, I'll see if switching that off helps also.
David S. 3 solutions 32 answers

Well since I first encountered this problem a couple of days ago I've been trying to reproduce the failure with no success. Scrolling is working again with no problems and nothing I've tried makes it fail again!

Nothing has changed in my System Preferences since I had the problem (I didn't get around to switching off two-finger swipe between pages), the only thing was I shutdown and rebooted my iMac overnight after the initial problem occurred, since then it's all worked fine again. Sigh. If it returns I'll do some more investigation.

Well since I first encountered this problem a couple of days ago I've been trying to reproduce the failure with no success. Scrolling is working again with no problems and nothing I've tried makes it fail again! Nothing has changed in my System Preferences since I had the problem (I didn't get around to switching off two-finger swipe between pages), the only thing was I shutdown and rebooted my iMac overnight after the initial problem occurred, since then it's all worked fine again. Sigh. If it returns I'll do some more investigation.

Modified by David S.

timbo3416 0 solutions 1 answers

I was dubious as to this being the problem as I have had it on and off through 3 versions of OS X but the change found at the link in this thread about checking Show Scroll Bar always fixed my issue so be certain to try it.

I was dubious as to this being the problem as I have had it on and off through 3 versions of OS X but the change found at the link in this thread about checking Show Scroll Bar always fixed my issue so be certain to try it.
kolen 0 solutions 1 answers

Some details: scroll stopped working in all Firefox windows and widgets, including tab bar, "Cookies" window, etc., not only on webpages.

Some details: scroll stopped working in all Firefox windows and widgets, including tab bar, "Cookies" window, etc., not only on webpages.
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers

On Mac the scroll bars can be hidden and only have them show when you scroll the page so you can see the current scroll position.
The idea is that a touch pad is used that doesn't require the scroll bars to be visible and thus have more screen estate for the browsing area.

You can make the scroll bars always visible:

System Preferences > General > Show Scroll Bar > Choose "Always"
On Mac the scroll bars can be hidden and only have them show when you scroll the page so you can see the current scroll position.<br /> The idea is that a touch pad is used that doesn't require the scroll bars to be visible and thus have more screen estate for the browsing area. You can make the scroll bars always visible: System Preferences > General > Show Scroll Bar > Choose "Always" *https://heresthethingblog.com/2013/02/25/mac-tip-missing-scroll-bars/
dhjdhjdhj 0 solutions 8 answers

I'm having EXACTLY the same problem --- just started --- it only happens in Firefox --- note that this has NOTHING to do with scroll bars being hidden, etc.

The problem only occurs in Firefox.

If I quit and restart, Firefox responds to 2 finger scrolling for a little while and then stops.

I'm having EXACTLY the same problem --- just started --- it only happens in Firefox --- note that this has NOTHING to do with scroll bars being hidden, etc. The problem only occurs in Firefox. If I quit and restart, Firefox responds to 2 finger scrolling for a little while and then stops.
dhjdhjdhj 0 solutions 8 answers

By the way, just for curiosity, I reinstalled Firefox 25 and the problem has gone away --- 2 finger scrolling now works just fine.

By the way, just for curiosity, I reinstalled Firefox 25 and the problem has gone away --- 2 finger scrolling now works just fine.
perryb 0 solutions 4 answers

Same here, FF26, OSX 10.9.1 - no two finger scroll or swipe back or forward a page.

Weird that it only just started happening out of the blue. I've had Mavericks for several weeks (though I'm not sure when FF updated though).

Same here, FF26, OSX 10.9.1 - no two finger scroll or swipe back or forward a page. Weird that it only just started happening out of the blue. I've had Mavericks for several weeks (though I'm not sure when FF updated though).
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers

You can restore some zoom feature by modifying the values of the related prefs on the about:config page via the right-click context menu.

  • browser.gesture.pinch.in -> cmd_fullZoomReduce
  • browser.gesture.pinch.in.shift -> cmd_fullZoomReset
  • browser.gesture.pinch.out -> cmd_fullZoomEnlarge
  • browser.gesture.pinch.out.shift -> cmd_fullZoomReset
  • browser.gesture.pinch.latched -> false
  • You can open the about:config page via the location bar

You can use this extension if you do not want to change the related browser.gesture.* prefs on the about:config page

You can restore some zoom feature by modifying the values of the related prefs on the <b>about:config</b> page via the right-click context menu. * browser.gesture.pinch.in -> <b>cmd_fullZoomReduce</b> * browser.gesture.pinch.in.shift -> <b>cmd_fullZoomReset</b> * browser.gesture.pinch.out -> <b>cmd_fullZoomEnlarge</b> * browser.gesture.pinch.out.shift -> <b>cmd_fullZoomReset</b> * browser.gesture.pinch.latched -> <b>false</b> *You can open the <b>about:config</b> page via the location bar ---- You can use this extension if you do not want to change the related browser.gesture.* prefs on the about:config page *pinchy: https://addons.mozilla.org/firefox/addon/pinchy/
dhjdhjdhj 0 solutions 8 answers

That's as may be but it doesn't help the vast non-tech user base who want understand how this broke (I don't understand it either)

That's as may be but it doesn't help the vast non-tech user base who want understand how this broke (I don't understand it either)
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers

Did you try the pinchy extension?

Did you try the pinchy extension? * https://addons.mozilla.org/firefox/addon/pinchy/
perryb 0 solutions 4 answers

Helpful Reply

I have to agree - I don't mind messing about with Firefox settings personally just as long as this is acknowledged as a bug that needs fixing.

Otherwise this sort of tinkering is outside regular users' abilities.

Tweak or no tweak FF is more or less unusable to me right now - please don't make me defect to Chrome! :)

I have to agree - I don't mind messing about with Firefox settings personally just as long as this is acknowledged as a bug that needs fixing. Otherwise this sort of tinkering is outside regular users' abilities. Tweak or no tweak FF is more or less unusable to me right now - please don't make me defect to Chrome! :)