X
Tap here to go to the mobile version of the site.

Support Forum

Suddenly, *only with Firefox* all computers in the house show (Error code: ssl_error_rx_record_too_long) when trying to access any Google product.

Posted

Today, all laptops in the house (latest ver of FF) began throwing the error:

(Error code: ssl_error_rx_record_too_long)

When trying to access any Google products: gmail, Google+, analytics, Google website, etc

Today, all laptops in the house (latest ver of FF) began throwing the error: (Error code: ssl_error_rx_record_too_long) When trying to access any Google products: gmail, Google+, analytics, Google website, etc

Chosen solution

Make sure to reset the security.tls.version.max pref to 1 if you have previously changed this pref to 0 to disable TLS 1.0

Read this answer in context 6

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/30.0.1599.101 Safari/537.36

More Information

philipp
  • Top 25 Contributor
  • Moderator
5152 solutions 22821 answers

hello, could you go to firefox > help > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on...

hello, could you go to ''firefox > help > troubleshooting information'', copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on...

Question owner

Application Basics


Name: Firefox Version: 25.0 User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0

Extensions


Name: Evernote Web Clipper Version: 5.9.0 Enabled: true ID: {E0B8C461-F8FB-49b4-8373-FE32E9252800}

Name: WiseStamp Version: 3.13.31 Enabled: true ID: wisestamp@wisestamp.com

Name: Xmarks Version: 4.2.1 Enabled: true ID: foxmarks@kei.com

Name: Adobe Acrobat - Create PDF Version: 2.0 Enabled: false ID: web2pdfextension@web2pdf.adobedotcom

Name: Skype Click to Call Version: 6.13.0.13771 Enabled: false ID: {82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}

Important Modified Preferences


accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.disk.smart_size_cached_value: 358400 browser.places.smartBookmarksVersion: 4 browser.sessionstore.upgradeBackup.latestBuildID: 20131025151332 browser.startup.homepage_override.buildID: 20131025151332 browser.startup.homepage_override.mstone: 25.0 dom.mozApps.used: true extensions.lastAppVersion: 25.0 font.internaluseonly.changed: false gfx.direct3d.last_used_feature_level_idx: 0 network.cookie.prefsMigrated: true places.database.lastMaintenance: 1383677511 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1381347811

Graphics


Adapter Description: Intel(R) HD Graphics 3000 Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32 Adapter RAM: Unknown Device ID: 0x0126 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.16492) Driver Date: 12-12-2012 Driver Version: 9.17.10.2932 GPU #2 Active: false GPU Accelerated Windows: 1/1 Direct3D 10 Vendor ID: 0x8086 WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: false AzureCanvasBackend: direct2d AzureContentBackend: direct2d AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0

JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.10.1 Version in use: 4.10.1

NSS Expected minimum version: 3.15.2 Basic ECC Version in use: 3.15.2 Basic ECC

NSSSMIME Expected minimum version: 3.15.2 Basic ECC Version in use: 3.15.2 Basic ECC

NSSSSL Expected minimum version: 3.15.2 Basic ECC Version in use: 3.15.2 Basic ECC

NSSUTIL Expected minimum version: 3.15.2 Version in use: 3.15.2

Application Basics ------------------ Name: Firefox Version: 25.0 User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 Extensions ---------- Name: Evernote Web Clipper Version: 5.9.0 Enabled: true ID: {E0B8C461-F8FB-49b4-8373-FE32E9252800} Name: WiseStamp Version: 3.13.31 Enabled: true ID: wisestamp@wisestamp.com Name: Xmarks Version: 4.2.1 Enabled: true ID: foxmarks@kei.com Name: Adobe Acrobat - Create PDF Version: 2.0 Enabled: false ID: web2pdfextension@web2pdf.adobedotcom Name: Skype Click to Call Version: 6.13.0.13771 Enabled: false ID: {82AF8DCA-6DE9-405D-BD5E-43525BDAD38A} Important Modified Preferences ------------------------------ accessibility.typeaheadfind.flashBar: 0 browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.cache.disk.smart_size_cached_value: 358400 browser.places.smartBookmarksVersion: 4 browser.sessionstore.upgradeBackup.latestBuildID: 20131025151332 browser.startup.homepage_override.buildID: 20131025151332 browser.startup.homepage_override.mstone: 25.0 dom.mozApps.used: true extensions.lastAppVersion: 25.0 font.internaluseonly.changed: false gfx.direct3d.last_used_feature_level_idx: 0 network.cookie.prefsMigrated: true places.database.lastMaintenance: 1383677511 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1381347811 Graphics -------- Adapter Description: Intel(R) HD Graphics 3000 Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32 Adapter RAM: Unknown Device ID: 0x0126 Direct2D Enabled: true DirectWrite Enabled: true (6.2.9200.16492) Driver Date: 12-12-2012 Driver Version: 9.17.10.2932 GPU #2 Active: false GPU Accelerated Windows: 1/1 Direct3D 10 Vendor ID: 0x8086 WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0) windowLayerManagerRemote: false AzureCanvasBackend: direct2d AzureContentBackend: direct2d AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0 JavaScript ---------- Incremental GC: true Accessibility ------------- Activated: false Prevent Accessibility: 0 Library Versions ---------------- NSPR Expected minimum version: 4.10.1 Version in use: 4.10.1 NSS Expected minimum version: 3.15.2 Basic ECC Version in use: 3.15.2 Basic ECC NSSSMIME Expected minimum version: 3.15.2 Basic ECC Version in use: 3.15.2 Basic ECC NSSSSL Expected minimum version: 3.15.2 Basic ECC Version in use: 3.15.2 Basic ECC NSSUTIL Expected minimum version: 3.15.2 Version in use: 3.15.2
philipp
  • Top 25 Contributor
  • Moderator
5152 solutions 22821 answers

thanks, can you check if the issue is also present when firefox is set up to directly connect to the internet ('no proxy') in firefox > options > advanced > network > connection - settings...

Firefox can't load websites but other browsers can

thanks, can you check if the issue is also present when firefox is set up to directly connect to the internet ('no proxy') in ''firefox > options > advanced > network > connection - settings...'' [[Firefox can't load websites but other browsers can]]
kobe 441 solutions 5048 answers

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.

Question owner

I changed it to 'No Proxy' but the problem persists...

I changed it to 'No Proxy' but the problem persists...
philipp
  • Top 25 Contributor
  • Moderator
5152 solutions 22821 answers

which kind of security software is running on your computers?

which kind of security software is running on your computers?

Question owner

It's happening on all laptops in the house, so likely not an add-on issue

It's happening on all laptops in the house, so likely not an add-on issue

Question owner

Malwarebytes

Malwarebytes
Sarke 0 solutions 2 answers

This happens to me too, on all HTTPS sites. I have not changed anything, and it just started today. Sites work in Chrome, but not Firefox.

This happens to me too, on all HTTPS sites. I have not changed anything, and it just started today. Sites work in Chrome, but not Firefox.
philipp
  • Top 25 Contributor
  • Moderator
5152 solutions 22821 answers

ok & what ISP are you using?
(sorry about all this questions, but this seems to be a very recent issue and maybe it's possible to find correlations between affected users)

ok & what ISP are you using? <br>(sorry about all this questions, but this seems to be a very recent issue and maybe it's possible to find correlations between affected users)

Question owner

@phillip Absolutely, happy to troubleshoot with you! I am using Shaw. I've also now realized that if I tether to my iPhone (Bell Mobility), those sites load with no problem.

@Sarke Can you try that too?

@phillip Absolutely, happy to troubleshoot with you! I am using Shaw. I've also now realized that if I tether to my iPhone (Bell Mobility), those sites load with no problem. @Sarke Can you try that too?
Sarke 0 solutions 2 answers

Shaw. I'm in Maple Ridge, BC.

Shaw. I'm in Maple Ridge, BC.

Question owner

@philipp I am thinking it's either a router issue, or an ISP issue (as maybe you were thinking as well?)

@philipp I am thinking it's either a router issue, or an ISP issue (as maybe you were thinking as well?)

Helpful Reply

Aha! I'm in South Surrey, BC. I've got a call into a Shaw tech.

Aha! I'm in South Surrey, BC. I've got a call into a Shaw tech.
cor-el
  • Top 10 Contributor
  • Moderator
16724 solutions 151203 answers

You can also check for issues caused by the router try to reset (power off/on) the router.

See also:

You can also check for issues caused by the router try to reset (power off/on) the router. See also: *http://kb.mozillazine.org/Error_loading_websites
philipp
  • Top 25 Contributor
  • Moderator
5152 solutions 22821 answers

most error reports by users, that are coming in via firefox > help > submit feedback also seem to mention google.ca - so this would also indicate that this issue is mostly affecting Canadian users at the moment... https://input.mozilla.org/en-US/?q=ssl_error_rx_record_too_long&date_end=2013-11-06&date_start=2013-11-02

most error reports by users, that are coming in via ''firefox > help > submit feedback'' also seem to mention google.ca - so this would also indicate that this issue is mostly affecting Canadian users at the moment... https://input.mozilla.org/en-US/?q=ssl_error_rx_record_too_long&date_end=2013-11-06&date_start=2013-11-02
Fireboy2009 0 solutions 1 answers

Haha I'm in Surrey, BC as well with Shaw. Its starting to look like Shaw messed something up on their end

Haha I'm in Surrey, BC as well with Shaw. Its starting to look like Shaw messed something up on their end
Noah_SUMO
  • Moderator
97 solutions 581 answers

Well who ever calls Shaw tech support and manages to get a answer about this, please keep us updated in this thread about what they say the problem is and when they plan to fix it. Thanks.

Well who ever calls Shaw tech support and manages to get a answer about this, please keep us updated in this thread about what they say the problem is and when they plan to fix it. Thanks.
Odat 0 solutions 1 answers

Having the same issue and also use Shaw. Some of the machines are Linux running Firefox 19 and they suddenly started sporting the same issue at the same time.

Rebooting the router and modem had no effect.

Having the same issue and also use Shaw. Some of the machines are Linux running Firefox 19 and they suddenly started sporting the same issue at the same time. Rebooting the router and modem had no effect.

Helpful Reply

I just spoke to Shaw and they are getting calls with similar issues, so they're looking into it.

Is anyone ending up here (ie with the same behaviours) who is *not* on Shaw?

I just spoke to Shaw and they are getting calls with similar issues, so they're looking into it. Is anyone ending up here (ie with the same behaviours) who is *not* on Shaw?