Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I unbrick ZTE Open with adb debug disabled?

  • 62 replies
  • 36 have this problem
  • Last reply by nhirata

more options

I have a ZTE Open for Telefonica Movistar Mexico.

On my ZTE Open, adb debug is _disabled_ I was trying to update it via "More Info" menu, but it never worked. So I tried to update it via SD Update using the ztems rom [0]

It just bricked my phone and now, every time I try to update it via SD card using any ZTE Open rom (I tried with several roms), including the Movistar Mexico's one [1] I'm getting errors like this:

E:failed to verify whole-file signature E:signature verification failed Installation aborted.

No matter if I delete the first three lines of /META-INF/com/google/android/updater-script, I'm getting the same kind of errors.

Please, any ideas about this?

[0] [1]

All Replies (20)

more options

I don't know how to modify my initial question. I have a ZTE Open from Telefonica Movistar Mexico.

more options

Have you tried the wipe data/ factory reset? If an update is not available over the air for download then this shouldn't have been performed. SD Card packages for to fix bricked phones, not to update them.

more options

I tried both wipe and factory reset. Did not work.

My ZTE Open was on 1.0.1-pre or 1.1-pre, when there is an 1.1 and that SD was ZTE's "official", so why don't try them?

Also, the more info -> update was giving me "Error on check updates". I think there is some kind of bug in the Movistar Mexico's version. Since I'm on the launching team I was trying to identify that bug and solve it.

...And I forgot to enable usb adb debugging :(

more options

The "Error on check updates" is normal. That should've been ignored - it just means that no update is available for you at this moment because it isn't available for the Mexico version yet. I am going to email Michelle, the Firefox OS Support manager to see if she can help you out.

Thank you for your patience.

more options

That should not be normal since Error while checking updates doesn't mean there are no updates for you at this time. Do you know if there's a bug report about this?

Since I'm not at home and I have only an Alcatel (which actually says Your system is up-to-date or something like that) I'm not able to file a bug about this right now. I think both we and ZTE and Telefonica need to be working on this

Thank you for email Michelle, I'll be waiting! :D

Modified by Mauricio Navarro Miranda

more options

[EDITADO] Disculpa Mautemático, soy bastante novato con los foros.

A mí, a efectos, me pasaba lo mismo que a ti. El recovery de fábrica no me permitía instalar ningún tipo de paquete por ir sin firmar. Después de muchas vueltas y de intentar mil cosas, fui a la tienda donde lo había comprado y me lo cambiaron.

Después de eso he instalado mediante el CWM la versión que activa fastboot (oficial de ZTE) mediante un tutorial que encontré aquí:

Mucha suerte con tu problema, espero que encuentres pronto solución :)

Modified by fiti123

more options

@fiti123: Me alegra que te ofrecieran solución a tu problema.

Ya tengo pensado como último recurso ir a alguna tienda y pedir que lo cambien, pero realmente preferiría encontrar otra solución porque estoy seguro que muchos más sufrirán un problema similar. Así al menos podría documentar los pasos para solucionar, que a más de uno han de servir.

Todo esto me hace pensar: Creo que ZTE (quizás Telefónica) ya debería estar recibiendo un reclamo de parte nuestra.

¡Un abrazo!

Modified by Mauricio Navarro Miranda

more options


As you can see on [0], my ZTE Open's recovery says "Android" instead of "Firefox OS". May it be causing the problem? Maybe my ZTE Open's recovery/boot partitions are the Android ones and not the Firefox OS ones, or something like that.

Anyway, I'm still unable to get adb or even fastboot working.


more options

@feer56 The mentioned update problem exists officialy.

Here at "Device revisions" says: "Phones produced before 09/27/2013 do not have fastboot enabled and must be updated. Normally, this would be handled by Software Updates, but since some users have reported trouble with this method, ZTE have made SD card packages available to enable fastboot on earlier devices. Flash images for:

   Phones purchased at ZTE eBay US/Hong Kong store 
   Phones purchased at ZTE eBay UK store 

The zip file is linked under Downloads. Once the file is downloaded and unzipped, follow the instructions in the bundled PDF to flash the package to your phone."

@Mautematico I first used the link for "Phones purchased at ZTE eBay UK store" above and succesfuly upgraded to V1.0.0B02, but the "download updates failed" remained, but I think I had to do it, in order to continue with ADB and 1.1 and better update results. Then I installed ClockWorkRecovery to flash 1.1 from Movistar and all went good after some modifications, but the "download updates failed" remained, I don't know if it was for similar updatets (apps, etc.). Also 1.1 insalled the StockRecovery that I didn 't want, I needed Skype, was risky and stupid and when I found the link text you also linked, thought as a good idea to flash Android to my ZTEOpen... That 's why the "android system recovery 3e" appears. !!!ATTENTION!!! for EVERYONE! If I 'm not wrong this will BRICK(recoverable I hope and try) your phone! I don 't know why ZTE published this description and what are these .zips for, we sould be carefull. Now ADB and fastboot cannot access the phone, so I cannot install ClockWorkRecovery again... yet! If I have anything helpfull, I 'll post here, please do the same, good luck.

more options

Do we have any news on this?

@feer56 , did you have success contacting Michelle?

more options

Mautematico: I apologize for the delay but no, I have no heard anything back. I have however escalated this thread and at the same time will contact somebody else but Michelle may pop in at any time and respond.

Thanks! Sorry for any inconvenience and thank you for your patience.

more options

Hey All,

I just asked about this and it look like this worked for another, thank you bobnormal!

  • Load an sdcard with firmware from ZTE's website then using the boot-time recovery menu (power+volup) to install it.

firmware @

Try that out, more to come.

Modified by guigs

more options
  • Please note that the link above is not for the version that you had.
more options

@Mautematico the option for Android and Firefox is expected, however the bricked phone due to updating to another build still needs to be addressed.

more options

so, i did the same mistake, flashed prerelease Firefox OS with Android recovery to my ZTE Open, now I'am not able to flash Firefox's builds due to "Signature verification failed"

more options

@ AkiNO

I believe you have to reformat the SIM card with a new build, as mentioned in another question. Try this: []

more options

SD card formatting doesn't help. we need signed firmware which will be accepted by Android recovery

more options

however, adb shell flash_image /sdcard/cwm.img works in that situation

more options

I'm stuck - nothing seems to work any more. I tried this: (Fedora 20 host) but neither fastboot nor adb sees the device! I'm going to make an attempt using a Windows host but that's the last option I have left. :-(

And yes, the udev stuff is OK:

   # more /etc/udev/rules.d/50-android.rules 
   SUBSYSTEM=="usb", ATTR{idVendor}=="19d2", MODE="0666", GROUP="plugdev" # ZTE Open
   SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", MODE="0666", GROUP="plugdev" # Google device 

But nothing in the device is talking to the USB:

   # lsusb
   Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 005 Device 002: ID 0bda:8150 Realtek Semiconductor Corp. RTL8150 Fast Ethernet Adapter
   Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
   Bus 004 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver
   Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
   Bus 009 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
   Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Modified by M. Edward (Ed) Borasky

more options


Just a quick question, is the device's developer menu is debugging mode on? as well as USB enabled?

  1. 1
  2. 2
  3. 3
  4. 4