Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

can't install ZTE supplied 'update' after flashing compiled B2G

  • 24 replies
  • 26 have this problem
  • Last reply by erotavlas

more options

My device is running version that was compiled from source (by someone else). Now ZTE has finally released a version 1.1 'update' that I would like to install. However, when I attempt to install the update I receive a signature verification failure error message. How do I install the update provided by ZTE?

All Replies (20)

more options

Hi jezra,

Thank you for your question, to better assist you:

  • Does the phone have a provider? If so, the update may not be available for that carrier.
  • What build is on the phone, and is this the ZTE Open that was purchased before or after 9/27/13 ?
  • Would you mind providing a screenshot of this error: "signature verification failure error message"
  • What steps are you taking to flash the phone?

[Manual update attempt results in download error - zte open firmware V1.]

Added: If it is a developer phone there should be a push this week, however I am suspicious since 1.3pre version that is on there now was flashed on, 1.1 may need to be flashbooted onto it. For clearer instructions on how to do this I would ask [] or [] - ZTE Open Orange phone is the Inari.

Modified by guigs

more options

The device is a rev1 ZTE Open purchased on Ebay, and the fastboot update has been enabled.

The current OS is and the build identifier is 20131007083940

To flash the phone: 1. I have downloaded the latest zip file from 2. I unzipped the file 3. after unzipping, I moved the included zip file to the top level of my device's SD card 4. I reboot the device and hold down the power button and the volume up button 5. from the menu that appears, I select "apply update from external storage" 6. I then select the update zip file and press the power button

I will try to find a digital camera to get a screen shot

more options

I managed to get the device to install the update after removing and formatting the SD card and then copying the update file back to the SD card.

more options

Hi jezra,

I asked about the verification error earlier today and this error happens when a file is missing or a check is not complete for a build, so they recommended to do a fresh install after a hard reset. Glad to hear that this worked after reformatting the SD card.

Modified by guigs

more options

Unfortunately, after the "update" I am no longer able to use fastboot to install compiled images. I can still use `adb reboot bootloader` to get into fastboot mode, but when I try to write to the device, the device restarts and exits fastboot mode, and this causes the write to fail.

more options

Same problem for me. The update to 1.1 works but after that i'm not longer able to flash my phone.

./ ... writing 'userdata'... FAILED (status read failed (No such device))

I read stuff speaking about that the device is not reboot in the right mode but i can't find a solution for that.

more options

I've tried to install the previous v1.0 'update' in the hopes that the ability to use fastboot would be restored. Unfortunately the update behaves like a ZTE update and won't install due to a signature verification.

more options

Jezra, what do the lines say above the "Signature Verification Error" there should be a file there?

This will help what is causing this verification issue.

more options

The output is:

--Install /sdcard ...

Finding update package...

Opening update package...

Verifying update package...

E: failed to verify whole-file signature

E: signature verification failed

Installation aborted

more options

For more details on the update error there are instructions on this bug from a previous error:

If adb log is recoverable with remote debugging on in the nightly version you are running on it ( is this still true?) This may give more error detail.

more options

I am not running a nightly. My device is running the official v1.1 from ZTE and the ability to use fastboot to install a compiled nightly is now broken.

I am trying to install the official v1.0 from ZTE onto a device running the official v1.1 from ZTE

more options

The reason I am trying to downgrade now, is so that I restore the ability to use fastboot on my device.

more options

Hi jezra, when you are attempting to fastboot, can you confirm that debugging is on in the Developer menu in settings?

more options

I can confirm that 'remote debugging' is not on in the developer menu.

Why would this affect writing images to the device when the device is in fastboot mode?

more options

jezra, there is another forum thread that is talking about this as well leading me to believe that flashing an image from the sd card is possible, remote debugging must be on to do use the flash method.

However this device has an official v1.1 from ZTE, which is not ultimately supported, and I would recommend bringing this up to ZTE as well.

Fastboot is used for the open phone sold on ebay and the builds

Flash images(as you are fastbooting):

This page also recommends to factory reset, but it is said it is not working, therefore you will need to contact the Ebay store.

"send your phone back to the eBay store you purchased it from in exchange for a new one. You may contact the store owner directly via an eBay message."

I hope after a factory reset the previous version will be there, since that was the original image?

more options

I am hesitant to do a factory reset because my device is one of the "early adopter punishers" that didn't have fastboot enabled. ZTE has already been contacted regarding my issues, as has the Ebay seller of the device.

Is there any "supported" version of FirefoxOS for the ZTE 'open'? If so, where can I download and install that version?

more options

I am also having a similar problem. I do not know who is to blame but after reading many comments on the internet and trying many things to solve the problem I think this whole business is a total mess.

My eBay ZTE Open has the last available update from ZTE:

I cannot flash a built version from sources because the version I have (Revision 01) does not have fastboot enabled. According to Mozilla's developer guides I can download an update from ZTE to enable fastboot, but the file does not exists. I could find it in a backup of my computer, but it is useless. I cannot update back to version 1.0. ('failed to verify' error, already mentioned by others).

This is a dead-end. I do not know whether the solution should come from Mozilla or ZTE, but we need a solution. As an early adopter I am willing to make an extra effort, but I am reaching the limit.

more options

I just want to add that I have contacted ZTE about this problem and I am waiting for an answer.

I will let you know their answer.

more options

Yeah - I have pretty much the same problems. The phone seems to be working fine with the ZTE 1.1 build but I want to flash it to 1.3 built from B2G source and I can't do that.

I'll watch this thread.

more options

There is nothing like being punished for being an early adopter.

In order to use fastboot, you may need to enable USB debugging in Settings > Device Information > More Information > Developer .

Why it would be necessary to change a setting in the OS in order for the bootloader to work properly is beyond me. It makes little sense, so I'll call it typical of Firefox OS and ZTE.

  1. 1
  2. 2