Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do you know if you have all the requirements in order to download Firefox?

more options

I've been trying to update my Firefox (version 3.6.17) so I can still go on YouTube and to just update it. I've already tried to reinstall it, but its the same version. I would like to know if there's a command for terminal to show if I have all the requirements needed in order to download the latest version of Firefox.

All Replies (1)

more options

http://www.mozilla.org/en-US/firefox/25.0/system-requirements/

Linux Software Requirements Please note that Linux distributors may provide packages for your distribution which have different requirements.

   Firefox 25 will not run at all without the following libraries or packages:
       GTK+ 2.18 or higher
       GLib 2.22 or higher
       Pango 1.14 or higher
       X.Org 1.0 or higher (1.7 or higher is recommended)
       libstdc++ 4.3 or higher
   For optimal functionality, we recommend the following libraries or packages:
       NetworkManager 0.7 or higher
       DBus 1.0 or higher
       HAL 0.5.8 or higher
       GNOME 2.16 or higher