X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Why does mozilla say: Firefox 3.6.28 and Firefox 12 are the last versions of Firefox that will work with the original version of Windows XP and Windows XP Servi

Posted

Mozilla says: Firefox 3.6.28 and Firefox 12 are the last versions of Firefox that will work with the original version of Windows XP and Windows XP Service Pack 1.

Is Firefox saying that firefox 9 and earlier will not work?

I tried firefox 9 and it works well. Why did firefox lie? It says they are the last versions that will work. What does last versions of Firefox will work mean? Last versions!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.11.847
  • Adobe Acrobat Plug-In Version 6.00 for Netscape
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Npdsplay dll

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Helpful Reply

I'm not sure I understand your question. Firefox 12 being the last version to support XP without SP2 implies that Firefox versions 4-11 would also work on XP without SP2.

You may have seen a reference to Firefox 3.6.28 because for a while Firefox 3.6 received some updates in parallel with the releases of Firefox 4-10, and 3.6.28 was the end of the line.

If there is an article that needs updating on this site -- and I can assure you there are many -- you may be able to submit proposed edits to it because many pages are "wiki" pages with an Edit link. Or if you want to post the URL of the problem page here, feel free to do that instead.

jscher2000
  • Top 10 Contributor
2375 solutions 21032 answers

Helpful Reply

Why would you not install Service Pack 2 for Windows XP? It strengthened the security of the OS considerably. Does it break a program that is essential to you??

Question owner

Mozilla says: Firefox 3.6.28 and Firefox 12 are the last versions of Firefox that will work with the original version of Windows XP and Windows XP Service Pack 1.

Is Firefox saying that firefox 9 and earlier will not work?

Why did firefox say Firefox 3.6.28 and Firefox 12 are the last versions? What are the facts?

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

The last version means that version released after Firefox 12 i.e Firefox 13 and later, including the current Firefox 24 release won't work. All older Firefox versions will still work on Windows XP SP1.

James
  • Top 25 Contributor
  • Moderator
437 solutions 3163 answers

Seems like you are still a bit unsure. https://support.mozilla.org/en-US/questions/987930

Not sure where you saw the Mozilla says: Firefox 3.6.28 and Firefox 12 are the last versions of Firefox that will work with the original version of Windows XP and Windows XP Service Pack 1.

Basically this means ALL Firefox releases between 3.6 and 12.0 will run on WinXP SP1. ALL being 3.6.x, 4.0, 5.0, 6.0, 7.0, 8.0, 9.0, 10.0, 11.0 and 12.0 as it did not mean only Firefox 3.6.x and 12.0 will work as "To" should have been in place of the "and".

Actually the many old Releases of this browser before Firefox 3.6 is also included in working on WinXP and SP1.

Firefox 13.0 (thirteen) requires at minimum Windows XP SP2 or newer (including WInXP SP3, Vista, Win 7, Win 8.0, Win 8.1) as the WinXP SP1 and Windows 2000 does not have what is required to run Firefox 13.0 and newer including the current 27.0.1.

If you install Windows XP3 or even XP2 at least then you will be able to use current Release which is Firefox 27.0.1 and will likely to be able to use new Firefox Release for a while still.

Modified by James

Question owner

About this firefox link: https://support.mozilla.org/en-US/kb/firefox-no-longer-works-some-versions-windows-xp?esab=a&s=no+longer+supported&r=3&as=s

I said:Mozilla says: Firefox 3.6.28 and Firefox 12 are the last versions of Firefox that will work with the original version of Windows XP and Windows XP Service Pack 1.

Is Firefox saying that firefox 9 and earlier will not work?

You said:ALL being 3.6.x, 4.0, 5.0, 6.0, 7.0, 8.0, 9.0, 10.0, 11.0 and 12.0 as it did not mean only Firefox 3.6.x and 12.0 will work as "To" should have been in place of the "and".

Prove to me why firefox made a mistake and said and and not to. Does the boss know or the technicians if that really was a mistake?



Seems like you are still a bit unsure. https://support.mozilla.org/en-US/questions/987930

Not sure where you saw the Mozilla says: Firefox 3.6.28 and Firefox 12 are the last versions of Firefox that will work with the original version of Windows XP and Windows XP Service Pack 1.

Basically this means ALL Firefox releases between 3.6 and 12.0 will run on WinXP SP1. ALL being 3.6.x, 4.0, 5.0, 6.0, 7.0, 8.0, 9.0, 10.0, 11.0 and 12.0 as it did not mean only Firefox 3.6.x and 12.0 will work as "To" should have been in place of the "and".

philipp
  • Top 10 Contributor
  • Moderator
2046 solutions 8905 answers

hello, the current wording of the article is correct, since there have been two parallel branches of firefox (firefox 3.6.* and firefox 4.* and upwards) available at the time the article was written.

i will also close this thread, since it is misplaced in the general firefox support forum. for such kind of input, please click on "discussion" under editing tools on the left next to an affected article. thank you!